1. bill51's Avatar
    I have an 8330. I thought you could charge it with a USB Cable. When I tried it didn't show the little plug symbol on my screen and a window came up on my PC asking to insert the CD that came with my device. A friend of mine has an 8300 and he has no problem charging it from his PC.

    02-25-10 01:20 PM
  2. sedalia066's Avatar
    My 9000 will not charge on one USB port at work. Try another port or a different computer. Maybe the port you tried does not provide enough power for charging.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-25-10 01:31 PM
  3. coolguy78240's Avatar
    I know that i have this issue if i try to charge my phone off of my laptop it does work with my pc tho.
    02-25-10 03:25 PM
  4. CanuckBB's Avatar
    Make sure you connect to the PC, not a hub.

    PCs will not charge if the correct drivers are not installed.
    02-25-10 03:29 PM
  5. JuiceBerryBlack's Avatar
    I'd try a diffrent pc . My laptop will not charge eaither my curve or tour it don't charge my ipod eather. But my desktop does..

    Posted from my CrackBerry at wapforums.crackberry.com
    02-25-10 04:02 PM
  6. snowindec9's Avatar
    yep, sometimes labtops don't charge devices very well. they work with desktops however. once i tried charging my ipod on my mac with an usb and it didn't charged. then i just used my ipod power station to charge it. i really don't think charging devices with usb ports is the safest way to go. you never know when they may cause battery damage.
    02-25-10 05:46 PM
  7. usernam9102's Avatar
    I have M1530 Dell Latop works great for charging my storm
    02-25-10 05:55 PM