1. dhaliwal06's Avatar
    Hi guys,

    I just bought a charging pod for my Bold 9000 and when I hooked it up, my berry wouldn't charge. The pod's light would light up when I connected the charging cable to the back, but when I dock my bold, it doesn't charge. It doesn't enter bedside mode and the charging battery icon isn't on. What could be the problem?

    I replaced the chrome bezel with a black one that I bought from DealsIShop.com, so could it be the bezel?

    Any advice is appreciated.
    06-30-10 09:50 PM
  2. grunt0300's Avatar
    Hi guys,

    I just bought a charging pod for my Bold 9000 and when I hooked it up, my berry wouldn't charge. The pod's light would light up when I connected the charging cable to the back, but when I dock my bold, it doesn't charge. It doesn't enter bedside mode and the charging battery icon isn't on. What could be the problem?

    I replaced the chrome bezel with a black one that I bought from DealsIShop.com, so could it be the bezel?

    Any advice is appreciated.
    If the charging pins on either side of the phone are black, that's your problem. The black pins do not conduct electricity. Replace them with the original chrome ones. Don't worry, the phone will still look cool. Good luck !
    06-30-10 10:07 PM
  3. bpgui's Avatar
    I replaced the chrome bezel with a black one that I bought from DealsIShop.com, so could it be the bezel?
    That is most likely the problem. When you did it, you probably didn't connect the charging "nodes" up properly to the main board with the little copper sticky connecting film (I think that is the technical term for them ).

    I did the exact same thing when I replaced my bezel.
    06-30-10 10:12 PM
  4. dhaliwal06's Avatar
    That is most likely the problem. When you did it, you probably didn't connect the charging "nodes" up properly to the main board with the little copper sticky connecting film (I think that is the technical term for them ).
    That might be the case. Although, I'm not too good with opening and tampering with a Blackberry.

    If the charging pins on either side of the phone are black, that's your problem. The black pins do not conduct electricity. Replace them with the original chrome ones. Don't worry, the phone will still look cool. Good luck !
    Thanks, I guess it's back to the chrome
    06-30-10 11:33 PM
LINK TO POST COPIED TO CLIPBOARD