1. cantstoptherobots's Avatar
    i went to t mobiles website and clicked where its supposed to resend your myfavs back to your phone...but instead of getting my myfavs back (all i did was hide them once and they never came back) i got a " uncaught exception: java.lang.nullpointerexception"


    help?

    after this i think ill have all the kinks worked out of my new phone. thanks guys.
    03-01-09 08:49 PM
  2. JTurtle's Avatar
    Did you just have them resend your MyFaves or have them send the UI? Just asking because I had the same issue twice now and found that having them send the UI fixes it.

    Go to wap.t-zones.com from your phone
    Click on "My Account" (at the top)
    Click on "MobileLife(sm)" (at the bottom)
    Click on "myFaves"
    Click on "Missing myFaves Interface"
    Click on "Turn on Faves UI"

    You can also do this on your desktop by going towww.my.t-mobile.com, logging in, and then going to Manage myFaves, myFaves Are Missing.
    03-01-09 11:33 PM
  3. cantstoptherobots's Avatar
    im still getting the same error
    03-01-09 11:48 PM
  4. cantstoptherobots's Avatar
    bump

    any ideas, im fresh out....
    03-02-09 06:22 PM
  5. DrzFyneztQt's Avatar
    i am having the same problem... Did anyone figure this out?!
    03-03-09 12:54 AM
  6. mywitheredeye's Avatar
    I had to call customer care today and was told that there systems were updating so I'm sure that has something to do with it...taking a look at this point my link is working just fine.
    03-03-09 01:29 AM
  7. PrincessDi's Avatar
    I've had this problem for over a month now...ever since I upgraded my OS.
    03-13-09 01:36 PM
  8. arickinreallife's Avatar
    i just had them send me the UI for myfaves and i get an icon in the menu that allows me to hide or show it on my main screen. think thats pretty cool because it does get annoying from time to time
    03-13-09 01:59 PM
  9. cantstoptherobots's Avatar
    i hid mine and they never came back lol. not a huge loss i suppose.
    03-13-09 02:03 PM
  10. exelant's Avatar
    You can try to go to their site, open myfavs and edit one of your contact's pictures or something simple like that and T-Mo will push your icons back to your device. That workd sometimes, but I once had to reload my OS to get them back.
    03-13-09 02:22 PM
  11. flobbit's Avatar
    I have only have my BB Curve for 2 weeks now and its great except for this odd MyFavs issue. I have an open ticket with T-Mobile because the person could not resolve it on the phone.

    I gave up on waiting for the call back and I reinstalled the OS, which fixed my problem. That is until I restored my DB from the backup I did last week. Took about 5 hours before I noticed the interface missing but its gone - again.

    I have about decided to not worry about it and just make sure I update any changes on my.t-mobile.com. It seems to me that the app on the phone is just a "convenience" feature not required to keep those calls off your minutes...

    --Will
    05-28-09 03:30 PM
  12. bthoefer's Avatar
    Are you hooked up to an exchange server (BES)? There is an issue with exchange causing the myfaves software to be deactivated on the phone. This also affects Google sync if you are using it. If you disconnect from exchange or uninstall Google sync and reset the phone the myfaves will reappear.

    I am not aware of a fix for this, you can use the tmobile website to edit your myfaves contacts.
    Last edited by bthoefer; 05-29-09 at 12:32 AM.
    05-29-09 12:30 AM
  13. android3k's Avatar
    I just switched to a MyFaves plan 3 days ago and updated everything but received no icons. My second line is the 8100 and got them immediately after we switched. I called Tmo and they said 24-48 hours. Tried the steps mentioned and just received 8 sms with symbols yet still no icons. Even set theme to default!
    05-29-09 12:52 AM
  14. Ikarus's Avatar
    Why does anybody still bother with this junk? There's enough evidence by now that it's severly broken. T-Mobile needs to fix it. Until then, just delete it or hide it and be done with it.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-29-09 01:18 AM
  15. g3kewl's Avatar
    Yeah tmo is full of jerks. Edit: nevermind that was too mean. Some of the tmo people are douches. Other than that they're ok haha

    Posted from my CrackBerry at wapforums.crackberry.com
    05-29-09 02:29 AM
  16. munan's Avatar
    You know, if you updated your OS, as you stated, to a version that isn't tested by TMobile, then it's not their problem. I've been using my 8900 on TMobile since I got it and it's just fine. I've never updated the OS beyond what it came with or was approved however. Just sayin...
    05-29-09 02:35 AM
  17. android3k's Avatar
    Why does anybody still bother with this junk? There's enough evidence by now that it's severly broken. T-Mobile needs to fix it. Until then, just delete it or hide it and be done with it.

    Posted from my CrackBerry at wapforums.crackberry.com
    Maybe reading comprehension is not your fortay. The problem is I would like to have the option of having those ugly circles, and have never had them.

    And stating that Tmo needs to fix it does not mean that it will be done in a timely manner. Although some may feel as your comment was superfluous, I appreciate your positive attempt at resolving our issue.
    05-29-09 02:46 PM
  18. bthoefer's Avatar
    If you have not ever had the my faves activate try going in to a local Tmobile corporate store, do not call in to customer care. There is a new tool available to retail reps to resend your myfaves activation and refresh your my faves contacts.
    If you are getting the java error when you refresh or change your faves from tmobile.com then this will not help.
    05-29-09 09:28 PM
  19. android3k's Avatar
    If you have not ever had the my faves activate try going in to a local Tmobile corporate store, do not call in to customer care. There is a new tool available to retail reps to resend your myfaves activation and refresh your my faves contacts.
    If you are getting the java error when you refresh or change your faves from tmobile.com then this will not help.
    I appreciate you advice. I have resolved the issue by downgrading to .114 and then upgrading back. If you are having the issue consider the process.
    05-29-09 10:02 PM
  20. Darrell Hughes's Avatar
    My wife works for TMO and we had the same problem with my new 89. Thru customer service, after downloading latest software version, in Desktop Manager had to delete all apps and reboot phone. MyFaves were back. Just make sure you backup before doing so.
    05-31-09 12:53 AM
LINK TO POST COPIED TO CLIPBOARD