1. BlackReef's Avatar
    I am putting the black frontplate on, and it seems I cant get all 4 tabs to snap into place together. I can get the two tabs on one side snapped in place but I cant get the other...if I get the other side snapped in, the opposite side comes loose...its driving me nuts!

    Edit: Specifically, I cant get the left side of the case on. Every time it 'snaps' into place, the rubber side strip pops out


    suggestions?

    Thanks
    Last edited by BlackReef; 02-06-09 at 11:21 PM.
    02-06-09 11:16 PM
  2. xliderider's Avatar
    Some have mentioned that the foam sealing material behind the lens on the front faceplate is thicker than the OEM original faceplate. If this is the case, it could be causing your problems.
    02-06-09 11:19 PM
  3. BlackReef's Avatar
    wait - i think i fixed it..

    there was a tab on the rubber strip that was bent flat, keeping it from closing all the way
    02-06-09 11:24 PM
  4. xliderider's Avatar
    Glad you got it squared away.

    Post pics in the Black Housing thread (search).
    02-06-09 11:27 PM
  5. BlackReef's Avatar
    eh - Im going to put the old case back on. the fit and finish is off - there are some slight gaps on the top of the phone. It is also more difficult now to use my track ball, as the skin seems to sit a bit higher (maybe because of the foam)?

    damn
    02-06-09 11:37 PM
  6. xliderider's Avatar
    My black housing didn't have the foam gasket. An option would be for you to remove the gasket and reinstall the faceplate, but the phone might be more prone to get dust between the lens and LCD.
    02-06-09 11:41 PM
LINK TO POST COPIED TO CLIPBOARD