1. koanaihe's Avatar
    I have a boostberry 8350i and just recently anything I plug in (charger or sync cable) will not be recognized by my phone so I can't charge or sync. I am guessing the inlet separated from the motherboard. Does anyone have any suggestions on diy fixes? Please keep in mind it is a boostberry so I have no warranty on it as I bought it off of ebay. I just recently updated it to the latest firmware last week. So taking it apart would be no problem. Thanx!
    04-26-09 01:53 AM
  2. BergerKing's Avatar
    I would order a charging unit and a spare battery from eBay or Amazon until you can get a repair job done.

    The only shop I know of that repairs them is BBrepairshop, you can Google them, and you're looking at about $80 for repair.

    You can also order the OEM charging pod for about $10 from Amazon.
    04-26-09 02:30 AM
  3. koanaihe's Avatar
    Would anyone happen to know if sprint repair centers can handle this?
    04-26-09 07:34 AM
  4. marctronixx's Avatar
    i had that happen to my first 8350i (i am on #3) and it is not something a sprint store will or CAN fix.
    04-26-09 08:09 AM
  5. BretR574's Avatar
    Did you look closely at the pins on the USB port? I had a similar problem with my 8350i. My phone wouldn't connect via USB. It turned out that one of the pins on the connector was pushed aside. I used a sewing needle to push it back into its slot. Works fine now. I did buy a charging pod off e-bay so that I don't have to keep plugging the usb cable in daily. I only use the cable when I need to connect to my pc and that's not very often.
    04-26-09 08:12 AM
  6. davidc2's Avatar
    I had the same exact problem with mine, the Sprint store replaced the phone.
    04-26-09 09:01 AM
  7. koanaihe's Avatar
    I was checking out the pod charger, does it also sync using the two prongs in the pod. Or will I still have to hook it up to the usb data port on the top left of the phone? Thank you all, you have been very helpful.
    04-26-09 07:04 PM
  8. justlovejoy's Avatar
    Sprint Repair Centers charge about $ 55 depending on what they think needs to be repaired!

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-09 09:07 PM
  9. BretR574's Avatar
    The pod cradle I have does not sync. It is simply a charging pod. I think it's the same one you're speaking of.
    04-26-09 09:28 PM
  10. speedtrip's Avatar
    Isn't that the same problems they had whan the 8350 first came on the market ? The charging ports were bad ?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-27-09 11:22 AM
LINK TO POST COPIED TO CLIPBOARD