1. Grebnehtor's Avatar
    The charging symbol shows up but the phone itself won't charge. It was on the car charger for 2 o
    Hours and gained no power. Ideas?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 11:43 AM
  2. bt224's Avatar
    Might not be getting enough juice to overcome usage. Could be a bad charger, lower voltage lighter socket, bad miniUSB, etc etc.
    05-21-09 11:45 AM
  3. Grebnehtor's Avatar
    I know the cars voltage is fine and I know the mini usb port on the phone is good. I'm leaning towards a bad charger.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 12:23 PM
  4. mahalo182's Avatar
    The old curve car chargers wont work with the bold. If it is one where you can see the # on the fuze, it needs to be a 3 not a 2. I had that problem.
    05-21-09 12:29 PM
  5. Grebnehtor's Avatar
    I will look at the charger when I get back to my truck. My Bold died and I'm posting from my brothers iPhone.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 12:47 PM
  6. bt224's Avatar
    I will look at the charger when I get back to my truck. My Bold died and I'm posting from my brothers iPhone.

    Posted from my CrackBerry at wapforums.crackberry.com
    Ouch, that just hurts to read. The irony is overwhelming.
    05-21-09 12:48 PM
  7. laollis's Avatar
    Sounds like bad charger to me.
    Yikes...iphone. LOL
    05-21-09 12:55 PM
  8. Grebnehtor's Avatar
    I'll be running to the ATT store shortly. I just got my Bold 2 weeks ago after spending 2 years with an iPhone so it's no big deal.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 01:08 PM
  9. bt224's Avatar
    I'll be running to the ATT store shortly. I just got my Bold 2 weeks ago after spending 2 years with an iPhone so it's no big deal.

    Posted from my CrackBerry at wapforums.crackberry.com
    Was the phone being used at all while on the charger? In 2 hours, the battery should have dropped if it was getting no juice.
    05-21-09 01:10 PM
  10. Username00089's Avatar
    No wonder why when I charge my phone with my old Motorola car charger my phone doesn't charge that much.
    05-21-09 01:20 PM
  11. Grebnehtor's Avatar
    The phone was used very little on the charger. I am gong to try a new charger.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 01:46 PM
  12. dallgirl's Avatar
    Just bought a Bold. Told that I needed the Bold charger because even though the Razr car charger fit, it has "blown up the Bold battery" according to my At&T store guy. Supposedly not compatible. He said it might happen or not. Anyone heard of this? Is he just trying to get me to not return the charger?
    06-18-09 12:08 PM
  13. bt224's Avatar
    Just bought a Bold. Told that I needed the Bold charger because even though the Razr car charger fit, it has "blown up the Bold battery" according to my At&T store guy. Supposedly not compatible. He said it might happen or not. Anyone heard of this? Is he just trying to get me to not return the charger?
    Absolute BS. Battery is self regulating and won't "blow up". I have been using my old Razr charger since November. I would also call out that rep, in a nice way of course.
    06-18-09 12:15 PM
  14. rush0's Avatar
    Im probably just superstitious, but I never trust car chargers.
    06-18-09 04:22 PM
LINK TO POST COPIED TO CLIPBOARD