1. astr0boy's Avatar
    I used to be able to charge my phone through the USB cable. I think I've reached a full charge on it once with the USB cable. I have all the drivers installed. Now it no longer charges with the USB cable. Does anyone know why? Is my phone defective?
    01-19-10 10:57 AM
  2. mofoahh's Avatar
    try charging it thru ac power and see if that works. If it does then try a different usb cable, then different usb ports, different computers.
    01-19-10 11:03 AM
  3. astr0boy's Avatar
    Same. Through the wall and through the computer. It indicates that its charging (lightning bolt) and the LED is on, but it doesnt ever go above 50% for some reason.
    01-19-10 11:07 AM
  4. smokin2thenub's Avatar
    If you by chance are running OS 5, make sure that your Mass storage is turned on.
    01-19-10 12:30 PM
  5. rbrown686's Avatar
    I have done all the suggested setup issues, already done, and it some times works and sometimes not. I even plugged it in to a desktop computer with drivers installed and it would not charge. Moved it back to my laptop via the docking station USB Port and it is now charging. There is something strange here. Only things that works if you are desperate for a charge is to power off and it charges great. My guess is that the Blackberry (Storm 2) charging control circuit is limiting the charging current to just maintain voltage on the USB jack, sometimes.
    01-19-10 03:45 PM
  6. boomerbsg's Avatar
    How long did you leave it plugged into the port. Mine charges but very slowly compared to the wall adapter/car charger.

    01-19-10 05:02 PM
  7. that_maynard's Avatar
    I have had the same problem, I thought it would be great, I can have my wall charger for home and the USB for work cuz I'm on the computer all day. I have tried different ports, different computers and left it plugged in for at least 40 minutes in each time. ????
    01-19-10 05:11 PM
  8. astr0boy's Avatar
    How long did you leave it plugged into the port. Mine charges but very slowly compared to the wall adapter/car charger.

    Overnight at least hours and it never goes past 50%.
    01-20-10 12:13 AM
  9. boomerbsg's Avatar
    What os are you running on your phone? On 4.7 for me, it was really slow. My usb charging improved a little with 5.0.230, and now with the leaked .419 it seems about as good as my curve was.

    But that being said mine never halted at 50%.

    01-20-10 02:58 AM
  10. astr0boy's Avatar
    4.7? I dunno. It charges through the wall. But when plugged in USB it does not charge for some reason. its really frustrating. I just need to know if its a defect or not that I could take the phone back to get it exchanged.
    01-20-10 05:01 AM
  11. xraytid's Avatar
    I had the same problem with 5.0 on my tour. Its just a ******** defect in the OS is my guess but if you do a battery pull then connect it to your laptop it should charge but it chargers at about 30% of the A/C speed

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-10 05:18 AM
  12. smokin2thenub's Avatar
    Are you using OEM cables or aftermarket?
    01-21-10 11:23 AM