1. Phone_Chemist's Avatar
    I am having problems with battery chargers and would appreciate any help. The wall charger that came with the Storm and the sync cable work perfectly. But, a purchased Verizon Storm car charger, a purchased wall charger and two chargers I already own that have the same specs as the charger that came with the Storm do not work.

    The chargers that do not work all show the same behavior. When first plugged in the Storm displays the familiar full screen clock. But, after about 10 seconds the clock disappears and nothing else happens. No charging occurs. This behavior has occurred on all operating systems I have used (.75, .113 and .132).

    Thanks in advance.
    05-15-09 07:15 PM
  2. jbloggs2002's Avatar
    I purchased a cheap 3rd party wall & car charger, and neither worked - you just have to buy the good stuff (and return the Verizon one you bought)
    05-15-09 08:13 PM
  3. Phone_Chemist's Avatar
    I agree. Sometimes, the cheap stuff does not work, and I am returning the two purchased chargers as you suggest. But, in my case 4 of 4 chargers that did not come with the phone failed, even though all met the electrical specifications of the OEM chargers. This could not happen by chance. Does the Storm have some requirement of chargers that is not obvious? In the recent past, most phones had unique connectors to force you to buy the OEM chargers. At least you knew this up front. The Storm has a generic charge connection, but it fails to work with a lot of chargers (at least mine does). What is going on?
    05-15-09 08:36 PM
  4. tyler.hopkins's Avatar
    I think you may have a problem with the port...but first...when its plugged in does it have the little lightning bolt on the battery meter or no? I bought a cheap micro usb wall charger from wal mart and have near had any problems charging.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-15-09 08:57 PM
  5. Phone_Chemist's Avatar
    If I check the battery icon in the first few seconds after plugging in the charger, it shows the lightning bolt. But this disappears quickly, and the charging stops. Weird.
    05-15-09 09:03 PM
  6. tyler.hopkins's Avatar
    Strange.....I would def. Take them back and either keep trying diff. Ones or have the phone replaced. But like I mentioned earlier I picked one up from wally world for $15 and it works like a champ. I do miss my old one (left it in louisiana when we went to coushatta) bc it had the diff. Prongs for overseas use.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-15-09 09:09 PM
  7. my_2_cents's Avatar
    This has been a well known issue. All BB's have issues with non BB chargers. I have a motorola charger for my bluetooth that works with my storm, but most non-RIM chargers don't work. I suspect RIM found a way to make this the case, but I don't know how they would do so, and there is no way to prove it.

    The solution is to buy RIM only for the moment. In my personal case motorola also seems to work, so if they're cheaper you could test their chargers.
    05-15-09 09:13 PM
  8. Phone_Chemist's Avatar
    Thanks for all the feedback. Guess I will just try some RIM chargers to see if they work. Failing that, I will replace the Storm.
    05-15-09 09:23 PM
  9. cadzilla74's Avatar
    I share a Palm Micro-USB charger with a buddy at work. It is 5 volts ... the BB AC charger is rated at 700 milliamps, the Palm at 1000 milliamps. I have no trouble charging my Storm with either one and the 12 vdc charger I got at the Verizon store works great with my Storm in the car as well. Sounds like your Storm is a little finicky ... might be trouble with your charging port.
    05-16-09 12:31 AM
LINK TO POST COPIED TO CLIPBOARD