07-13-15 09:03 PM
123 ... 345
tools
  1. MajorNess's Avatar
    I just got MMS on my Z10 working on Straight Talk. Here are my settings:

    APN: tfdata
    MMSC URL: http://mms-tf.net
    Proxy URL: 66.209.11.33:80

    Software Release: 10.2.1.2179
    OS Version: 10.2.1.2273

    My Z10 is an unlocked T-mobile phone but I'm using an AT&T Straight Talk SIM, so I'm on AT&T's network.
    05-16-14 05:16 PM
  2. jrdba's Avatar
    Your welcome and glad I could help!

    Posted via CB10
    Hi George. A few months ago i lost my ability to send/receive MMS via my AT&T z10 (now unlocked for awhile). I never bothered to get it fixed due to the fact that i mostly use email to send pictures, but now i'm getting sent MMS via work colleagues and need to get this fixed. Unfortunately i'm not seeing the MMSC URL setting in text|mms|advanced section (can't scroll down for additional options). My OS version is 10.2.1.1925 (via Telus sim card). I tried the following solution linked below by removing my RedPocket SIM card, but no cigar. Please advise...thank you

    http://forums.crackberry.com/blackbe...unning-893863/
    05-17-14 02:31 PM
  3. Tom R W's Avatar
    Thanks to jrdba and djsvetljo and all the others who created this stream. I now can access the internet from my Blackberry Q5 running BB10. I could not find the screen to enter the 'tfdata' and the other necessary values, but thanks to jrdba and djsvetljo, I was able to find the screen and enter the values.
    06-29-14 10:16 AM
  4. Todd Case's Avatar
    I just got MMS on my Z10 working on Straight Talk. Here are my settings:

    APN: tfdata
    MMSC URL: http://mms-tf.net
    Proxy URL: 66.209.11.33:80

    Software Release: 10.2.1.2179
    OS Version: 10.2.1.2273

    My Z10 is an unlocked T-mobile phone but I'm using an AT&T Straight Talk SIM, so I'm on AT&T's network.


    hi majorness...i have a at&t z10 with an old at&t st card and i can get texting and calling but no mms i put in the settings you said an still nothing... my software release an os versions are the same as what you stated any suggestions to help me out?
    07-13-14 10:31 AM
  5. Todd Case's Avatar
    Data policy changed on Net10 recently (also now at 2.5gb)

    my APN set up is tfdata. This has been the same since my last phone (Samsung Galaxy, loaded in in July 2012).

    I am aware mms2/mms3 and other settings can vary slightly (I know you don't know what level of brainz someone has, but please, don't condescend. I have more than a wee bit of telecom knowledge)

    So far, no MMS... if I can't send a text picture, so be it... I got the whole of the internet to send it through plus emails... just trying to get to gravy.

    hi paisley pirate... been reading threw the blogs an seen that you figured out your problem with your z10 i jus got one an security whipped it an reset it it is stl100-3 running 10.2.1.2179 an i used both apn settings tfdata and att.mvno and i have calling an texting still no mms i have the old att straight talk sim card...idk where to go from here ive been looking for a solution for days an still nothing works...any suggestions for me? plz and thank you!!
    07-13-14 10:35 AM
  6. Paisley Pirate's Avatar
    hi paisley pirate... been reading threw the blogs an seen that you figured out your problem with your z10 i jus got one an security whipped it an reset it it is stl100-3 running 10.2.1.2179 an i used both apn settings tfdata and att.mvno and i have calling an texting still no mms i have the old att straight talk sim card...idk where to go from here ive been looking for a solution for days an still nothing works...any suggestions for me? plz and thank you!!
    Hi Todd,
    Which carrier are you using? (ST? Net10? TF? or ATT?)

    I am running Net10 (and I *think* this holds true for TF and ST as well) - I go to the Hub / Text Messages / lower right 3 dots / Settings / Text Messages / Advanced /

    (whew)

    In that screen - towards the bottom? MMSC URL should be http : // mms-tf . net (remove the spaces)

    PROXY URL should be mms2 . tracfone . com : 80 (again, remove spaces)

    leave the proxy user and pass blank. Also make sure that the APN user and pass are blank.

    I'm not running 2179, I jumped to 3.0.700 - but I know this was the same set up all along.
    07-13-14 12:48 PM
  7. Todd Case's Avatar
    Hi Todd,
    Which carrier are you using? (ST? Net10? TF? or ATT?)

    I am running Net10 (and I *think* this holds true for TF and ST as well) - I go to the Hub / Text Messages / lower right 3 dots / Settings / Text Messages / Advanced /

    (whew)

    In that screen - towards the bottom? MMSC URL should be http : // mms-tf . net (remove the spaces)

    PROXY URL should be mms2 . tracfone . com : 80 (again, remove spaces)

    leave the proxy user and pass blank. Also make sure that the APN user and pass are blank.

    I'm not running 2179, I jumped to 3.0.700 - but I know this was the same set up all along.


    im using straight talk at&t ive had my sim card for a lil over a yr so its the older sim card....i set everything up the way you said and i have tfdata as my apn an still cant send mms i even tryd putting 66.209.11.33:80 like majorness did an still didnt work and i also tried att.mvno as my apn
    07-13-14 12:56 PM
  8. Paisley Pirate's Avatar
    Do you have internet otherwise? IF SO - your APN is fine (APN is your internet access point)

    IF your internet is working, then the MMS access (proxy) that is the issue.


    mms2 . tracfone . com OR mms3 . tracfone . com in the MMS Proxy settings.




    In that screen - towards the bottom? MMSC URL should be http : // mms-tf . net (remove the spaces)

    PROXY URL should be mms2 . tracfone . com : 80 (again, remove spaces)
    Double check this again, too. Again, (technically) yours on ST should be mms3 - not 2, but some people have had 2 work, and some others using the IPv4 address (like majorness did)

    The other thing you might try is this page: How To Update Data Settings | StraightTalk Wireless if you haven't already done so (if you have, sorry, honestly trying to help)

    EDIT : Reason why to check with ST directly - there may be a bug in your SIM that isn't allowing you to go MMS - ST/TF/N10 have occasionally sent out new sims to correct this issue (come to find out from a friend who is an iFruit tech) soooo - maaaaybbeeeee it isn't just us! LOL!
    Last edited by Paisley Pirate; 07-13-14 at 01:24 PM. Reason: clarity
    07-13-14 01:20 PM
  9. Todd Case's Avatar
    Do you have internet otherwise? IF SO - your APN is fine (APN is your internet access point)

    IF your internet is working, then the MMS access (proxy) that is the issue.


    i have wifi but if i turn it off i have no internet it jus says h and the signal bars

    mms2 . tracfone . com OR mms3 . tracfone . com in the MMS Proxy settings.






    Double check this again, too. Again, (technically) yours on ST should be mms3 - not 2, but some people have had 2 work, and some others using the IPv4 address (like majorness did)

    The other thing you might try is this page: How To Update Data Settings | StraightTalk Wireless if you haven't already done so (if you have, sorry, honestly trying to help)

    EDIT : Reason why to check with ST directly - there may be a bug in your SIM that isn't allowing you to go MMS - ST/TF/N10 have occasionally sent out new sims to correct this issue (come to find out from a friend who is an iFruit tech) soooo - maaaaybbeeeee it isn't just us! LOL!
    07-13-14 01:25 PM
  10. Todd Case's Avatar
    Do you have internet otherwise? IF SO - your APN is fine (APN is your internet access point)

    IF your internet is working, then the MMS access (proxy) that is the issue.


    mms2 . tracfone . com OR mms3 . tracfone . com in the MMS Proxy settings.






    Double check this again, too. Again, (technically) yours on ST should be mms3 - not 2, but some people have had 2 work, and some others using the IPv4 address (like majorness did)

    The other thing you might try is this page: How To Update Data Settings | StraightTalk Wireless if you haven't already done so (if you have, sorry, honestly trying to help)

    EDIT : Reason why to check with ST directly - there may be a bug in your SIM that isn't allowing you to go MMS - ST/TF/N10 have occasionally sent out new sims to correct this issue (come to find out from a friend who is an iFruit tech) soooo - maaaaybbeeeee it isn't just us! LOL!
    ok so i went an put my number in the web site you told me to it said to put att.mvno for apn and mms apn and http://mmsc.cingular.com for the mmsc and 66.209.11.33 for the mms proxy and 80 for the mms port....so i added the port number after the proxy like i was supposed to and it still didnt work...the only thing that changed is i had a little h an signal bars and now i have H an signal bars...ok so im not really smart when it comes to stuff like this lol but it says the mobile network is home i guess thats what the h is for...i also went into my moblie network and under available networks it says home-voice/data....and also the net is working jus not the mms
    Last edited by Todd Case; 07-13-14 at 02:11 PM.
    07-13-14 01:37 PM
  11. Tonymcc2's Avatar
    BBz10 STL100-1 in USA
    After a couple months relentlessly going through allll the forums avalilable on the topic trying to get my data and mms working on Straight Talk,
    I finally got it done...
    Installed Software Release 10.2.1.2156 -- OS versuib 10.2.1.2228 ....and....VOILA!!!
    It all works!!!
    Downloaded this file...
    Used BBLink to backup everything then downloading this file :
    Z10_10.2.01.2228_STL100-1
    Its a 7z file...(7zip to extract)
    Removed Straight Talk/ATT sim
    hooked phone to computer and executed the unzipped file.
    Took about 30 minutes for it to massage the phone then restarted.
    Opended BBLink and reinstalled contacts, apps, etc.
    shutdown phone.
    Put ST/ATT sim back in...
    restated and HALLELUJAH it works!!!!
    had to reinstall some apps that didnt make it
    but no biggy...
    Just pleased as punch that my Berry is now even more awesome!!!

    Tony
    Z10 STL 100-1 USA
    09-01-14 09:18 AM
  12. VictoriaPa1's Avatar
    Thank you for the heads up!
    09-18-14 04:55 AM
  13. knibbeone's Avatar
    Many Thanks, I could not get it to work. Then i did a battery pull and walla! MMS all 20 test pics at once.
    10-08-14 01:20 PM
  14. crailey01's Avatar
    I have an STA100-3 for Verizon with unlocked GSM. I am using a ST(Atnt) SIM. I tried upgrading to one of the new 10.3.1 leaks. Every time I change my APN to tfdata in the Advanced MMS/SMS settings....it resets itself back to vzwapp....therefore it will not send or receive MMS. Has anyone ran into this issue before and is there a fix in escreen:// for it?! Thanks!

    Posted via CB10
    11-01-14 01:16 PM
  15. edhgreatone's Avatar
    Wow wow wow...

    Finally got mine working on my BlackBerry Classic!!

    APN: tfdata
    MMSC URL: http://mms-tf.net
    Proxy URL: 66.209.11.33:80

    You MUST reboot device... I even tried to flick data on and off it doesn't work... must fully reboot
    12-19-14 11:50 PM
  16. EastonAtkins's Avatar
    Very Helpful
    12-24-14 01:00 AM
  17. Marcus Collier's Avatar
    My fianc is wanting a Q10 (because she loves mine) but she NEEDS to have it use verizon cdma towers because of where she lives. I can find an unlocked verizon Q10 no problem, but I'm concerned that she won't be able to use it on straight talk. The ppl I see here discussing an unlocked verizon q10 are talking about using the gsm att Sims but that is not really an option for my fianc. So has anyone here used to an unlocked verizon Q10 on ST using the CDMA towers and NOT the gsm towers?

    Posted via CB10
    12-25-14 10:35 PM
  18. Marcus Collier's Avatar
    So I take it no one can help me with this issue lol

    Posted via CB10
    01-04-15 03:34 AM
  19. WaveGod's Avatar
    Does anybody with an AT&T sim have group messages working correctly?

    Posted via CB10
    01-07-15 09:29 AM
  20. VeryBumpy's Avatar
    Wow wow wow...

    Finally got mine working on my BlackBerry Classic!!

    APN: tfdata
    MMSC URL: http://mms-tf.net
    Proxy URL: 66.209.11.33:80

    You MUST reboot device... I even tried to flick data on and off it doesn't work... must fully reboot
    This worked for me too!! [Jan 15 2015 Milwaukee, Wi just for reference. ]
    01-15-15 08:12 PM
  21. secretsanta's Avatar
    My fianc ...NEEDS to have it use verizon cdma towers ...So has anyone here used to an unlocked verizon Q10 on ST using the CDMA towers and NOT the gsm towers?

    Posted via CB10
    It is possible to use StraightTalk with a Verizon CDMA phone.

    The Bring-Your-Own-Phone (BYOP) Activation Kit which you can buy at Wal-Mart for ~$60 includes:

    1. Verizon CDMA Network Access Code and instructions
    2. AT&T Network SIM cards (nano, micro, mini)
    3. T-Mobile Network SIM cards (nano, micro, mini)
    4. $45 unlimited everything 1st month activation card

    Here are two suggestions to completely answer your question(s):

    A-1. Go to www straighttalk com / wps / portal / home / support / contactus
    A-2. Click on the LIVE HELP graphic on the right.
    A-3. Chat with a representative, they are VERY good and USA-based

    **I advise you DO NOT tell the representative that this is for a Blackberry. It is highly doubtful that they are aware BBs with v10 OS don't require BIS activation. Pretend your phone is an Android during the discussion**

    afterwards, visit your local Wal-Mart Electronics Dept. Find the isle with the massive green-themed StraightTalk area.

    B-1. **WITH THE HELP OF A WAL-MART ELECTRONICS DEPT. EMPLOYEE OR MANAGER,** open up one of these kits PRIOR TO PURCHASE (refunds will not be permitted for these because of their one-time-use nature)
    B-2. Make sure the contents with their provided information ANSWER YOUR QUESTION PRECISELY


    --Typed on the spectacular BlackBerry Passport via StraightTalk GSM 4G LTE
    02-21-15 09:06 PM
  22. Chicchan's Avatar
    Thank you so much for this information! Straight Talk could only tell me that they are not compatible with Blackberry and that only phone and text could be utilized (****Major Disappointment****) until I decided to do another web search on the issue and your forum info was first in line for me to check out and YES it worked!!!! Love you so much & thanks for resolving this issue!

    I will share this on other forums that had little info on the matter.
    Last edited by Chicchan; 03-03-15 at 08:58 AM. Reason: Wrong Words Typed
    03-03-15 08:57 AM
  23. punkchain's Avatar
    Thank you thank you thank you.

    I so appreciate this post. I have a blackberry passport, which i bought the day it came out and I love my phone. After an update from blackberry I think in the year 2015 I have been unable to receive/send picture messages. My phone is through Straight Talk. It's been very frustrating for me. Some of my coworkers feel I am a technical expert but when I compare myself to others in the computer science field I am more intermediate. Anyways I have restarted my phone ten times, lost my contacts the last time, researched and researched what it could be. I practically have pulled my hair out. After just a simple addition of the port number it worked for me. I also made sure there was no spaces in the URL.

    Thank you for your post.
    Suzette
    07-13-15 09:03 PM
123 ... 345

Similar Threads

  1. Can you pick what to restore ?
    By urbnimports in forum BlackBerry Z10
    Replies: 6
    Last Post: 08-06-13, 04:06 PM
  2. unable to pair pb with z10 on 10.2
    By sweb in forum BlackBerry PlayBook
    Replies: 6
    Last Post: 08-06-13, 01:52 PM
  3. Order and Chaos Working with New Runtime?
    By webdave in forum BB10 Android App Sideloading
    Replies: 3
    Last Post: 08-06-13, 12:14 PM
  4. Skype doesn't work for 1047 leaked OS
    By djsvetljo in forum BB10 Leaked/Beta OS
    Replies: 12
    Last Post: 08-06-13, 12:12 PM
  5. .Zip Files on Z10
    By TheQuietRioter in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 08-06-13, 08:24 AM
LINK TO POST COPIED TO CLIPBOARD