1. skoubidoufr's Avatar
    Hi Folks,
    I have a Z10 STL100-3 that I would like to upgrade to 10.2
    When I got it it was containing a 10.0.9.2372, I then tried several methods to upgrade it (with autoloaders, with sachesi), but I'm always blocked at the same point: the downloading process is fine and goes to the end, but when the phone is supposed to reboot it does not (I have then tried everything, waiting for a complete night, removing the battery, keep power button press during more than 10 seconds, but the result is the same, when I'm there I need to reload a new OS - the BB logo even does not appear).

    The only OS I have managed to load is a 10.0.10.972 (with an autoloader), in that case no issue the phone reboots properly (led switches from green to red, and after a couple of seconds the blackberry logo appear), while in the other case the led also switches from green to red but nothing more happens.
    Any idea?
    11-06-13 05:48 AM
  2. jaydee5799's Avatar
    Hi! Welcome to CB!
    This sounds like a hardware issue to me. Who is your carrier?
    11-06-13 06:17 AM
  3. berryabusr88's Avatar
    I would maybe try to re download your preferred autoloader. Maybe the download was corrupted. 10.2.0.1791 seems to be what everyone is using especially if you don't want the pin marks in the corners. What OS were you trying to install?

    Posted via CB10
    11-06-13 07:28 AM
  4. skoubidoufr's Avatar
    To answer to the 2 preceding questions:
    - this device is not linked to any carrier (there is even no SIM yet inserted)
    - I also did tried with 10.2.0.1791
    11-06-13 08:31 AM
  5. thurask's Avatar
    Have you tried any autoloaders besides 10.2.0.1791? You could try updating to an earlier version first.

    Posted via CB10
    11-06-13 08:36 AM
  6. BlackBerry Owner 1's Avatar
    Find a 10.1 release and then upgrade to 10.2...maybe incremental steps to upgrading would help.

    If not than try resetting the phone to factory defaults and then try to upgrade.

    If that doesn't work than insert a sim card and try to upgrade to your carriers latest OS and then try to upgrade using an autoloader after that.

    Posted via CB10
    rjkolo likes this.
    11-06-13 08:46 AM
  7. skoubidoufr's Avatar
    Yep I tried with a 10.1 release, same issue.
    What do you mean by resetting the phone to factory defaults, a security wipe?
    11-06-13 09:04 AM
  8. thurask's Avatar
    Yep I tried with a 10.1 release, same issue.
    What do you mean by resetting the phone to factory defaults, a security wipe?
    Was it a 10.1 or a 10.1 MR release?

    And if you wipe the phone clean with a security wipe and try to update, does the problem persist?

    Posted via CB10
    11-06-13 09:07 AM
  9. Uzi's Avatar
    are you sure it is not dev alpha a?

    CB10 need update!
    11-06-13 09:12 AM
  10. berryabusr88's Avatar
    That was my next question. Dev alpha A cant be updated can it??
    11-06-13 01:18 PM
  11. skoubidoufr's Avatar
    Guys thanks for your support, so quickly:
    - No it's not an alpha device, it's a lisbon
    - I did a wipe + install 10.2.b1791 ==> same issue no reboot
    - concerning the 10.1, it was 10.1.b1092

    May be a dummy question, but is it possible to update the bootloader? (or at least now what version I have)
    11-06-13 01:55 PM
  12. thurask's Avatar
    Guys thanks for your support, so quickly:
    - No it's not an alpha device, it's a lisbon
    - I did a wipe + install 10.2.b1791 ==> same issue no reboot
    - concerning the 10.1, it was 10.1.b1092

    May be a dummy question, but is it possible to update the bootloader? (or at least now what version I have)
    1092? I don't think that was an actual version of 10.1. You could try 10.1.0.1483/STL100-3, that's the earliest version available to install (10.1 MR and 10.2 blacklisted 10.0 for security reasons). http://l.bitcasa.com/ulYnOu7W

    And as for learning nitty gritty device details, there's cap info, which you can use with cap.exe.
    11-06-13 02:10 PM
  13. skoubidoufr's Avatar
    Thanks, I will try with the 10.1.0.1483/STL100-3
    For information I just found something similar to my issue here:
    BlackBerry Z10 Developer handset, broken after upd... - Page 3 - BlackBerry Support Community Forums
    (knowing that my device also had a not for sale label on the back)
    The conclusion of this thread is that "It seems to be that some STL100-3 has a 10.0 upgrade limit", could it be true?
    11-06-13 02:29 PM
  14. thurask's Avatar
    (knowing that my device also had a not for sale label on the back)
    Where'd you get it?

    I know some later 10.1 releases incorporated a PIN blocklist, I think those were for unreturned internal models...
    11-06-13 02:49 PM
  15. Gearheadaddy's Avatar
    When I first went to 10.2 from 10.1 I had to load a BlackBerry Developers os first and then my phone took the 10.2 fine. The download was from BlackBerry. The os # was 10.2.0.341. I still have a copy if you need it. I can upload it I think to my Dropbox. PM me...

    Trusted Member Genius
    11-06-13 03:25 PM
  16. thurask's Avatar
    When I first went to 10.2 from 10.1 I had to load a BlackBerry Developers os first and then my phone took the 10.2 fine. The download was from BlackBerry. The os # was 10.2.0.341. I still have a copy if you need it. I can upload it I think to my Dropbox. PM me...

    Trusted Member Genius
    I think that was because 10.2.0.483 was missing a radio.
    11-06-13 03:29 PM
  17. Gearheadaddy's Avatar
    I think that was because 10.2.0.483 was missing a radio.
    Nope, it was because we couldn't load a 10.2 from 10.1 until you loaded the developer os from BlackBerry to enable the upgrade process ...thurask, how soon we forget...lol

    If he loads the developer os it will work...load dev and then immediately load the 10.2 of his choice over the dev os...worked for me way back when...


    Trusted Member Genius
    11-07-13 01:20 AM
  18. thurask's Avatar
    Nope, it was because we couldn't load a 10.2 from 10.1 until you loaded the developer os from BlackBerry to enable the upgrade process ...thurask, how soon we forget...lol

    If he loads the developer os it will work...load dev and then immediately load the 10.2 of his choice over the dev os...worked for me way back when...


    Trusted Member Genius
    Odd, I put 1791 on a just out of the box Q10 a few weeks ago without having to do anything extra. Didn?t even have the MR, that.

    483 was from a simpler time, back when autoloaders were magic black boxes that spit out 10.2.

    Anyway, the circumstances of the not for resale sticker on a non-Dev Alpha device are probably relevant to this.

    Posted via CB10
    11-07-13 08:38 AM
  19. skoubidoufr's Avatar
    Tried as suggested to load first a dev 10.1 os (1483), same my z10 does not reboot.
    Only way to resurrect it is to load a 10.0.
    Don't know if it can help but here is a log obtained with cap:
    Bootrom Version: 5.35.0.17
    Hardware ID: 0x8500240A RIM BlackBerry Device
    HW ID Override: 0x8500240A (OSTypes: 0x00000010)
    Hardware OS ID: 0x051D0001
    BR ID: 0xFF009000
    Build Date: Jun 26 2012
    Build Time: 16:24:04
    Build User: ec_agent
    Security: Disabled
    Boot OS Count: 8,0,0 (Region0,Region1,Max)

    HWV:
    Board Revision 0x01 - 0x0D
    CPU Version 0x02 - 0xB9
    SW Compatibility 0x03 - 0x01
    POP Revision 0x04 - 0x03
    Power Mgt Hardware 0x07 - 0x0D
    POP Security 0x0B - 0x02
    BSIS support 0x41 - 0x01
    NFC 0x49 - 0x08
    MFG DDR Traceability 0x4F - 0x05

    Flash:
    Number of chips: 1
    Total Size: 14912 MB

    DRAM:
    Size: 1024 MB
    VendorID: 0x6
    Vendor Name: Hynix
    Revision: 0x100

    Branding:
    ECID: 1

    OS Version: 10.0.10.672 DEV
    Build Date: Feb 19 2013
    Build Time: 02:42:36
    Build User: ec_agent
    STP Protocol Ver: 0.0.4 (release OS)


    Done.
    11-08-13 03:26 PM
  20. thurask's Avatar
    I did the same thing with my Z10 a while ago, here it is for comparison: cap - BerryLeaks

    According to this you have 1GB of RAM and your bootrom was built four months before mine (a launch-day model), which means that you've probably got your hands on a pre-release model. The Security:disabled in the first paragraph might have something to do with why you can't load any other operating systems.

    Here's an autoloader for 10.0.10.822, the final 10.0 release. See if that works.

    http://l.bitcasa.com/ZZ5akN7Q
    11-08-13 04:21 PM
  21. skoubidoufr's Avatar
    thanks thurask, 10.0.10.822 loads fine. I then tried with the first of 10.1 series (1483), unfortunately same issue as before, seems like this z10 will never go above 10.0 :-(
    11-09-13 02:33 AM
  22. Skyhi7142's Avatar
    Bootrom Version: 5.35.0.17 is an insecure bootrom and loads > 10.0.10.822 or so are blacklisted.

    Not sure how to get the latest bootrom (5.35.0.29) loaded though...

    I have the same problem.
    11-12-13 09:22 PM
  23. CarbonKevin's Avatar
    I know with the PlayBook, there's a way of loading an OS if you bricked the device with BlackBerry desktop software - involved turning the PB off, plugging it into the PC, sacrificing a goat to Mike Lazaridis, etc.

    I would do some searching to see if there's an unbrick method for BB10 devices.

    Also, have you done a security wipe?

    Posted via CB10
    11-12-13 09:32 PM
  24. Skyhi7142's Avatar
    My device does not brick as long as I keep it below 10.1.xx.xxx

    The trick is going to be loading a newer bootrom so that a newer os is whitelisted.

    As an fyi -using Dingleberry I was able to ssh into the device with 5.35.0.17 and look around at the file structure. I'm not a Linux/Unix expert so I am trying to get an ftp program working but I'm having trouble with the authentication.

    I figure if this is an insecure bootrom we should have a lot more privileges and maybe a newer os can be loaded this way with some modifications to what prevents the older bootrom from running the newer os.

    I believe we have root access with this bootrom but maybe someone else with more knowledge can comment.
    11-14-13 05:14 AM

Similar Threads

  1. OS 10.2 software update problems
    By gdassoy in forum Telstra
    Replies: 2
    Last Post: 05-03-14, 07:38 AM
  2. Usual temperature for Z10 while idle
    By blueisme in forum BlackBerry Z10
    Replies: 17
    Last Post: 04-10-14, 08:09 AM
  3. Spotify on 10.2 can't access wifi for sync
    By Benedikt_W in forum BB10 Android App Sideloading
    Replies: 4
    Last Post: 11-17-13, 06:25 PM
  4. OS 10.2 download interrupted!?
    By gdassoy in forum BlackBerry Z10
    Replies: 2
    Last Post: 11-06-13, 09:51 AM
LINK TO POST COPIED TO CLIPBOARD