1. Geraldo Rocha's Avatar
    Hi, this issue has recently come to my attention...
    My battery sometimes get stuck at 70% and others at 80% and shows as fully charged all though it's not. How can I solve this? I'm running 10.3.0.1814 on my Z10 STL100-2... installed the leak on Saturday...
    10-14-14 10:03 AM
  2. sk8er_tor's Avatar
    Remove the charger from the wall. Restart your phone. Use it all day. Charge the phone fully. Let us know if it continues.
    10-14-14 10:19 AM
  3. Geraldo Rocha's Avatar
    couldn't even fully charge it, it began to discharge at 84% even plugged! it's overheated I guess... this update is giving me much problem
    10-14-14 09:50 PM
  4. Gearheadaddy's Avatar
    Don't plug the charger into the wall with the phone connected to it...


    Crackberry Genius on Verizon 10.3.1.632
    10-14-14 09:50 PM
  5. damienR's Avatar
    Try letting the battery die and then recharge had similar issues on my z10 stl100-1 ended up buying a spare

    Posted via CB10
    10-14-14 10:07 PM
  6. todparsons's Avatar
    Make sure you're using a blackberry charger or one that isn't too powerful. And drain it as much as possible, let it run out then battery pull and then keep trying to turn on for a while

    Posted with my z10 stl100-2 running 10.3.0.1052
    10-14-14 10:49 PM
  7. Geraldo Rocha's Avatar
    My phone did charge till 100% but it's draining so much
    Why won't my battery fully charge after 10.3 update?-img_20141015_015916.png

    Posted via CB10
    10-15-14 12:01 AM
  8. syah iejam's Avatar
    My phone did charge till 100% but it's draining so much
    Click image for larger version. 

Name:	IMG_20141015_015916.png 
Views:	1419 
Size:	89.1 KB 
ID:	306100

    Posted via CB10
    Wow!


    White z10
    TX3 likes this.
    10-15-14 12:08 AM
  9. Kaye_max008's Avatar
    Before I opened this thread, I knew OP was using Z10

    Snow White Z10 10.3.0.1052
    10-15-14 12:23 AM
  10. Geraldo Rocha's Avatar
    My phone used to work perfectly before installing the 10.3 leak... after that things got screwed up...
    Seems like you have the same phone and OS, are u facing the same things?

    Posted via CB10
    10-15-14 01:29 AM
  11. Shona Mogano's Avatar
    not sure if this will help but, my friend's Z10 wasnt charging i switched off "Battery Saving Mode" then turned off advanced interation feature... and then everything worked... so try that.
    02-26-15 07:21 AM
  12. tushargkwd's Avatar
    Yup... I can confirm..
    Today morning my phone charged only upto 84% and then stopped. I kept it for charging overnight.

    This has never happened in the last six months of my ownership of the phone!

    Posted via my  z30/2243
    03-05-15 12:16 PM
  13. kamarov's Avatar
    Blackberry released a bulletin about this issue, see here http://btsc.webapps.blackberry.com/b...ListHelperImpl
    03-05-15 09:49 PM
  14. XOW JTO's Avatar
    Just info only... I had that problem from 10.1 until I replaced my battery with other vendors...not originally BlackBerry. More ampere power.
    Reading baterai is perfect. Downgrade or upgrade OS no problem with battery. Why I don't know.

    Posted via CB10
    03-07-15 04:46 AM
  15. ArmedHitman's Avatar
    Why does your input services use so much, how many languages do you have installed, do you use that voice typing feature?

    Posted via CB10
    03-09-15 06:12 AM
  16. star_night_21's Avatar
    I have a bbz10 and I updated to the new OS10 a couple of weeks ago. Shortly after that I noticed that the battery wasn't fully charging while plugged into the wall. I purchased a car charger and it worked for a couple of days but would only charge to 59% then it ended up not charging as well. So, I tried to get a new battery but had to wait for 10 days for it to be delivered and went through the process of using up the new battery then when it died, plugged it into the wall but it would only charge up to 70%! Now, it stays at 10% or less when I have it charging through my laptop. Why is this happening and how can I fix it? Thanks!
    07-08-15 10:27 PM
  17. VIP30's Avatar
    Switch on "Flip To Save Power"
    Charge using the wall charger
    Do a "Restart" while charging
    Flip the phone face down
    Let it be until it shows 100%

    These steps works on my STL1 & STA2...


    RedBlackBeast
    07-14-15 02:18 AM
  18. James Blight's Avatar
    My phone did charge till 100% but it's draining so much
    Click image for larger version. 

Name:	IMG_20141015_015916.png 
Views:	1419 
Size:	89.1 KB 
ID:	306100

    Posted via CB10
    Something isn't right here. I would reload your operating system. Input services is through the roof.

     Z30 STA100-5 on OS 10.3.2.2339 / SR 10.3.2.2226
    07-15-15 09:33 AM

Similar Threads

  1. BlackBerry 10.3.1 Feature Requests
    By dguillaume in forum BlackBerry 10 OS
    Replies: 48
    Last Post: 11-05-14, 08:16 PM
  2. Android not work on 10.3.0.1418
    By dmunozduarte in forum BB10 Leaked/Beta OS
    Replies: 9
    Last Post: 10-15-14, 10:12 AM
  3. Why won't my BlackBerry Z10 start up?
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 10-14-14, 10:31 AM
  4. Request for an "Undo Option" in Blackberry 10
    By TW007 in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-14-14, 10:00 AM
  5. It's even harder to wait after reading this
    By cb64800 in forum BlackBerry Passport
    Replies: 2
    Last Post: 10-14-14, 07:56 AM
LINK TO POST COPIED TO CLIPBOARD