1. barryb20's Avatar
    Hi All,

    Updated my Z30 to 10.3.1 and my BB Desktop software would not see it. I tried everything even removed, then reinstalled from the "CD" that the phone attaches to the PC when selecting install software.

    Software installed, but still the drivers would not install grrr! So tried to un-install the BB Desktop (that includes blend) and it would not, kept rolling back to the installed state.

    So I have spent ages sifting and removing it manually, but no matter what when I re-run the updated BB Desktop with Blend it comes back saying it s all install, which it plainly is not

    Any ideas?

    Barry
    12-02-14 12:06 PM
  2. Carl Estes's Avatar
    You need to install BB Link, not BB Desktop. BB DT is for legacy devices (OS7 and earlier) and the departed Playbook.
    BB Link is for OS 10 devices.
    Go to BB world and fink BB Lionk, and you will be good to go!
    And you have to be aware that you may have other issues as this is an OS leak, and they are nnot official, and can/may have other issues.
    12-02-14 12:10 PM
  3. Legal Eagle's Avatar
    You need to install BB Link, not BB Desktop. BB DT is for legacy devices (OS7 and earlier) and the departed Playbook.
    BB Link is for OS 10 devices.
    Go to BB world and fink BB Lionk, and you will be good to go!
    And you have to be aware that you may have other issues as this is an OS leak, and they are nnot official, and can/may have other issues.
    If you read the first [post properly you will see that the OP refers to Desktop software that includes Blend, so he is not installing Legacy DM.

    I can't see that the OS version will affect the ability of a PC to install Link.

    I presume that the OP is trying to delete Link by doing so from Windows uninstall / change programs which would be the correct way to do it and this is failing.

    Try rebooting the PC and running CCleaner and try again. May help.

    Does Windows give you the option to repair the program ? If so, have you tried this option ?

    And 10.3.1 1154 is going to be the Classic launch OS, so it really can't be classified as a leak.
    BigBadWulf and barryb20 like this.
    12-02-14 12:24 PM
  4. barryb20's Avatar
    Hi,

    Thanks both for the reply, sorry if terminology was a bit out, yes tried via add / remove programs, that's what led me to start removing manually as the software kept rolling back the removal once it hit the drivers stage.

    I did run CCleaner but the software install still thinks it is installed!

    Thought I would post here to see if someone had this before.

    Barry
    12-02-14 02:16 PM
  5. masterscarhead1's Avatar
    Hi,

    Thanks both for the reply, sorry if terminology was a bit out, yes tried via add / remove programs, that's what led me to start removing manually as the software kept rolling back the removal once it hit the drivers stage.

    I did run CCleaner but the software install still thinks it is installed!

    Thought I would post here to see if someone had this before.

    Barry
    Seems like the problem lies in your computer OS, not the phone
    BigBadWulf likes this.
    12-02-14 02:20 PM
  6. Gearheadaddy's Avatar
    Delete ALL BlackBerry computer software.
    RESTART THE COMPUTER.
    Download the newest Link Software.
    Install said software.

    Crackberry Genius on Verizon 10.3.1.1154
    BigBadWulf likes this.
    12-02-14 04:55 PM
  7. barryb20's Avatar
    Thanks guys,

    yes did that and eventually had to re run CClean 4 times before it tidied up the rogue keys, I now have link re-installed, it worked OK for a bit and yet again my BBerry is not recognised by the software so I cannot restore my back ups. A tad inconvenient.

    I think perhaps something new is blocking the connection from the BB to the PC and it is not "seeing" the device, will have another go at it latter on today,

    Barry
    12-03-14 08:08 AM
  8. akawarrior's Avatar
    1. Use System Restore in Windows and set your computer back to a date that you know it was working..
    2. Use uninstall from control panel and remove the older version of Link..
    3. Download the new version and reinstall it.

    Make sure you are using the USB cable that came with your phone.

    Should work..

    AkaWarrior....
    BigBadWulf likes this.
    12-03-14 08:29 AM
  9. magnetman-'s Avatar
    If you are running an anti virus program you may have to deactivate it. It might be preventing what you want to do.

    Posted via CB10
    12-03-14 09:00 AM
  10. Viet Ton's Avatar
    Maybe you should change the USB port or the cable.

    Posted via CB10
    12-03-14 11:53 AM
  11. heveys4's Avatar
    I had this problem with my z30. Turn off blend on your phone or it won't connect to link with a z30.



    Posted via CB10
    12-03-14 01:16 PM
  12. Gearheadaddy's Avatar
    Make sure you are in "Airplane Mode" too.
    Incoming signals may cause other issues...just sayin...

    Crackberry Genius on Verizon 10.3.1.1154
    12-03-14 01:47 PM

Similar Threads

  1. Can I recover WhatsApp data from old BlackBerry?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 02-16-15, 08:30 PM
  2. Closed:WTS: Blackberry Z30 - STA100-5
    By kb1234 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 8
    Last Post: 12-11-14, 09:41 PM
  3. BlackBerry Being Compared to a Flip Phone... Are You Kidding Me?
    By rshore in forum General BlackBerry Discussion
    Replies: 29
    Last Post: 12-07-14, 08:08 AM
  4. Replies: 3
    Last Post: 12-04-14, 01:23 PM
  5. Blackberry OS 10.3 update
    By Akash9944 in forum Ask a Question
    Replies: 3
    Last Post: 12-02-14, 01:20 PM
LINK TO POST COPIED TO CLIPBOARD