1. ahpsi's Avatar
    I apologize in advance for beginning a new thread however I cannot determine the cause and any potential resolution to this issue and am hoping someone can assist.

    I'll use the report format requested by the BerryLeaks team in their OS release threads:

    Device: Z10
    Device Model: STL100-4
    Issue/Question: WhatsApp will function normally after OS installation for approximately 24 hours. Afterwards hub integration is no longer functional and notification of new messages does not occur unless the app is running in an open frame. Even then messages do not appear in the hub. Older messages do still appear in the history.
    What action caused the issue? Installing OS 10.2.0.13XX As far as I remember WhatsApp worked in most of the 10.1 variants.
    What did you try to resolve the issue? I've reinstalled OS 10.2.0.1371, security wiped, installed Android runtime v127.0.0.595, configured two mail accounts and one social account, installed BBM channels and then WhatsApp v2.11.1.1 from the app store. Yesterday, it worked. Today, it doesn't.

    I'd been running 10.2.0.1371 since the day it was made available on CrackBerry and had this issue but hoped it was because of the large number of changes I was making regularly while testing the OS. When I had my apps converted, defined and ready for installation I thought I'd wipe and then test as cleanly as possible (without installing too many any Android or BlackBerry apps). I had read in one of the threads that this may be a known issue but hold out hope that it can be corrected. I had attempted uninstalling and reinstalling which only succeeded in removing WhatsApp from the hub all together. I had converted the APK and attempted to run that but had issues and regardless would not see the same level of hub integration that I would from the native/official app.

    Anyone out there have any insight into this issue?

    Thank you for reading this far.
    08-27-13 12:08 PM
  2. cchilderhose's Avatar
    Did you try uninstalling, rebooting and then reinstalling the app?
    08-27-13 12:27 PM
  3. jackmoe's Avatar
    What about restarting the hub when the integration fails? (5 Swipes) - Does it restore the functionality?

    I see you also mentioned that you tried sideloading a newer version which you had converted from an APK, and had problems. One might conclude that this OS leak doesn't include a possible Whatsapp update that may solve the issue you are encountering. E.g. Whatsapp is given the OS release ahead of time to test their app, and if they discover any fixes that are needed, they get released just before or immediately after OS 10.2 is officially available.

    TLDR; I think you might be waiting on a version update from Whatsapp that will come sometime around 10.2
    08-27-13 12:39 PM
  4. ahpsi's Avatar
    Thank you for your replies. Cchilderhose, yes unfortunately under 10.2.0.1323 and 10.2.0.1371 I've uninstalled, rebooted and then reinstalled but have not been able to get hub to work more than once in one several hour period after a security wipe. I've also tried rebooting using the power button and by holding both volume buttons. I've pulled the battery and tried several things that make absolutely no sense (and didn't do a bit of good).

    Jackmoe, I have tried the 5 swipe hub restart and while the hub does restart the WhatsApp content is stuck and static as of the last time it worked. Refreshing just the WhatsApp content in the hub does not report an error but also does not change the visible text. I am able to compose from the hub and also able to click on any existing conversations that were in progress at the time of the 'freeze' and enter into the correct chat however I am simply not notified at all if there is a response and my hub never reflects the current status of the chat. I agree most probably I am in need of a fix from WhatsApp however I have attempted to contact WhatsApp in the past and have not yet received a response. In their defense at least in this case I would not expect a response as I am not running a valid OS version (from their perspective).

    The real kicker is I wouldn't even be on WhatsApp if BBM had been available on Android and IOS a few months ago!
    08-27-13 02:56 PM
  5. obaquerizo's Avatar
    Having the same issue but with 10.1.0.273 the official os, can change to a beta cause I can't get a stl100-1 os 10.2

    Posted via CB10
    09-02-13 07:36 PM
  6. trinichindian's Avatar
    Having the same issue but with 10.1.0.273 the official os, can change to a beta cause I can't get a stl100-1 os 10.2

    Posted via CB10
    Yes you can 10.2.0.1047

    >Zedding since the beginning<
    09-05-13 07:00 PM
  7. toobs623's Avatar
    Having the same issue but with 10.1.0.273 the official os, can change to a beta cause I can't get a stl100-1 os 10.2

    Posted via CB10
    Check out Wu-Wei's hybrid thread in the stickies

    Posted via CB10
    09-05-13 08:39 PM

Similar Threads

  1. Let's bet: Verizon will push 10.2 before or AFTER xmas?
    By Magnetic_dud in forum Verizon Wireless
    Replies: 30
    Last Post: 01-22-14, 05:15 PM
  2. 10.2.0.810 and instagram not working
    By sindai in forum BB10 Android App Sideloading
    Replies: 2
    Last Post: 08-28-13, 11:31 AM
  3. BlackBerry using PhlyBoy vid for Marketing on Facebook. Might as well hire him.
    By Jerale Hoard in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 08-28-13, 06:41 AM
  4. Footylight bar file?
    By Spartiatis in forum PlayBook Apps & Games
    Replies: 3
    Last Post: 08-27-13, 02:05 PM
LINK TO POST COPIED TO CLIPBOARD