1. gregorylkelly's Avatar
    Ever since installing the latest leak on Z30, I have had some weird internal clock issues. I first noticed problems in my calendar app where everything was showing 5 hours later than what I had put in. Even if I went to change an appointment time, it would show me the correct time to edit, but would save it as the wrong time (however it showed correctly on other devices that the same account was synced to).

    Up until today, I thought this was an issue with my calendar app, however I noticed strange things going on with my text messages too. In the following picture, I sent "1" then received "1", then sent "2", then received "2", etc...

    Strange Time Bug-img_20140825_142735.png

    As you can see, when I send a text, the time is correct, however the texts I receive are showing 4 1/2 hours in the future.

    I have changed my date and time settings, trying everything from manual to automatic, to changing time zones and daylight savings.

    Does anyone have any ideas that don't require a full OS reinstall?

    Posted via my BlackBerry Z30
    08-25-14 03:49 PM
  2. Tecker Man's Avatar
    Did u backup and restore cuz that could be the problem

    Posted via CB10
    08-25-14 04:59 PM
  3. mrjmc99's Avatar
    Did u backup and restore cuz that could be the problem

    Posted via CB10
    I love how this is the default answer to all problems.

    Sorry I can't think of anything for you to try. Maybe pull your sim, boot up verify time then put the sim back and hope for the best

    Z30STA100-3/10.3.0.1052
    08-25-14 05:04 PM
  4. gregorylkelly's Avatar
    So strangely I realized that all of my incoming texts were coming in at 6:55pm. So, now that it is after 6:55, all new texts are coming in correctly.

    The texting issue seemed to fix itself, but the calendar issue remains.

    Posted via my BlackBerry Z30
    08-25-14 07:23 PM
  5. graeme somerville's Avatar
    If time zone set to auto update, it picks up correct time (presume from the carrier).

    However clock application is out by several hours. Have to manually set to GMT to get correct time on the clock app as I use this for an alarm while I am on the road.

    Calendar and email times are out of sync. Not having calendar correct is very frustrating.

    Just updated to 10.2.1.3062 this morning. Still the same behaviour.

    I have a Z10.

    Can't find any posts anywhere that provide a resolution to this.

    Been a loyal BB user since 1999 but this is really testing my patience.

    Any suggestions would be very welcome.
    11-08-14 08:11 AM
  6. maremil's Avatar
    Maybe your carrier has clock issues in the network. Try other sim (carrier) and check if it is still wrong.

    Posted via CB10
    11-08-14 10:48 AM
  7. Dodger52's Avatar
    I've experienced more or less the same issue with my passport after upgrading to 10.3.1.0.1016

    Posted via CB10
    11-08-14 01:16 PM
  8. rickkel's Avatar
    I had the same issue when I upgraded my Z30 to 10.3.1. It was a simple fix, but it seems like you may have already tried this? It's worth a try anyway:

    1. Open Settings>Date and Time.
    2. Your time zone is probably set at your current time zone; mine was. Change it to anything except the real time zone you are in.
    3. Tap the back (<) button to save your setting.
    4. Go back into Date and Time and reset your time zone to the correct one.
    5. Tap the back (<) button to save your setting.

    I then went into my calendar and all the times were fixed. I found a recurring event I have with a specific time I knew for the test.

    It is obviously a bug, but was easily fixed. I hope this helps.
    jzajac likes this.
    11-08-14 01:28 PM
  9. Lacker20's Avatar
    I had the same issue when I upgraded my Z30 to 10.3.1. It was a simple fix, but it seems like you may have already tried this? It's worth a try anyway:

    1. Open Settings>Date and Time.
    2. Your time zone is probably set at your current time zone; mine was. Change it to anything except the real time zone you are in.
    3. Tap the back (<) button to save your setting.
    4. Go back into Date and Time and reset your time zone to the correct one.
    5. Tap the back (<) button to save your setting.

    I then went into my calendar and all the times were fixed. I found a recurring event I have with a specific time I knew for the test.

    It is obviously a bug, but was easily fixed. I hope this helps.
    thanks for the tip! Worked out fine, at first I thought the events I had marked were deleted but a few minutes later they reappeared with the correct hours.
    11-08-14 01:43 PM
  10. danp2000's Avatar
    Nice, simple fix,

    Glad to know that worked.

    CB as it should be, users helping users.

    T-Mobile STL100-3 running autoloaded 10.3.1.1016 setup from scratch.
    11-08-14 04:19 PM
  11. rickkel's Avatar
    I'm just hoping it also works for the OP (Gregory)...I hate when my BlackBerry is acting weird, so I don't like it when other people's is too!

    Posted via CB10
    11-08-14 04:39 PM
  12. jzajac's Avatar
    I had this bug when I first updated to 10.3.0.1418. It was a non destructive update through sachesi over an earlier build of 10.3.0, and it drove me crazy. My fix was to perform another non destructive flash of the OS and radio files, and that did the trick for me, but I was very close to wiping and starting from scratch with an autoloader. Thank you rickkel
    for providing another solution.
    11-08-14 04:59 PM
  13. mcutworm's Avatar
    I have seen a txt message time bug also. If you long press a text reply the overflow menu would give you an exact time. It now shows feb 19th 1970. I always do a security wipe and autoloader. I know it was on 1016 and I reverted back to 800 and its on it too.
    Verizon Q10
    11-08-14 05:39 PM
  14. kojita's Avatar
    Hi all,

    Unfortunately, the trick to change the date settings did not wok, was it set to automatic time?
    I set an appointment at 2pm, it shows me 12pm but on my server, the event is correct (2pm) ...???
    first bug on my passport.
    Any help appreciated
    Cheers
    Fred
    11-10-14 05:43 AM
  15. kojita's Avatar
    sooo solution found by removing and re-adding the concerned account (activesync to a zimbra server).
    Cheers
    11-10-14 09:08 AM

Similar Threads

  1. Wats app received sent time for each msg
    By Obaid Rahman in forum Ask a Question
    Replies: 6
    Last Post: 09-01-14, 09:45 AM
  2. Time-of-flight camera
    By Easy-G in forum BlackBerry Passport
    Replies: 8
    Last Post: 08-25-14, 04:21 PM
  3. Calling led left side on speaker blinks all the time
    By janidushman in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 08-25-14, 11:19 AM
  4. Time stamp on BBM chat for group
    By Rohan Sadula in forum General BBM Chat
    Replies: 1
    Last Post: 08-25-14, 12:41 AM
  5. 9900 STUCK during RESTORE... multiple times.
    By RyanKspeaks in forum BlackBerry Bold 9930/9900
    Replies: 1
    Last Post: 08-24-14, 09:41 PM
LINK TO POST COPIED TO CLIPBOARD