09-07-14 11:43 PM
28 12
tools
  1. Gearheadaddy's Avatar
    I've had the same experience as most everyone above.

    Media settings is ALWAYS ok to restore, unless BlackBerry changes the device storage folder listings (and even then it might be ok, depending in how they do it).
    Apps are restored to their own section of the OS, and I can't imagine a change that would make restoring apps not work (at least not that doesn't include fundamental OS changes that would likely render most apps inoperable in general).

    Settings, once in a blue moon, have some major changes that makes an old settings backup incompatible. I think I've had this happen once, maybe twice, in years.

    I always restore my backups in full. In the unlikely event that it doesn't work, I wipe and try again. If it's still giving problems, I restore just media and apps and everything is fine.
    So in a nutshell.. you agree.

    CrackBerry Genius on Verizon 10.3.0.1154
    09-07-14 11:37 PM
  2. Gearheadaddy's Avatar
    When you upgrade an OS, it has a built-in settings migration that modifies your settings and adjusts them for known variances between Old OS and New OS.

    The problem is when you use destructive autoloaders. You wipe the settings and install the new OS at the same time. Then the migration sees nothing to migrate. Then you restore old settings that weren't migrated.
    Technically it should know what OS the settings came from and then do a migration using that information, but it doesn't.
    Thanks Xsacha, great explanation. I like learning new stuff. Especially from an expert.

    CrackBerry Genius on Verizon 10.3.0.1154
    09-07-14 11:42 PM
  3. Gearheadaddy's Avatar
    Restore? Where they do that at?

    Posted via CB10
    Over there....>>>> <<<<

    CrackBerry Genius on Verizon 10.3.0.1154
    09-07-14 11:43 PM
28 12

Similar Threads

  1. Problem with application settings & device's upgrade
    By Anas Khan in forum BlackBerry Curve 3G
    Replies: 3
    Last Post: 11-03-14, 08:43 PM
  2. From a Long Time Ago!
    By piko 72 in forum Rehab & Off-Topic Lounge
    Replies: 11
    Last Post: 09-17-14, 04:38 PM
  3. Z10 sensors stop working
    By vim674 in forum Ask a Question
    Replies: 3
    Last Post: 09-07-14, 07:37 AM
  4. BlackBerry Q10 from eBay has BlackBerry Error. Help!
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 09-06-14, 08:22 PM
  5. Setting up a wifi hotspot on Bold 9900
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-06-14, 08:15 PM
LINK TO POST COPIED TO CLIPBOARD