1. huckstero's Avatar
    Hey guys - quick question:

    I'm currently using 10.3.738 (with 10.3.0.1154 OS).

    Should I upgrade to the latest 10.3.0.1418 or go straight to 10.3.1.632? (on Blackberry Q10).
    10-14-14 07:04 AM
  2. Ecm's Avatar
    You'll get views from both sides of the fence on this.

    10.3.0.1418 is very smooth and stable, but just an improvement on .1154. I'm using it on my carry device.

    10.3.1.632 has some cool new features (notifications, battery saver, etc.), but also has a few glitches. I have this on one of my backup devices.
  3. Ecm's Avatar
    You'll get views from both sides of the fence on this.

    10.3.0.1418 is very smooth and stable, but just an improvement on .1154. I'm using it on my carry device.

    10.3.1.632 has some cool new features (notifications, battery saver, etc.), but also has a few glitches. I have this on one of my backup devices.
    10-14-14 07:57 AM
  4. prithvi64's Avatar
    Although, I am using 1418 on my stl-1 as a compulsion since 632 wasn't available for this model and 634 was a dev OS with missing daily drivers. I used 3-4 days 634 and I liked features but because of missing drivers, I had to come back on 1418.
    10-14-14 08:04 AM
  5. jafrul's Avatar
    I'm using 10.3.1 as daily driver.
    Bugs and glitches a plenty. But coming from torch hybrid, I can handle and always look for a work around on any bugs I face.
    And so far, none too severe for me to downgrade to 10.3.0. Yet.

    With due diligence from my Astro on Z30STA100-2/10.3.1.632
    rockivy likes this.
    10-14-14 08:31 AM
  6. Don_Henry's Avatar
    I am running 10.3.1.632 as daily driver - other than one very minor glitch, I find it to be excellent. Everything works 100% (except for the very minor glitch - voice mails can only be deleted from the Hub).

    Posted via CB10
    10-14-14 09:14 AM
  7. howards's Avatar
    I was running 632 for a few days but found it just a tad too early of a build to run day to day. 1418 has been rock solid, and later 10.3.1 updates shouldn't be too far away now.

    Z30 / STA 100-3 / 10.3.0.1418
    10-14-14 09:39 AM
  8. GedZju's Avatar
    10.3 and 10.3.1 not smooth on Z30 :/

    Posted via CB10
    10-14-14 10:00 AM
  9. tom4golf's Avatar
    For me running either the latest 10.2 or 10.3.1.632 worked best with the Q10. I did not like the lack of instant actions with the 10.3.0. Being able to quick dial or launch apps with one button makes the Q shine on 632.

    Posted via CB10
    10-14-14 10:26 AM
  10. theonecid's Avatar
    10.3 and 10.3.1 not smooth on Z30 :/

    Posted via CB10
    10.3.0.1418 pretty smooth on my Z30 here... :/
    10-14-14 10:28 AM
  11. IFCArea51's Avatar
    On the latest 10.3.1,

    Some callers reported that my calls were going straight to voicemail. They had to call my landline to tell me what was up.

    Posted via CB10
    10-14-14 10:46 AM
  12. masterscarhead1's Avatar
    632 has just been a bit too buggy for my personal use, and this is coming from someone who beta tests on quite a few platforms and programs
    I'm using 1418 for my phone currently after downgrading to 1154 from 632
    10-14-14 10:50 AM
  13. Trini-34's Avatar
    10.3.0.1418 still have the ability to run flash applications from the browser- while 10.3.1.632 does not. I would recommend that you upgrade (if you want) to .1418- I have not experience any issues running this OS/build but had a couple of issues running .632 (nothing drastic tho')...
    10-14-14 10:55 AM
  14. VIP30's Avatar
    632 has just been a bit too buggy for my personal use, and this is coming from someone who beta tests on quite a few platforms and programs
    I'm using 1418 for my phone currently after downgrading to 1154 from 632
    Severe bugs has always been known for early build... Wait for a 4 digits build...

    ODIN 9520 / 5.0.0.1743 Hybrid / 1850mAh
    10-14-14 11:04 AM
  15. tomsobon's Avatar
    The few new features of the current 10.3.1 dont justify the bugs!
    I stay on 10.3 for now!

    Posted via CB10
    10-14-14 11:09 AM
  16. GedZju's Avatar
    and no transition lag sometimes ?? wth ? why all leaks till 10.2.1.2758 are smooth and no laggy transitions, and the later leaks have it.. I mean lag ..
    10-14-14 03:56 PM

Similar Threads

  1. Is there a possibility of uninstalling or deleting amazon apps(Appstore)?
    By lemmie14 in forum General BlackBerry Discussion
    Replies: 7
    Last Post: 02-21-15, 02:31 PM
  2. Typing in Android apps problematic after 10.3.0.1154 update.
    By Ammar Mariti in forum BlackBerry Z10
    Replies: 4
    Last Post: 10-18-14, 09:29 AM
  3. Where is the new Software Logging Tool ( under 10.3.x )?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 10-14-14, 08:55 AM
  4. Replies: 5
    Last Post: 10-14-14, 07:47 AM
  5. Coming soon - A close look into how the Mercedes AMG PETRONAS team use BlackBerry 10
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-14-14, 05:00 AM
LINK TO POST COPIED TO CLIPBOARD