09-08-15 10:03 PM
609 ... 22232425
tools
  1. ewakil12's Avatar
    I have the .SIGNED files from 10.1.0.2062 autoloader, can I use Sachibar to upgrade without wiping?

    Thanks!
    06-26-13 05:29 PM
  2. xsacha's Avatar
    Put a new version up which fixes some bugs with extraction.

    I have the .SIGNED files from 10.1.0.2062 autoloader, can I use Sachibar to upgrade without wiping?

    Thanks!
    You can grab the 2062 .bar from Sachup. Then you can upgrade without wiping.
    The .signed won't do.
    ewakil12, Sator and Mecca EL like this.
    06-27-13 12:57 PM
  3. dustmalik's Avatar
    Great work xsacha, well done. i would like to report some bugs i have found on the 28June13 Edition as it concerns the 'Extract Apps' and 'Dump All' features. i will start with the STL 100-1 images.

    STL 100-1 Images Extraction Bugs
    it's able to extract apps from the Dev 10.2.0.341 image and 10.0 images. but unable to extract apps from all the 10.1 images i tried it on. namely, OS 10.1.0.2354, 10.1.0.2062, 10.1.0.1627, 10.1.0.1720. Sachup even crashes sometimes when trying to extract apps from the 10.1 images.

    STL 100-2,3,4. Q10 variants and Dev AlphaC images extraction Bugs
    it's unable to extract apps from the Dev 10.2.0.341 images, but able to extract apps from 10.1 images.
    06-27-13 07:19 PM
  4. xsacha's Avatar
    Thanks for report.
    06-27-13 08:28 PM
  5. Adam Szucs's Avatar
    hello sacha, i don't know if it's a bug or normal behavior (i mean could not be fixed), but yesterday i switched to mass storage mode for my sd card, and by mistake i left it like that. however sachibar could not find the device with this on.
    06-29-13 05:00 AM
  6. DetlevCM's Avatar
    hello sacha, i don't know if it's a bug or normal behavior (i mean could not be fixed), but yesterday i switched to mass storage mode for my sd card, and by mistake i left it like that. however sachibar could not find the device with this on.
    BlackBerry 10 and the PlayBook emulate a network drive - their driver is responsible for that.
    In mass storage Mode this is switched off - so I suspect this is by design.

    Posted via CB10
    06-29-13 05:54 AM
  7. Sator's Avatar
    hello sacha, i don't know if it's a bug or normal behavior (i mean could not be fixed), but yesterday i switched to mass storage mode for my sd card, and by mistake i left it like that. however sachibar could not find the device with this on.
    It's not a bug, it's a normal behavior, vnbb10 or similar tools also won't detect your device if you enable your mass storage mode.

    Sent from my BlackBerry 9900 using Tapatalk
    06-29-13 06:01 AM
  8. Adam Szucs's Avatar
    Thank you guys for confirming this. And also for a brief insight how mass storage mode works.
    06-29-13 06:11 AM
  9. Yogeshwar P's Avatar
    hello sacha, i don't know if it's a bug or normal behavior (i mean could not be fixed), but yesterday i switched to mass storage mode for my sd card, and by mistake i left it like that. however sachibar could not find the device with this on.
    Not a bug you can only access your device in mass storage mode when this setting is on

    Posted via CB10
    06-29-13 07:18 AM
  10. Sator's Avatar
    Thank you guys for confirming this. And also for a brief insight how mass storage mode works.
    If you enable your mass storage mode, you can open and manage all your files in your SD card.

    Sent from my BlackBerry 9900 using Tapatalk
    06-29-13 09:32 AM
  11. Adam Szucs's Avatar
    If you enable your mass storage mode, you can open and manage all your files in your SD card.

    Sent from my BlackBerry 9900 using Tapatalk
    Thanks, I know how does it work, just didn't know that how it actually makes the connection, as it's not working with encrypted SD card.

    Posted via CB10 from my Z10
    06-29-13 11:17 AM
  12. Sator's Avatar
    Thanks, I know how does it work, just didn't know that how it actually makes the connection, as it's not working with encrypted SD card.

    Posted via CB10 from my Z10
    Yes, PC won't detect it if we encrypted the SD card.

    Sent from my Z10 using Tapatalk 2
    06-29-13 12:17 PM
  13. DetlevCM's Avatar
    Yes, PC won't detect it if we encrypted the SD card.

    Sent from my Z10 using Tapatalk 2
    I am pretty sure I have used mass storage mode with an encrypted SD card - BUT then the phone needs to decrypt first and i think it copies the file first and then encrypts it.

    Posted via CB10
    06-29-13 05:26 PM
  14. Adam Szucs's Avatar
    I am pretty sure I have used mass storage mode with an encrypted SD card - BUT then the phone needs to decrypt first and i think it copies the file first and then encrypts it.

    Posted via CB10
    Nope, the switch in the settings is inactive if your SD card is encrypted.

    Posted via CB10 from my Z10
    06-29-13 05:55 PM
  15. DetlevCM's Avatar
    Nope, the switch in the settings is inactive if your SD card is encrypted.

    Posted via CB10 from my Z10
    Hmm. I remember copying files to my phone at university once - and it does not have the BlackBerry driver so I need encryption there.
    I don't think I encrypted the cars after the fact...

    Anyway, my approach nowadays is to just out irrelevant stuff on my SD card - i leave it unencrypted because there is nothing Wort stealing on it while my phone is encrypted.

    Posted via CB10
    06-30-13 04:01 AM
  16. xsacha's Avatar
    Update available (4th July).
    Fixes some bugs.
    Extracts RCFS partition.

    I'm currently in the process of a complete overhaul of Sachup and Sachibar.
    They will be turned in to a single application which will do everything (much more than they currently do) and be much easier to use.

    Here's a spoiler:
    Last edited by xsacha; 07-04-13 at 03:15 AM.
    07-04-13 02:18 AM
  17. Shantanu Gupta's Avatar
    Thanks a lot!

    Have you considered programmatically querying their server for all possible MNC/MCC codes and determining the latest OS available ? Would be a great feature
    07-08-13 02:13 PM
  18. xsacha's Avatar
    Thanks a lot!

    Have you considered programmatically querying their server for all possible MNC/MCC codes and determining the latest OS available ? Would be a great feature
    They don't have such a list of codes available
    The update server will accept any code and gives back a generic OS (10.0.9 usually) if the code isn't whitelisted for newer firmware.
    07-08-13 02:56 PM
  19. Shantanu Gupta's Avatar
    They don't have such a list of codes available
    The update server will accept any code and gives back a generic OS (10.0.9 usually) if the code isn't whitelisted for newer firmware.
    How about taking the list off wikipedia ? I know some carriers may not be supported by blackberry but if generic OS (10.0.9) is sent back for such carriers, you can ignore this as the highest OS version will obviously be from a carrier supported by BBRY.
    07-08-13 04:52 PM
  20. tickerguy's Avatar
    If you hit their server with too many requests in a relatively short period of time they blackball your IP number.
    07-08-13 05:34 PM
  21. xsacha's Avatar
    How about taking the list off wikipedia ? I know some carriers may not be supported by blackberry but if generic OS (10.0.9) is sent back for such carriers, you can ignore this as the highest OS version will obviously be from a carrier supported by BBRY.
    That's the list that I am using in the app

    Some carriers still only support OS 10.0.9. Some carriers don't sell Blackberry's yet.
    Also, the command is time-rated so it's going to take a long time to do such a scan considering that some carriers may sell Q5 and not Z10. Then considering there are roughly 5 variants of each phone and a carrier may only sell one. There is hundreds of thousands of combos.

    At the end of the day a list of countries (that don't entirely match up to any 1 code) is going to be much harder to navigate than a code. Not to mention that some carriers own over 70 different codes and the code means more than their name.
    07-08-13 10:04 PM
  22. knowledge_6's Avatar
    anyone know why sachibar is not detecting my device?

    i changed the ip under dev mode to match the greyed out box in sachibar but it still won't detect my device!
    09-05-13 03:56 PM
  23. xsacha's Avatar
    anyone know why sachibar is not detecting my device?

    i changed the ip under dev mode to match the greyed out box in sachibar but it still won't detect my device!
    If you're using Linux or Mac, make sure your device is in 'Mac' mode in Storage settings.
    09-05-13 09:21 PM
  24. knowledge_6's Avatar
    If you're using Linux or Mac, make sure your device is in 'Mac' mode in Storage settings.
    nope windows 7... weird!
    09-05-13 09:44 PM
  25. xsacha's Avatar
    Is it in 'Driver' mode? You'll have to let it install Link / USB Drivers if it hasn't done this before.
    09-05-13 10:12 PM
609 ... 22232425
LINK TO POST COPIED TO CLIPBOARD