11-02-16 10:03 PM
638 ... 910111213 ...
tools
  1. Max Waldo's Avatar
    Alright, for who ever is getting over 100% issue and its not downloading I found a fix. at lease on a mac where i had the issue.

    Put the Sachesi app in a folder alone then download. I named the folder Sachesi too just cause but I think as long as the app is put in a folder it should work and download.
    09-26-14 09:37 PM
  2. xsacha's Avatar
    Alright, for who ever is getting over 100% issue and its not downloading I found a fix. at lease on a mac where i had the issue.

    Put the Sachesi app in a folder alone then download. I named the folder Sachesi too just cause but I think as long as the app is put in a folder it should work and download.
    Ah, so a problem with the directories on Mac OSX then I guess.
    I'll try to fix that one properly.
    Edit: Should be fixed for OSX in v1.9.0.1.
    Last edited by xsacha; 09-26-14 at 10:36 PM.
    09-26-14 09:52 PM
  3. EdY's Avatar
    First of all, Thank you xsacha for an awesome app. I am new to Sachesi, but have been using Autoloaders before on my Dev Alpha C. I want to update my SQN 100-3 DAC to the latest 10.3 without erasing my phone. When I load Sachesi, It is giving me country 510, carrier 010 (indonesia, telkomsel) when I search for Q5+Q10+P9983 and any variant, mode upgrade, server production.

    I have attached a screen-shot:

    Sachesi Tutorial: How to install the latest OS as an Update-untitled.jpg

    I am confused about the color codes (pink, purple, blue) and whether it is safe to use the SQK 100-1 update.... From what I understand, since Passport is the only official phone with the 10.3 upgrade, that is what is being found on servers? Except for the core/radio which are meant for Q10 (and not Passport)?

    Any help would be appreciated. Also, I notice it puts the files in the same folder as Sachesi so I will have to run it from another partition (D: drive instead of my C: drive) since I think I'll end up running out of space.
    09-27-14 03:22 PM
  4. xsacha's Avatar
    Basically, it doesn't matter what your phone is, it will download it for your device.
    See the 'Download for' down the bottom? It automatically converts the links so they work on your device! Even if your device is 'Unknown'.

    However, in this situation, the links are already correct for a Dev Alpha C (Q10) anyway. It will convert the links but it won't end up changing anything because they are already correct.

    Colours:
    That colour up the top is for OSes, the colour below it is for Radios. Whenever you search, the OS and Radio will be #1 and #2 result.
    The blue colour is just a normal application (which can be sideloaded by any method) and the purple colour is for data apps.
    Sachesi can sideload all of those files, but normal sideload methods can only load blue ones successfully.
    09-27-14 05:23 PM
  5. Lizzi1017's Avatar
    I created a separate folder with the app in it. It didn't work for me. My download said 272% and i have no idea where it is downloading to! I am using a Mac as well.
    09-27-14 06:06 PM
  6. redtape1's Avatar
    I am having big problems with my Z10. I used this as my practice phone and good thing, because it appears i have messed up. I didnt follow all the instructions clearly, and it appears i have forced the install of a system that is incorrect. This is causing very long boot times, stalling of the OS, and many other malfunctions. So i thought i would connect to LINK to fix and restore, but it continually tells me that setup isnt complete and I have done everything i can think of for setup (BB ID, WIFI, Tutorials, etc.) Because it says setup is incomplete, it will not allow with the reload of software. Then if i try Sachesi, it says Error-Authorization and hangs. Please help me either restore to factory or fix this bad install. Thanks
    09-27-14 07:44 PM
  7. redtape1's Avatar
    I had the same problem on the Mac, I ended up using a PC
    09-27-14 07:56 PM
  8. yhamaie's Avatar
    Sachesi can sideload all of those files, but normal sideload methods can only load blue ones successfully.
    Noted with a lot of thanks.

    That colour up the top is for OSes, the colour below it is for Radios.
    The blue colour is just a normal application (which can be sideloaded by any method) and the purple colour is for data apps.
    The colour for radio and the colour for data stuff look identical on my screens . . . I wonder if they are displayed correctly on my screens.
    09-27-14 08:27 PM
  9. xsacha's Avatar
    I created a separate folder with the app in it. It didn't work for me. My download said 272% and i have no idea where it is downloading to! I am using a Mac as well.
    To confirm, is this version 1.9.0.1?
    Also, look at the folder that Sachesi.app is in.
    09-27-14 11:13 PM
  10. xsacha's Avatar
    I am having big problems with my Z10. I used this as my practice phone and good thing, because it appears i have messed up. I didnt follow all the instructions clearly, and it appears i have forced the install of a system that is incorrect. This is causing very long boot times, stalling of the OS, and many other malfunctions. So i thought i would connect to LINK to fix and restore, but it continually tells me that setup isnt complete and I have done everything i can think of for setup (BB ID, WIFI, Tutorials, etc.) Because it says setup is incomplete, it will not allow with the reload of software. Then if i try Sachesi, it says Error-Authorization and hangs. Please help me either restore to factory or fix this bad install. Thanks
    Your device hasn't completed setup. Look in hub for setup instructions. You have about 7 days to complete it and it requires internet access. This is not related to tutorials or WiFi.

    Delayed setup is a new feature of 10.3
    09-27-14 11:15 PM
  11. redtape1's Avatar
    That is very strange...The Hub is all black...it is a blank space so nothing to do in there, so dont know what that means
    I have the STL 100-3 and it has the 10.3.0.1154 OS build 761676 Radio Ver. 10.2.1.3140 if that helps.
    The device does have internet access and i even tried to update via the device, but it tells me i have the latest version installed already.
    Thanks again for any assistance and for the great app you have provided (it did work on my z30) paid better attention the 2nd time
    09-28-14 12:29 AM
  12. Uzi's Avatar
    That is very strange...The Hub is all black...it is a blank space so nothing to do in there, so dont know what that means
    I have the STL 100-3 and it has the 10.3.0.1154 OS build 761676 Radio Ver. 10.2.1.3140 if that helps.
    The device does have internet access and i even tried to update via the device, but it tells me i have the latest version installed already.
    Thanks again for any assistance and for the great app you have provided (it did work on my z30) paid better attention the 2nd time
    Because you have the wrong radio should be 10.3 radio

    Posted via CB10
    09-28-14 12:49 AM
  13. EdY's Avatar
    I downloaded the 201 files needed for 10.3.0.738 under the Q5+Q10+P9983. When I start Sachesi again, it shows I have the 199 files (it says "(downloaded") beside them in the list) but it says I still need 2 files... namely, the coreos.qc8960 (325.5 mb) and radio.qc8960 (27.8 mb) files.... and checks them off.

    When I press "download" Sachesi crashes.... If I go into the 10.3.0.738 folder and rename or delete the corresponding coreos and radio bar files, Sachesi can download them again. So it must be crashing because it can't overwrite existing files in the folder and doesn't know what to do.

    Anyways, even after I download them again, Sachesi keeps thinking I have not downloaded them. Perhaps it is not recognizing them in the folder that they were downloaded, or it is not matching up some search string it is looking for when scanning the directory.

    For example, when I go into the directory and rename the file "ava-10.3.0.2-nto+armle-v7+signed.bar", and then do a SEARCH again in Sachesi, the checkmark appears again next to the "sys.data.nuance_ve.ENU.ava" line and it no longer says "(downloaded)" beside it. As soon as I rename it back, the checkmark goes off and it says "(downloaded)".

    So I think the coreos and radio files are not being found in the directory even though they are downloaded. Something in the name is not matching what it is looking for. I am not sure if this is messing up the installation.
    09-28-14 01:17 AM
  14. yhamaie's Avatar
    So I think the coreos and radio files are not being found in the directory even though they are downloaded. Something in the name is not matching what it is looking for. I am not sure if this is messing up the installation.
    May I ask on what platform you have been trying to download files . . . Windows, Mac, Android, or Linux?


    Posted via CB10
    09-28-14 01:24 AM
  15. EdY's Avatar
    I am on a Windows 7 Pro machine (ASUS M51Aseries laptop). Sachesi is located under D:\Sachesi folder and the downloads are in D:\Sachesi\10.3.0.738. I choose to "install folder" and pick the 10.3.0.738 folder, and then I see a window with the circular progress showing installing 1 of 201, 2 of 201, etc... And on my Dev Alpha C device I see a dialog saying "Software Update In Progress"... but it always says Installing 0% Complete... Maybe because it doesn't know how large the install is and can't calculate the value.

    Anyways, after installing all 201 files (or so Sachesi says) the device reboots but I have so far ended up still with my old OS (Settings > About) as if nothing happened.

    I freed up some more space (now there is about 5-6 gb free) and trying again....

    Note that the "Your Applications" tab in Sachesi says I have "com.qnx.coreos.qcfm.os.qc8960.factory_sfi" version 10.2.0.1047 and "com.qnx.qcfm.radio" version 10.2.0.1048. The name given to the updated core is the same but the radio on the 10.3.0.1155 is called "com.qnx.qcfm.radio.qc8960.wtr" (not just "com.qnx.qcfm.radio")... I don't know if the missing "qc8960.wtr" makes a difference or not, if the update is trying to overwrite the radio file or keeping both due to different names. Nevertheless, the core ID's are the same (just different version numbers, my old one 10.2.0.1047 and the new one 10.3.0.1154) and it is not replacing my old one either.
    09-28-14 01:33 AM
  16. yhamaie's Avatar
    Nevertheless, the core ID's are the same (just different version numbers, my old one 10.2.0.1047 and the new one 10.3.0.1154) and it is not replacing my old one either.
    I have a Q10 but I do not own any Dev Alpha C device.

    Unless you would mind wiping your device, would you please try to load 10.3.0.700 https://developer.blackberry.com/dev...ha_update.html to see if it works?


    Posted via CB10
    09-28-14 01:43 AM
  17. EdY's Avatar
    I am giving the Sachesi method another chance and if it still doesn't work, I'll just use an Autoloader but it will of course wipe my device, which is what I was trying to avoid in the first place. Not that I have anything critical on there.... it is just for developing purposes, no SIM card, not my main phone... but I didn't want to have to load all my apps back on, especially my testing apps which I sideloaded onto the device in the first place. The ones from Appworld should automatically allow me to download once I put my BlackBerry ID into the device... it will associate everything again. I just don't want to set up the accounts in the hub and everything else I had on there.

    When I search for a SQN 100-3 variant it is only up to 10.2.1.3175... but when I choose Any variant, it gives me the SQK 100-1 files. I have a feeling the device is not liking this variant and it will not initiate the install procedure... even though the bars are getting on the device, when it reboots it is not replacing the existing OS.... Isn't that the Porsche 9983? There must be something preventing it from installing on a SQN otherwise everyone would turn their Q5/Q10 into a "Porsche Design" phone... Unless we all have the same OS but there is additional code in the apps that turn on "Porsche" features when it sees the model number is of the Porsche type.

    So after the Sachesi install, the device just keeps rebooting over and over with the BlackBerry logo and red light.... after about 3 or 4 times it finally boots to completion and I'm back to where I started with 10.2.

    I am guessing since the 10.3 is only available for the new Porsche design phone for now, it has code making sure it will only run on a Porsche phone even if the hardware is essentially compatible with Q10, to keep it exclusive. I will need to search for the SQN 100-3 variant (or anything other than Porsche) but there is no 10.3 yet in any other variant.
    Last edited by edyb; 09-28-14 at 02:53 AM.
    09-28-14 02:06 AM
  18. BlackBerry9930's Avatar
    Hey guys. When I open sachesi 1.9.0 I only see a blank page... does anybody know why? :/

    Posted via CB10
    09-28-14 03:33 AM
  19. yhamaie's Avatar
    When I search for a SQN 100-3 variant it is only up to 10.2.1.3175... but when I choose Any variant, it gives me the SQK 100-1 files.
    That is true . . . BlackBerry Limited has officially released 10.3.0.x only for Passport and P'9983 (Q10 in Porsche Design outfit).

    I have downloaded all files for SQK 100-1 (P'9983) and successfully updated my Q10 (SQN 100-1) from 10.2.1.x to 10.3.0.x non-destructively with Sachesi. (I understand that you have been trying to update your Dev Alpha C from 10.2.0.x to 10.3.0.x non-destructively with Sachesi.)
    09-28-14 03:36 AM
  20. yhamaie's Avatar
    When I open sachesi 1.9.0 I only see a blank page... does anybody know why?
    May I ask if you are running Sachesi 1.9.0 on Windows XP?

    Please try https://github.com/xsacha/Sachesi/re....9.0-WinXP.zip as well to see if it works.
    09-28-14 03:42 AM
  21. redtape1's Avatar
    Because you have the wrong radio should be 10.3 radio

    Posted via CB10
    Correct, that is what i assumed as well. However, trying to rectify that seems to be the problem
    09-28-14 08:31 AM
  22. sereabogdan's Avatar
    install stopped at file 106/154 at 93 % . what can i do?
    gemoelle likes this.
    09-28-14 08:42 AM
  23. xsacha's Avatar
    When I press "download" Sachesi crashes.... If I go into the 10.3.0.738 folder and rename or delete the corresponding coreos and radio bar files, Sachesi can download them again. So it must be crashing because it can't overwrite existing files in the folder and doesn't know what to do.

    Anyways, even after I download them again, Sachesi keeps thinking I have not downloaded them. Perhaps it is not recognizing them in the folder that they were downloaded, or it is not matching up some search string it is looking for when scanning the directory.

    For example, when I go into the directory and rename the file "ava-10.3.0.2-nto+armle-v7+signed.bar", and then do a SEARCH again in Sachesi, the checkmark appears again next to the "sys.data.nuance_ve.ENU.ava" line and it no longer says "(downloaded)" beside it. As soon as I rename it back, the checkmark goes off and it says "(downloaded)".

    So I think the coreos and radio files are not being found in the directory even though they are downloaded. Something in the name is not matching what it is looking for. I am not sure if this is messing up the installation.
    Sachesi always assumes coreos and radio aren't downloaded because it can't know in advance what the links will be converted to.
    When you click Download, it then verifies the converted links and then checks if they exist. If they exist, it removes them from download queue.

    Even if you have selected 'As Searched', Sachesi has to assume you may wish to convert links in future. The reason is: you may Search, then decide you want to download for another device (for instance, connect your phone). In this situation, if the coreos and radio were unchecked, it would never download these files (which is bad!).
    Hence, it always leaves coreos and radio checked even if the current option is already downloaded.
    Other applications are unaffected by device type.

    Edit: Thanks for reporting the crash when you download OS/Radio that already exists and no other downloads are queued. Fixed this for next version.

    install stopped at file 106/154 at 93 % . what can i do?
    Unfortunately you may have to try again because it looks like the device and your computer stopped talking to eachother .


    When I search for a SQN 100-3 variant it is only up to 10.2.1.3175... but when I choose Any variant, it gives me the SQK 100-1 files. I have a feeling the device is not liking this variant and it will not initiate the install procedure... even though the bars are getting on the device, when it reboots it is not replacing the existing OS.... Isn't that the Porsche 9983? There must be something preventing it from installing on a SQN otherwise everyone would turn their Q5/Q10 into a "Porsche Design" phone... Unless we all have the same OS but there is additional code in the apps that turn on "Porsche" features when it sees the model number is of the Porsche type.

    So after the Sachesi install, the device just keeps rebooting over and over with the BlackBerry logo and red light.... after about 3 or 4 times it finally boots to completion and I'm back to where I started with 10.2.

    I am guessing since the 10.3 is only available for the new Porsche design phone for now, it has code making sure it will only run on a Porsche phone even if the hardware is essentially compatible with Q10, to keep it exclusive. I will need to search for the SQN 100-3 variant (or anything other than Porsche) but there is no 10.3 yet in any other variant.
    "Unless we all have the same OS but there is additional code in the apps that turn on "Porsche" features when it sees the model number is of the Porsche type."
    This is correct. Most Blackberry 10 phones actually run the same code/firmware. Only exceptions are the 'STL 100-1' and 'Passport' models that have a different OS. Also, some phones have different radios. The groups that Sachesi has placed the phone models in to are groups that have 100% identical OS and Radio code. So, yes, Q10 = Q5 = Porsche. All these phones run identical firmware.

    You definitely want to use that firmware. It is not related to Porsche whatsoever. There's nothing special about it that makes it any different. Whenever Blackberry compiles a firmware for Porsche, they use that exact same code for Q10 and Q5. That is, not a single bit is changed.

    I am running this on my Q10 by the way (updated via Sachesi) without any issues.

    Another important thing to remember is that: Sachesi automatically converts links to your device. So, if you have connected a phone to your computer and you try to download this Porsche (Q10/Q5) firmware, it will automatically convert the links to work for your phone.
    The way it does this is futureproof. It doesn't try to work out your device or anything like this. It simply uses the name of the currently installed firmware on your phone and then downloads this from the Blackberry download server. This guarantees you get only exactly what you had already installed on your phone (but a newer version).
    If the firmware doesn't exist, it tells you this. If you try to install an incompatible firmware, it tells you this.
    Last edited by xsacha; 09-28-14 at 09:10 AM.
    09-28-14 08:53 AM
  24. EdY's Avatar
    Thanks for the explanation.

    I have unsuccessfully tried to update the DAC a few times now... It goes through the installation, reboots the phone, but at the end of the day it is unchanged. So I am trying another method, perhaps you can confirm if this the way to go about it.

    I downloaded the Autoloader on the Dev Alpha BlackBerry developer site, for the SQN 100-3. It is about 1.8gb. I am using Sachesi to extract all the apps, which it has created in a subfolder called "Autoload-SQN100-3-10.3.0.700" which is the autoloader exe file name. It put 128 bar files in there, most of them sys.* and some com.*.

    Then it created another folder called "Autoload-SQN100-3-10.3.0.7002" and put another 128 bar files in there, looks like the same names, and even the same size folder as the .700 one... it is about 741 mb.

    So I assume I need to extract the core and radio, but they make .signed files.... can I use Sachesi to take apart this Autoloader this way and install it non-destructively? What do I with the .signed files?
    09-28-14 11:50 AM
  25. xsacha's Avatar
    Probably not the autoloader you want. That's an SDK release without any decent apps or features.
    If you use the latest autoloader (1154) you're just going to get the files you already have from Sachesi when you extract though.

    You can't turn .signed (from Autoloader) in to .bar, you'd have to download those .bar separately.

    Main issue is your phone not changing OS through update for some reason.
    09-28-14 12:11 PM
638 ... 910111213 ...

Similar Threads

  1. How to uninstall amazon app on 10.3.0.1154
    By chu duc binh in forum BlackBerry 10 OS
    Replies: 21
    Last Post: 05-03-16, 03:58 PM
  2. snap app installer folder
    By pryde aw in forum BlackBerry Q10
    Replies: 23
    Last Post: 10-13-14, 03:49 AM
  3. Blackberry 10.3 OS in Blackberry z10
    By Erman Loy1 in forum BlackBerry Z10
    Replies: 4
    Last Post: 09-09-14, 03:48 PM
  4. Passport available in Germany right from the beginning
    By Sequester#WN in forum BlackBerry Passport
    Replies: 4
    Last Post: 09-09-14, 03:12 PM
  5. The BlackBerry Beta Zone gets a small bug fixing update
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 09-09-14, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD