11-05-18 06:24 PM
3,576 ... 9192939495 ...
tools
  1. D ST's Avatar
    Here is all okay with 1.5.0...no Problem wit Windows 8.1.1 Update 2...all runs greate.
    08-30-14 04:21 PM
  2. yhamaie's Avatar
    Here is all okay with 1.5.0...no Problem wit Windows 8.1.1 Update 2...all runs greate.

    Would you please compare the following files to those extracted on your PC?

    ----------

    C:\BlackBerry\Sachesi-1.5.0-Win> dir /s

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win

    2014/08/30 08:52 Qt
    2014/08/30 08:52 QtQuick
    2014/08/30 08:52 QtQuick.2
    2014/08/30 04:55 26,564,608 Sachesi.exe

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\Qt

    2014/08/30 08:52 labs

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\Qt\labs

    2014/08/30 08:52 settings

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\Qt\labs\settings

    2014/06/19 20:08 103 qmldir

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick

    2014/08/30 08:52 Controls
    2014/08/30 08:52 Layouts
    2014/08/30 08:52 PrivateWidgets
    2014/08/30 08:52 Window.2

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick\Controls

    2014/06/19 20:07 111 qmldir

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick\Layouts

    2014/06/19 20:07 107 qmldir

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick\PrivateWidgets

    2014/06/19 20:07 116 qmldir

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick\Window.2

    2014/06/19 20:08 99 qmldir

    Directory of C:\BlackBerry\Sachesi-1.5.0-Win\QtQuick.2

    2014/06/19 20:08 88 qmldir

    Posted via CB10
    08-30-14 05:18 PM
  3. babaroga's Avatar
    yes, just extracted and I have 64 bit professional, yet to try on my enterprise desktop, but don't expect it to fail ... will post update on this reply when i turn it on.


    Attachment 294658

    As expected it's running fine. I had to install couple of microsoft C++ stuff on v 1.4 ...

    I have Win Enterprise/8.1.1/64bit and it doesn't work
    08-30-14 05:24 PM
  4. D ST's Avatar
    yhamaie
    yes the same....qmldir from 19.06.2014 and other the same from your Post!
    08-30-14 05:33 PM
  5. stealthbob's Avatar
    I am having difficulty getting any version to work for me.

    I have been reading through many pages of this thread and am having difficulty finding the answer to my issue and am hoping someone can help.

    I can not load any .bar files, all versions crash on me when attempted. This latest version comes back with this:

    Communication Error: 2 (Connection closed) from (my ip4 address)

    I do have it connected and link has it open.

    This is an enterprise phone and I would love to gain the benefit of side-loading but I cant enable the developer mode due to restrictions. I understand this program will work with enterprise and no need for the developer mode.

    Surely I am missing something simple...just having difficulty finding it. I would appreciate any guidance that may get me over this barrier.

    Thanks
    08-30-14 07:57 PM
  6. xsacha's Avatar
    I can not load any .bar files, all versions crash on me when attempted. This latest version comes back with this:

    Communication Error: 2 (Connection closed) from (my ip4 address)

    I do have it connected and link has it open.

    This is an enterprise phone and I would love to gain the benefit of side-loading but I cant enable the developer mode due to restrictions. I understand this program will work with enterprise and no need for the developer mode.
    Since v10.2, enterprise mode cannot load .bar files no matter what. It will get to 50% (sending to phone) and then the phone will refuse to install it.
    However, this doesn't appear to be related to your issue as the connection should still work.

    If it's saying connection refused, that means that your OS or device is preventing the connection. This could mean the OS or an application that handles communication on your OS (such as antivirus?) is blocking the connection from Sachesi. I don't really know why some anti-virus do this as it makes very little sense to block USB connections but people have reported that this is the case.
    stealthbob likes this.
    08-30-14 08:10 PM
  7. stealthbob's Avatar
    As I am limited with the enterprise issue I guess its a moot point for me now. I will still however keep testing to get past the initial comm issue...

    Hey, big thanks for getting back to me. I made it through many pages in this thread but not to the 10.2 part and enterprise.

    I assume its a security issue, if so I don't mind....glad to have good security. My only issue with 1052 is with Dropbox and I see there is an updated version in 1130 so I wanted to test it. I could just wipe off the phone load what I want and ask for another activation again from IT next week but don't want to push my luck.

    I am approved to get the Passport when it comes in so I can happily wait.....
    08-30-14 08:28 PM
  8. yhamaie's Avatar
    yes the same....qmldir from 19.06.2014 and other the same from your Post!
    Thank you so much.

    I have even tried to invoke Sachesi.exe (Version 1.5.0) on my Windows Server machines (2008 as well as 2012) . . . only to watch blank windows popping up on displays. I have also tried in vain various VCredist (Visual C++ Redistributable) installers (2010, 2012, and 2013).

    I have not yet been able to figure out what is missing in common from my client and server PCs running Windows XP, Windows 7, Windows 8.1, Windows Server 2008, and Windows Server 2012.
    08-30-14 10:02 PM
  9. ralfyguy's Avatar
    It is astounding that 1.2.1 worked for pretty much anybody. Can this version not being updated to the capabilities the latest version has?

    Posted via CB10
    08-30-14 10:47 PM
  10. George_B's Avatar
    Xsacha,

    Using Sachesi 1.4. Had difficulty connecting Q10 to my iMac.

    Had used Autoloader to install 10.3.0.1052 yesterday.

    Changed Q10 USB connection to 'Connect to Mac'

    Works fine in Install tab, but not on Backup tab.

    When I click on Load Backup Options,
    I receive an error messaage

    noauth: loginsession=j3SA5GieBl8lCKJU3lb;
    dtmauth=53ZL5CA7739wA84SeMs210URx;74C9FsjVa4s98167 42cRrw0Z4snzr34buWvzQPH2Ap70aJCM4tZ94

    I did not try to load anything with Install. The screen did show the files in the device - OS, radio,...

    Able to use Backup on a PC earlier, while the USB Connection was set to Autodetect.
    08-30-14 11:11 PM
  11. xsacha's Avatar
    Xsacha,

    Using Sachesi 1.4. Had difficulty connecting Q10 to my iMac.

    Had used Autoloader to install 10.3.0.1052 yesterday.

    Changed Q10 USB connection to 'Connect to Mac'

    Works fine in Install tab, but not on Backup tab.

    When I click on Load Backup Options,
    I receive an error messaage

    noauth: loginsession=j3SA5GieBl8lCKJU3lb;
    dtmauth=53ZL5CA7739wA84SeMs210URx;74C9FsjVa4s98167 42cRrw0Z4snzr34buWvzQPH2Ap70aJCM4tZ94
    Sounds like it lost auth during the backup. This can happen if another app tries to auth at the same time. Was this reproducible or just a one-off?
    Backup takes about 5 seconds to return a result and while this is happening nothing else can talk to the device. For some reason, communication is blocking so Link can't talk while Sachesi talks and vice-versa. This is why I don't do 'Load backup Options' by default and require the user to manually click on it.

    I did a few tests backup and restoring on Mac OSX 10.9 and it seems to flow smoothly. I don't have Blackberry Link installed. Hopefully it was just a one-off for you.
    08-31-14 12:19 AM
  12. yhamaie's Avatar
    Mmm, difficult to tell without debugger.
    Would it be possible to slightly modify Sachesi.exe so that it will write in a .log file the progress of its start-up process?

    I will try to make it entirely standalone.
    It appears that somebody else has bumped into a similar problem.

    c++ - Deploying Qt Qml App to Windows shows me a blank window - Stack Overflow

    P.S.

    May I ask what files are referred to in Sachesi.exe (Version 1.5.0)?

    example

    Rename Files
    + Qt
    + labs
    + folderlistmodel
    - plugins.qmltypes
    - qmldir
    - qmlfolderlistmodelplugin.dll
    + QtQuick.2
    - plugins.qmltypes
    - qmldir
    - qtquick2plugin.dll
    - icon_rc_res.o
    - icudt52.dll
    - icuin51.dll
    - icuuc51.dll
    - libgcc_s_dw2-1.dll
    - libstdc++-6.dll
    - libwinpthread-1.dll
    - main.o
    - moc_qtquick2applicationviewer.o
    - moc_renamer.o
    - qrc_resource_file.o
    - Qt5Core.dll
    - Qt5Gui.dll
    - Qt5Network.dll
    - Qt5Qml.dll
    - Qt5Quick.dll
    - Qt5Script.dll
    - Qt5V8.dll
    - qtquick2applicationviewer.o
    - Rename Files.exe
    - rename.o
    Last edited by yhamaie; 08-31-14 at 02:10 AM.
    08-31-14 12:21 AM
  13. xsacha's Avatar
    I've repacked the application without any additional files needed. It also fixes the drag and drop bug.
    Try the new version.

    Would it be possible to slightly modify Sachesi.exe so that it will write in a .log file the progress of its start-up process?
    None of those files listed are actually needed. I can make it produce a log when it hits an error and will have that for the next version.
    08-31-14 02:46 AM
  14. yhamaie's Avatar
    Try the new version.
    Thank you very much . . . Version 1.5.0.1

    C:\BlackBerry> dir Sachesi.*
    Directory of C:\BlackBerry
    2014/08/31 15:11 26,558,976 Sachesi.exe

    downloaded from https://github.com/xsacha/Sachesi/releases/latest has ended up in blank windows on my PCs running Windows XP (32 bit), Windows 7 (32 bit), and Windows 8.1 (64 bit). I have started double-checking OpenGL settings of these PCs.
    Last edited by yhamaie; 08-31-14 at 04:17 AM.
    08-31-14 03:05 AM
  15. CyberMan2013's Avatar
    I've repacked the application without any additional files needed. It also fixes the drag and drop bug.
    Try the new version.


    None of those files listed are actually needed. I can make it produce a log when it hits an error and will have that for the next version.
    Just tried installing Sachesi 1.4.0 bar (using Sachesi Windows 1.5.0.1) on my STL100-1 via drag and drop using Windows 7 Pro 64 bit and got Error 533, something about file is not a zip file. Using the button worked fine. Either method works fine on version 1.2.3.

    Posted via CB10
    08-31-14 04:32 AM
  16. D ST's Avatar
    Xsacha what have you change in your new Sachesi Windows 1.5.0.2.exe Download.
    It runs without Folder Files in the zip File very good.

    Change-Log!
    08-31-14 05:45 AM
  17. xsacha's Avatar
    OK, I uploaded 1.5.0.2 which will now report an error if loading failed. Also, drag and drop should be working now for Windows.
    08-31-14 05:45 AM
  18. babaroga's Avatar
    OK, I uploaded 1.5.0.2 which will now report an error if loading failed. Also, drag and drop should be working now for Windows.
    Just tried 1.5.0.2 and doesn't work (Win Enterprise/8.1.1/64bit).
    What shall I do?
    Attached Thumbnails Sachesi: Firmware Extractor, Searcher and Installer-2.png  
    08-31-14 06:12 AM
  19. xsacha's Avatar
    Just tried 1.5.0.2 and doesn't work (Win Enterprise/8.1.1/64bit).
    What shall I do?
    Eeks. No error message? That's confusing. If you run it from a terminal window, is there any output?
    Shift + right click inside that window in background -> Open command prompt here.
    Then type in: Sachesi
    08-31-14 06:17 AM
  20. babaroga's Avatar
    Eeks. No error message? That's confusing. If you run it from a terminal window, is there any output?
    Shift + right click inside that window in background -> Open command prompt here.
    Then type in: Sachesi
    In opened window can't execute command prompt, nothing happen.
    Copied sachesi.exe on C and then command prompt as Admin, same thing
    Attached Thumbnails Sachesi: Firmware Extractor, Searcher and Installer-3.png  
    08-31-14 06:24 AM
  21. xsacha's Avatar
    In opened window can't execute command prompt, nothing happen.
    Copied sachesi.exe on C and then command prompt as Admin, same thing
    You shouldn't need Admin privileges for anything in Sachesi. Is there a way to see what blocked it from loading without admin?
    08-31-14 06:38 AM
  22. babaroga's Avatar
    The samo and no info on what is blocked
    Sachesi: Firmware Extractor, Searcher and Installer-img_20140831_124331.jpg

    Posted via CB10
    08-31-14 06:44 AM
  23. xsacha's Avatar
    The samo and no info on what is blocked
    What video card is this running on?
    08-31-14 07:13 AM
  24. babaroga's Avatar
    Sachesi: Firmware Extractor, Searcher and Installer-img_20140831_134042.jpg

    Posted via CB10
    08-31-14 07:41 AM
  25. dev3011's Avatar
    I got a problem with building autoloaders.
    Each time I make an autoloader and open the exe it says "program too big to fit in memory" (in the black Dos window). This only happens with autoloaders I built myself, the autoloaders I download work. I tried this with multiple .signed files (combining core os and radio) and both Sachesi 1.4.0 and 1.5.0.
    Somebody knows what's going wrong?
    08-31-14 07:45 AM
3,576 ... 9192939495 ...

Similar Threads

  1. Replies: 41
    Last Post: 01-09-16, 12:03 PM
  2. Q10 shows "4G" and Z10 shows "4GLTE"
    By BGQ10 in forum BlackBerry Q10
    Replies: 22
    Last Post: 01-20-14, 11:31 AM
  3. BlackBerry needs to get BB10 in cars, and fast!
    By BlackBerry_Pwner in forum General BlackBerry Discussion
    Replies: 19
    Last Post: 09-17-13, 10:26 AM
  4. Suggestion: BBM Forum for x-platform BBM software and features
    By lorax1284 in forum Site Feedback & Help
    Replies: 2
    Last Post: 07-05-13, 07:01 PM
  5. July 9th Blackberry Webcast What do you expect and What do you want to hear?
    By Wilsonia Goldens in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 07-04-13, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD