1. 69goat's Avatar
    Having some issues getting sachesi to recognize my phone, since updating to Ubuntu 15.04. Seems to see the phone, but times out when trying to login. I'll try removing the password, but it seems to be detecting the phone differently than it was in 14.10. I kinda regret updating since 14.10 was getting really stable. Anyone else have any problems on latest Ubuntu?
    Yes I was having problems connecting also with a 15.05 Lubuntu. Here is what I did to get a connection. Edit /etc/network/interfaces and add this
    Code:
    auto usb0 
    iface usb0 inet dhcp
    Then save it and run
    Code:
    sudo /etc/init.d/networking restart
    That worked for me.
    05-07-15 06:48 PM
  2. Joseph Sochet's Avatar
    I should have figured it was not automatically initializing it. I feel insanely silly now. Thank you for the assistance. For some reason, I had to do a restart for it to work completely. I would blame systemd, but that would be a cop-out. Back to studying for boards now after a quick leak update.



    Yes I was having problems connecting also with a 15.05 Lubuntu. Here is what I did to get a connection. Edit /etc/network/interfaces and add this
    Code:
    auto usb0 
    iface usb0 inet dhcp
    Then save it and run
    Code:
    sudo /etc/init.d/networking restart
    That worked for me.
    69goat likes this.
    05-07-15 07:34 PM
  3. 69goat's Avatar
    15.04 beta was working fine, but when I did the upgrade it stopped working. I am also having connection problems with LXQT Manjaro, an Arch based distro. Haven't fixed that yet, but using
    Code:
    sudo dhcpcd
    works. Could be systemd related, or maybe NetworkManager.
    05-08-15 04:36 PM
  4. alaviss's Avatar
    15.04 beta was working fine, but when I did the upgrade it stopped working. I am also having connection problems with LXQT Manjaro, an Arch based distro. Haven't fixed that yet, but using
    Code:
    sudo dhcpcd
    works. Could be systemd related, or maybe NetworkManager.
    You need to initialize TCP/IP connection to your phone with an DHCP client (eg. dhcpcd, dhclient,...) before Sachesi could work

    You could activate the connection using systemd:

    NOTE: Assuming your phone modem interface is usb0, this could be different between machines

    Code:
    # systemctl start dhcpcd@usb0
    Z10STL100-1/10.3.2.500
    69goat likes this.
    05-10-15 01:08 AM
  5. 69goat's Avatar
    You need to initialize TCP/IP connection to your phone with an DHCP client (eg. dhcpcd, dhclient,...) before Sachesi could work

    You could activate the connection using systemd:

    NOTE: Assuming your phone modem interface is usb0, this could be different between machines

    Code:
    # systemctl start dhcpcd@usb0
    Z10STL100-1/10.3.2.500
    What did to get it connect and stick after reboots is this.
    Code:
    # systemctl enable dhcpcd@enp0s29f7u4
    # systemctl start dhcpcd@enp0s29f7u4
    With enp0s29f7u4 being usb0. Seems to stay now after reboots and no more need to run sudo dhcpcd every time I want to connect.

    Thanks. I have just started using an Arch based distro and liking it so far.
    05-10-15 09:24 AM
  6. minttea's Avatar
    Hi all

    First timer here, more used to BBOS..
    Have installed Sachesi 2.0 on my mac, and having 'an issue connecting' on the Backup and Install tab. Development mode on, usb mass storage is off.. Blackberry Device Manager also requests password when I connect usb, then disappears. Not sure if this is expected. Also, Sachesi says '3 possible devices', again not sure (edit: thought this might be old backups so deleted, same thing).

    Any advice appreciated.

    Sachesi: Firmware Extractor, Searcher and Installer-screen-shot-2015-05-19-14.07.32.png

    Sachesi: Firmware Extractor, Searcher and Installer-screen-shot-2015-05-19-14.01.57.png
    Last edited by minttea; 05-19-15 at 08:41 AM.
    05-19-15 08:10 AM
  7. minttea's Avatar
    I've since deleted, reinstalled Link & Blend, downgraded Sachesi to 1.9.5, same issue.
    Edit: 1.9.5 is a bit hit and miss, so will stick to autoloaders on my windoze server.



    Hi all

    First timer here, more used to BBOS..
    Have installed Sachesi 2.0 on my mac, and having 'an issue connecting' on the Backup and Install tab. Development mode on, usb mass storage is off.. Blackberry Device Manager also requests password when I connect usb, then disappears. Not sure if this is expected. Also, Sachesi says '3 possible devices', again not sure (edit: thought this might be old backups so deleted, same thing).

    Any advice appreciated.

    Click image for larger version. 

Name:	Screen Shot 2015-05-19 at 14.07.32.png 
Views:	418 
Size:	47.4 KB 
ID:	353553

    Click image for larger version. 

Name:	Screen Shot 2015-05-19 at 14.01.57.png 
Views:	419 
Size:	46.2 KB 
ID:	353552
    Last edited by minttea; 05-24-15 at 04:18 AM.
    05-21-15 10:30 AM
  8. Mr4aces's Avatar
    @xsacha
    Thank you for a great program. I have learned so much in the past 2 months, your postings and assistance is very much appreciated
    05-23-15 03:41 PM
  9. Paul86's Avatar
    Have a weird issue with the latest version of Sachesi on Windows 7. When I open the app, I get the icon in the task bar, but the app window doesn't appear. Redownloaded the app, restarted. Is there a fix anyone can think of?

    Posted via CB10
    05-23-15 08:05 PM
  10. Paul86's Avatar
    Have a weird issue with the latest version of Sachesi on Windows 7. When I open the app, I get the icon in the task bar, but the app window doesn't appear. Redownloaded the app, restarted. Is there a fix anyone can think of?

    Posted via CB10
    So I right clicked on the window preview and selected maximize. I thought it was something simple like window not having focus


    Sachesi: Firmware Extractor, Searcher and Installer-img_20150523_212937.jpg

    Posted via CB10
    05-23-15 08:30 PM
  11. Mr_Runningfromlife's Avatar
    what has been the latest leaked OS that has been running smoothly on devices. Im running an old 10.3.1 and its starting to get really slow and buggy. I was wondering what any of you would suggest for a new OS
    05-24-15 10:14 AM
  12. Akure4Life's Avatar
    I am using Sachesi 2.0.0 RC for windows.

    It stopped working about a week ago. I have gone through every single possibilities to get it working bit no joy

    My laptop is running Windows 7

    Posted Via CB10 From My Z30 Running On OS10.3.2.680
    05-26-15 05:14 AM
  13. TheOmegaGamer's Avatar
    i've been looking all around the forums and cant find the post that lists all the carrier codes. we really need a sticky for this stuff! and im talking about a detailed list of which code is which carrier, not what code gives the latest update!
    05-26-15 09:59 PM
  14. John Clark's Avatar
    05-26-15 10:08 PM
  15. conite's Avatar
    i've been looking all around the forums and cant find the post that lists all the carrier codes. we really need a sticky for this stuff! and im talking about a detailed list of which code is which carrier, not what code gives the latest update!
    You'll find a link to that within Sachesi.

    Z30STA100-5/10.3.2.680
    raw_dog likes this.
    05-31-15 11:43 AM
  16. katiepea's Avatar
    is anyone able to build this with arch? yaourt yields errors:

    Makefile:794: recipe for target 'rcfs.o' failed
    make: *** [rcfs.o] Error 1
    ==> ERROR: A failure occurred in build().
    Aborting...
    ==> ERROR: Makepkg was unable to build sachesi-git.
    ==> Restart building sachesi-git ? [y/N]
    ==> ------------------------------------
    ==>
    Last edited by katiepea; 05-31-15 at 08:45 PM.
    05-31-15 03:42 PM
  17. santhoshmanikandan's Avatar
    Can't connect my phone to Sachesi in Linux. Sachesi doesn't seem to get connected. Any fix?

    Edit: got the answer in the last page

    Posted via CB10
    Last edited by santhoshmanikandan; 06-01-15 at 02:00 AM.
    BallRockReaper likes this.
    06-01-15 01:37 AM
  18. alaviss's Avatar
    is anyone able to build this with arch? yaourt yields errors:

    Makefile:794: recipe for target 'rcfs.o' failed
    make: *** [rcfs.o] Error 1
    ==> ERROR: A failure occurred in build().
    Aborting...
    ==> ERROR: Makepkg was unable to build sachesi-git.
    ==> Restart building sachesi-git ? [y/N]
    ==> ------------------------------------
    ==>
    Hi, I'm the maintainer of sachesi-git. Could you provide full log (post it on pastebin please)? The ERROR line doesn't explain anything.

    Z10STL100-1/10.3.2.680
    06-02-15 06:50 PM
  19. Akure4Life's Avatar
    I was using Sachesi 2.0.0rc for windows.

    When I run the application, I can see it on the taskbar but it won't open

    Posted Via CB10 From My Z30 Running On OS10.3.2.680
    06-02-15 07:57 PM
  20. katiepea's Avatar
    Hi, I'm the maintainer of sachesi-git. Could you provide full log (post it on pastebin please)? The ERROR line doesn't explain anything.

    Z10STL100-1/10.3.2.680


    I thought maybe it was failing because of utf-8 not outputting for $LANG, I was having that problem, as other packages weren't building but I solved that and everything else will build for me except this one still.

    http://pastebin.com/wKCqyct8
    06-03-15 06:58 PM
  21. alaviss's Avatar
    I thought maybe it was failing because of utf-8 not outputting for $LANG, I was having that problem, as other packages weren't building but I solved that and everything else will build for me except this one still.

    http://pastebin.com/wKCqyct8
    It was falling because of an invaild conversion in the source code.

    This seems to be an upstream error. I will create a fix later when I get on my PC

    Z10STL100-1/10.3.2.798
    Last edited by alaviss; 06-04-15 at 08:59 AM.
    06-04-15 08:46 AM
  22. Legal Eagle's Avatar
    Hi, I'm the maintainer of sachesi-git
    Hi Alaviss

    Many thanks for taking care of Sachesi for us.

    Just checking if you can advise if Scahesi will run on Windows 10, and if not, are there plans to make it compatible.

    Cheers

    Legal
    06-04-15 09:49 AM
  23. alaviss's Avatar
    Hi Alaviss

    Many thanks for taking care of Sachesi for us.

    Just checking if you can advise if Scahesi will run on Windows 10, and if not, are there plans to make it compatible.

    Cheers

    Legal
    Actually I was talking about the arch linux package. But I may look at Windows 10 later. Xsacha hasn't built any new binary (Sachesi now have some new features), maybe building a new one could help.

    Z10STL100-1/10.3.2.798
    Legal Eagle likes this.
    06-04-15 11:06 AM
  24. Legal Eagle's Avatar
    Actually I was talking about the arch linux package. But I may look at Windows 10 later. Xsacha hasn't built any new binary (Sachesi now have some new features), maybe building a new one could help.

    Z10STL100-1/10.3.2.798
    As a tool relied upon and appreciated by many CB members, anyone taking over the development of Sachesi would receive a whole heap of gratitude.

    Given that Microsoft is rolling out Windows 10 as a free upgrade at the end of July compatibility of Sachesi would be awesome as would any updates to the Windows based version.

    Xsacha has laid a great foundation, and if he no longer is willing or able to build on it I sincerely hope that someone else will.
    06-04-15 11:14 AM
  25. 69goat's Avatar
    I have been running it. I just downloading the Sachesi-master.zip and ran qmake, make.

    is anyone able to build this with arch? yaourt yields errors:

    Makefile:794: recipe for target 'rcfs.o' failed
    make: *** [rcfs.o] Error 1
    ==> ERROR: A failure occurred in build().
    Aborting...
    ==> ERROR: Makepkg was unable to build sachesi-git.
    ==> Restart building sachesi-git ? [y/N]
    ==> ------------------------------------
    ==>
    06-06-15 08:24 AM
3,558 ... 129130131132133 ...

Similar Threads

  1. Replies: 41
    Last Post: 01-09-16, 11:03 AM
  2. Q10 shows "4G" and Z10 shows "4GLTE"
    By BGQ10 in forum BlackBerry Q10
    Replies: 22
    Last Post: 01-20-14, 10:31 AM
  3. BlackBerry needs to get BB10 in cars, and fast!
    By BlackBerry_Pwner in forum General BlackBerry Discussion
    Replies: 19
    Last Post: 09-17-13, 09:26 AM
  4. Suggestion: BBM Forum for x-platform BBM software and features
    By lorax1284 in forum Site Feedback & Help
    Replies: 2
    Last Post: 07-05-13, 06:01 PM
  5. July 9th Blackberry Webcast What do you expect and What do you want to hear?
    By Wilsonia Goldens in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 07-04-13, 08:38 AM
LINK TO POST COPIED TO CLIPBOARD