1. yhamaie's Avatar
    I cannot find this in BlackBerry World.
    I have already installed it on my Z30.

    Sachesi: Firmware Extractor, Searcher and Installer-img_20141014_003545.png

    Posted via CB10
    10-13-14 11:37 AM
  2. ralfyguy's Avatar
    Searching for it yields no results.

    Posted via CB10
    Attachment 305704
    10-13-14 12:12 PM
  3. ralfyguy's Avatar
    Found link on Google and it says it is unavailable for my device. So Z10 is not compatible?

    Posted via CB10
    10-13-14 12:20 PM
  4. russnash's Avatar
    Searching for it yields no results.

    Posted via CB10
    Attachment 305704
    Here's a direct link to it:

    Check out Sachesi in BlackBerry World! You can find it at http://appworld.blackberry.com/webst...ntent/59941296

    Posted via CB10
    10-13-14 12:20 PM
  5. ralfyguy's Avatar
    Thank you for the link. Here is the result:

    Sachesi: Firmware Extractor, Searcher and Installer-img_20141013_113612.png

    Posted via CB10
    10-13-14 12:36 PM
  6. xsacha's Avatar
    It requires OS 10.3.
    For OS 10.2, I recommend using the github bar for v1.9.1 for now. It doesn't look as nice but it has more (unapproved by Blackberry) features.
    10-13-14 01:12 PM
  7. russnash's Avatar
    It requires OS 10.3.
    For OS 10.2, I recommend using the github bar for v1.9.1 for now. It doesn't look as nice but it has more (unapproved by Blackberry) features.
    Xsacha, does the github 1.9.1 version have the cascades UI? Is that UI available outside of the BlackBerry World version?

    Posted via CB10
    10-13-14 02:30 PM
  8. xsacha's Avatar
    Xsacha, does the github 1.9.1 version have the cascades UI? Is that UI available outside of the BlackBerry World version?
    No, the 1.9.1 version is the QtQuick cross-platform UI. To make the code easier to maintain, all platforms use the exact same source.
    10-13-14 04:01 PM
  9. georgiesynder's Avatar
    Oh, that's an odd situation.
    What do you see on the phone's screen?

    If nothing there, just pull (it's safe) and plug in again.
    Then probably restart Sachesi in case it's some memory bug and then try again.
    I was following all that advice about "Don't touch the phone!!" But I looked at it like you asked and there was nothing relevant. So I pulled the phone, restarted Sachesi, gave it another go and it worked just fine. Two phones down and 1 to go now....I myself also have a ShopBlackberry unlocked Z10-3, which I was able to update upon receipt in June to OS 10.2.1.3247, long past the TMo divorce with BlackBerry and any OS support from TMo. I can't remember how I did that update, with Link maybe. But trying Link again now to get OS 10.2.1.3337 on my Z10-3 is not going anywhere. Is there another direct way since it is "factory unlocked", or am I going to have to use Sachesi always on this phone also?? Thanks again in advance for your advice and help!
    10-13-14 05:40 PM
  10. PapiPabs's Avatar
    Hadn't seen this mentioned, but I apologize if this has been covered...

    For those using the program on XP SP3: has anyone noticed that the Install Folder option on the Install tab in both 1.9.2 and 1.9.4 appears to function exactly as the Install Files option does. On my PC, it does not allow you to actually choose the directory you've highlighted when selecting Open as it has in the past. It just navigates into the directory. Also, the field usually labeled Directory says File Name (probably the reason for the behavior).

    It looks like the Files of Type field does not have a default option listed in either case, or any options in the drop-down for that matter.
    To follow up, these options are working fine on Windows 7. Could be that something on my XP machine is screwing with those options if nobody else running XP is affected.
    10-13-14 05:54 PM
  11. canook's Avatar
    Edit : figured it out
    Last edited by canook; 10-14-14 at 09:12 AM.
    10-13-14 08:39 PM
  12. yhamaie's Avatar
    To follow up, these options are working fine on Windows 7. Could be that something on my XP machine is screwing with those options if nobody else running XP is affected.
    It does happen on Windows XP.

    May I ask if you have tried drag-and-dropping a folder into Sachesi?

    Posted via CB10
    PapiPabs likes this.
    10-13-14 08:41 PM
  13. PapiPabs's Avatar
    It does happen on Windows XP.

    May I ask if you have tried drag-and-dropping a folder into Sachesi?

    Posted via CB10
    Thanks for confirming.

    I mentioned that I had in my original post on this topic, but figured I would cut it down when I quoted it for the recent post. That worked fine. Just figured I would bring this up in case it wasn't noted yet.

    Posted via BBCBZ10
    10-13-14 08:55 PM
  14. TGD66's Avatar
    Hi xsacha,

    Any chance you can publish a tweeked version 1.9.4 for "Windows XP" like you did with 1.9.0? I'm trying to update the video drivers of the PC I'm using, but since it's the HP Compaq I use at work I'm not having much success with the required driver update...

    Cheers,
    TGD66
    10-14-14 07:43 AM
  15. nah.uhh's Avatar
    Hi xsacha,

    Any chance you can publish a tweeked version 1.9.4 for "Windows XP" like you did with 1.9.0? I'm trying to update the video drivers of the PC I'm using, but since it's the HP Compaq I use at work I'm not having much success with the required driver update...

    Cheers,
    TGD66
    1.4.0 is the version for you

    (right, xsacha?)
    10-14-14 11:37 AM
  16. conite's Avatar
    Guys, stop bugging him about Windows XP. It's 13 years old!!! Move on! The guy has enough on his plate.

    Z30STA100-5/10.3.1.632
    LP_Rigg and Gykesdollars like this.
    10-15-14 08:46 AM
  17. yhamaie's Avatar
    (Including Sachesi 1.9.5) Passport is displayed as choice of default at the bottom section of AppWorld . . . may I ask if there is any plan to unfix this option?

    Posted via CB10
    10-15-14 04:46 PM
  18. ralfyguy's Avatar
    (Including Sachesi 1.9.5) Passport is displayed as choice of default at the bottom section of AppWorld . . . may I ask if there is any plan to unfix this option?

    Posted via CB10
    I wondered about that myself.

    Posted via CB10
    10-15-14 05:27 PM
  19. PapiPabs's Avatar
    Guys, stop bugging him about Windows XP. It's 13 years old!!! Move on! The guy has enough on his plate.

    Z30STA100-5/10.3.1.632
    Sorry, xsacha. Oh, wait...

    It doesn't seem like anyone is demanding anything, especially not in an urgent manner. If xsacha feels the need, he can always drop support for XP. Those of us that have mentioned XP are just pointing things out in case he feels the need to tweak things since he hasn't yet.


    Posted via BBCBZ10
    Last edited by PapiPabs; 10-16-14 at 07:37 AM.
    10-16-14 06:31 AM
  20. xsacha's Avatar
    I can add more options to App World but I'm not sure it is that useful on desktop.

    Sorry, xsacha. Oh, wait...

    It doesn't seem like anyone is demanding anything, especially not in an urgent manner. If xsacha feels the need, he can always drop support for XP. Those of us that have mentioned XP are just pointing things out in case he feels the need to tweak things since he hasn't yet.
    I'm not dropping support for XP. All these versions work perfectly on Windows XP. I can confirm 1.9.1, 1.9.2, 1.9.3, 1.9.4 and 1.9.5 all work perfectly on Windows XP. It also supports remote desktop.
    The problem is only people with very very old graphics drivers that don't support direct x 9.0c. Note: Intel integrated works fine.
    10-16-14 07:53 AM
  21. PapiPabs's Avatar
    I'm not dropping support for XP. All these versions work perfectly on Windows XP. I can confirm 1.9.1, 1.9.2, 1.9.3, 1.9.4 and 1.9.5 all work perfectly on Windows XP. It also supports remote desktop.
    The problem is only people with very very old graphics drivers that don't support direct x 9.0c. Note: Intel integrated works fine.
    Sorry for the confusion. I know you haven't dropped support for XP. My reply was towards the person I quoted that was telling people to "stop bugging you" with things we have noticed that may need to be tweaked for XP.

    The recent versions work fine on my XP machine outside of the Install Folders/Files issue that I mentioned. Drag and drop works fine, though. Do you think that could still be caused by graphics drivers? Pretty sure this PC is up to date in that regard, but not the end of the world either way. Just like to use this PC for storage/grunt work, so it is used for backups and OS upgrades here and there.

    Posted via BBCBZ10
    10-16-14 08:16 AM
  22. xsacha's Avatar
    The recent versions work fine on my XP machine outside of the Install Folders/Files issue that I mentioned.
    Has the Folders/Files thing worked on any version for you? Example: 1.4?
    It is probably a Qt bug. I do ask Qt to provide a folder dialog and a file dialog but Qt, it seems, no longer does any compatibility tests on XP.
    No, that's not related to GPU
    10-16-14 08:45 AM
  23. PapiPabs's Avatar
    Has the Folders/Files thing worked on any version for you? Example: 1.4?
    It is probably a Qt bug. I do ask Qt to provide a folder dialog and a file dialog but Qt, it seems, no longer does any compatibility tests on XP.
    No, that's not related to GPU
    Never tried 1.4.0 as 1.2.1 was working well and I stuck with it till now. Looks like that version has almost the same issue, but the drop-down does show a default of Blackberry Installable(*.bar) for both the Folder and .bar(s) options. Both still have Field Name for the label on the file selection box, though.

    Edit: it definitely worked on 1.2.1, though. Not sure how much relevance that has now as you have come so far in terms of the newer versions.


    Posted via BBCBZ10
    10-16-14 09:16 AM
  24. yhamaie's Avatar
    Of course the free version has more features because it has stuff Blackberry won't approve. Although more time and effort is spent on the paid versions UI. It has a special UI just for Blackberry.
    Such a beautiful UI . . .

    Sachesi: Firmware Extractor, Searcher and Installer-img_20141017_074845.png

    Sachesi: Firmware Extractor, Searcher and Installer-img_20141017_074829.png

    Posted via CB10
    10-16-14 06:53 PM
  25. HomeyJay's Avatar
    Hi
    Can anyone please tell me how to go back to the original factory firmware using this program? I'm having a problem with my Q10 and I need to return it to BB with the factory OS!
    Whats the easiest way to do this?
    10-17-14 11:45 AM
3,553 ... 108109110111112 ...

Similar Threads

  1. Replies: 41
    Last Post: 01-09-16, 12:03 PM
  2. Q10 shows "4G" and Z10 shows "4GLTE"
    By BGQ10 in forum BlackBerry Q10
    Replies: 22
    Last Post: 01-20-14, 11:31 AM
  3. BlackBerry needs to get BB10 in cars, and fast!
    By BlackBerry_Pwner in forum General BlackBerry Discussion
    Replies: 19
    Last Post: 09-17-13, 10:26 AM
  4. Suggestion: BBM Forum for x-platform BBM software and features
    By lorax1284 in forum Site Feedback & Help
    Replies: 2
    Last Post: 07-05-13, 07:01 PM
  5. July 9th Blackberry Webcast What do you expect and What do you want to hear?
    By Wilsonia Goldens in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 07-04-13, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD