1. gastr's Avatar
    Two questions:

    I'm a Gmail user and I use Gmail's priority inbox in the browser, in particular the 'starred and unread first' mode. Does BB10.2 have a feature for Gmail users to make the BlackBerry priority inbox mimic the Gmail one somehow? Or does it only have its own rules that may or may not allow you to do something similar?

    I use the starring feature of Gmail to remind myself of emails that I need to follow up on. One thing that annoys me about 10.1 is that starring an email in Gmail doesn't cause it to appear flagged in the Hub, and flagging an email in the Hub doesn't cause it to be starred in Gmail. Has this changed with 10.2 and Priority Inbox?

    Starred items are key to my work flow. I'm concerned that, whilst BB10.2's PI feature sounds great, it doesn't seem particularly useful if I can't use the same work flow in the browser as well. I want to flag/star an email wherever I am and pick up that work flow on another device.

    Posted via CB10
    10-10-13 04:53 AM
  2. Ecm's Avatar
    I've been using Gmail (IMAP) on my Z10 since it launched. Flagging an email on device has always synced back to Gmail giving it starred status -- and vice versa. That was on all the official and leaked OS versions. As with Read/Unread status, this syncs on the interval set under your account settings.

    Google's Priority Inbox views do not sync through to the device, as they don't sync through if you have Gmail set up in the Outlook desktop program. The device is getting the raw info from the Google servers. That said, you can always use the filters in the Hub -- that may help. You can filter by Unread, Flagged, Attachment, (etc.) and any combinations shown in the filter as well. Alternatively, I've been told a couple of the Gmail apps in BB World and available side-loads claim to duplicate the Google PI functionality. (I abandoned the Google PI a while ago, so I didn't pursue them.)

    The BB10 Priority Inbox does work, but isn't quite as flexible as it could be. It does help, though.
    gastr likes this.
    10-10-13 07:17 AM
  3. gastr's Avatar
    @Elessar.cm, thank you so much for your answer, that's exactly what I was after.

    I'm using Exchange rather than IMAP, that's probably why the flagging isn't working. I guess I have to choose between sync'd starred emails and push notifications! I will choose the former because it's very important to me.

    Looking forward to playing with priority inbox.

    Posted via CB10
    10-10-13 07:51 AM
  4. Ecm's Avatar
    @Elessar.cm, thank you so much for your answer, that's exactly what I was after.

    I'm using Exchange rather than IMAP, that's probably why the flagging isn't working. I guess I have to choose between sync'd starred emails and push notifications! I will choose the former because it's very important to me.

    Looking forward to playing with priority inbox.

    Posted via CB10
    I haven't used ActiveSync with Gmail, but the Flagged/Starred status should sync. It does on both of my EAS accounts.

    The Gmail IMAP does push to your device, so you won't lose anything there. The only setup annoyance is that you need to use the "Advanced" mode to be able to set up Gmail to with a SyncTimeframe greater than the default. Unlike EAS, you can't change the sync timeframe after the fact. Also, you'd have to set up calendar and contacts using the CalDav and CarDav options. A minor PITA, but it works just dandy once set up.

    A last note. By default, the Gmail setup will automatically archive messages when you delete from device unless you set particular options within Gmail. See post #4 here for the settings to make messages deleted on device move to Trash in Gmail: http://forums.crackberry.com/blackberry-10-os-f269/email-deleted-z10-but-stays-gmail-773238/#post8638154.

    10-10-13 08:08 AM
  5. gastr's Avatar
    I tried to switch to IMAP and it doesn't seem to have fixed my issue.

    First I edited the account and changed the server from m.google.something to imap.gmail.com and set the port to 993 with SSL enabled. There wasn't a field for outgoing mail. When I hit save it wouldn't work, said it was invalid or something. So I deleted the account and added it again, and BB10 by default used IMAP. It synced all the emails again and email is working. But no syncing of stars/flags in either direction.

    I didn't need to do anything complex in the way of configuration. I don't even get an advanced option actually. I also didn't have to set up anything like CalDav or CardDav. I might be missing something or did something wrong if I didn't experience what you expected?

    Posted via CB10
    10-10-13 08:56 AM
  6. gastr's Avatar
    Oh wait, it does sync them now. Great! Only it takes 15 minutes, despite me having set the sync interval to 5 minutes. What's that all about?

    Posted via CB10
    10-10-13 10:18 AM
  7. Ecm's Avatar
    Oh wait, it does sync them now. Great! Only it takes 15 minutes, despite me having set the sync interval to 5 minutes. What's that all about?

    Posted via CB10
    That's odd. I'd try changing it to a higher time frame, exit then go back and put it back to 5 min.
    10-10-13 12:18 PM
  8. gastr's Avatar
    I changed it to 30, saved, then changed it to 5. It synced the stars right away that I was waiting on from a few minutes earlier. I then starred something else and it took 25 minutes to sync. Think I'll reboot and try again.

    Posted via CB10
    10-10-13 01:35 PM
  9. gastr's Avatar
    Rebooted. No luck. Oh well. I shall put up with it I guess! Very happy to have synced starring again.

    Posted via CB10
    10-10-13 02:30 PM
  10. Ecm's Avatar
    I'm glad your flagged/starred status is syncing finally.

    As Gmail has a few IMAP quirks, I'm betting there are EAS oddities as well. We need someone who's using Gmail via ActiveSync to chime in. You could try PM'ing one of the moderators, ask them to tweak your thread tile to include "ActiveSync". That may get someone's attention.
    10-10-13 03:04 PM
LINK TO POST COPIED TO CLIPBOARD