01-26-14 02:10 PM
27 12
tools
  1. Stwutter's Avatar
    Hi.

    I'm on the latest 10.2.1.1055, and this is some info. from the device monitor that now is available on my Z10...

    Is this PIM/System Usage High?-img_00002122.png

    Are the PIM/System usages exceptionally high? I've seen others posting usages on CB over the past week or so, and these do seem to been considerably higher than most. I ask mainly as I've always had poor battery performance (yes, a heavy user, but still), and was wondering if this just reflects that, or if it's unusual regardless...
    dkreeg likes this.
    11-22-13 07:30 AM
  2. anon1727506's Avatar
    Also on 10.2.1.1055, but checking my last 48hrs PIM Services is only at 3.0% of CPU usage. My biggest CPU user is the SYSTEM at 75%.... but my biggest Battery user is the Display at 80%. Life is usually around 5 hours during the day.

    The Z10 should have come with a free external battery charger, it is a must for the Z10.
    11-22-13 08:27 AM
  3. Stwutter's Avatar
    Also on 10.2.1.1055, but checking my last 48hrs PIM Services is only at 3.0% of CPU usage. My biggest CPU user is the SYSTEM at 75%.... but my biggest Battery user is the Display at 80%. Life is usually around 5 hours during the day.

    The Z10 should have come with a free external battery charger, it is a must for the Z10.
    Cheers.

    I carry 4 spares. Overkill, but i have had one occasion where I got stuck somewhere, and by the time I was back by a charger I was 10% on battery no. 4....
    11-22-13 08:29 AM
  4. meltbox360's Avatar
    System is my biggest drain. Could it be that certain android player functions are logged as system and therefore it's not really system but android apps? I noticed this behavior with native apps that backup texts, they make PIM services do all the work for them so while they are doing heavy lifting the system is logging it as PIM sevices.

    Posted via CB10
    11-23-13 12:07 AM
  5. Stwutter's Avatar
    Well, I had a think about this, and tried a few things, and now, I get this...


    Is this PIM/System Usage High?-img_00002131.png

    OK - it's overnight, but I was up for a lot of it with my 4 week old! Amazing difference. Solution - deleted Twitter again. It had started to settle down on the official 10.2 release, but, as I had found in some 10.1 leaks I had had in the past, the native Twitter app. seems to play havoc with my phone.

    Posted via CB10
    11-23-13 03:33 AM
  6. Stwutter's Avatar
    I know it I have put battery instead of CPU this time, but the CPU has settled hugely, and my battery was draining in a few hours.

    Posted via CB10
    11-23-13 03:37 AM
  7. JamieWilson01's Avatar
    I know it I have put battery instead of CPU this time, but the CPU has settled hugely, and my battery was draining in a few hours.

    Posted via CB10
    When did you install your OS?

    Via CB10 from Scotland while pretty stoned using Z10STL100-2/10.2.1.1055
    11-23-13 07:08 AM
  8. Stwutter's Avatar
    When did you install your OS?

    Via CB10 from Scotland while pretty stoned using Z10STL100-2/10.2.1.1055
    Erm.... last Wednesday I believe

    Posted via CB10
    11-23-13 07:17 AM
  9. guozhongyan's Avatar
    i have the same issue
    11-24-13 08:30 AM
  10. sylvaing's Avatar
    All messages you get are handled by the PIM service, so if you get an above average amount of messages (email, BBM, Facebook, Twitter, etc), this service will show a higher usage.

    The system service also handles all the communications so depending on how heavy you use your phone wireless / wifi, it will impact that service usage.

    Posted via CB10
    11-24-13 08:50 AM
  11. mtvictor's Avatar
    When I first installed 1055, my pim service was the highest, because it needed to settle things, after 8 hours, it went back to normal, no battery drain or hot

    Posted via CB10
    11-24-13 09:58 AM
  12. dkreeg's Avatar
    Thanks OP for posting this. I was having exactly the same issue and considering bumping back down to one of the 10.2.0 leaks. Higher than normal System/pim usage was puzzling me, since I don't run anything but native apps. After deleting the native twitter, things look much better.


    Posted via CB10
    Attached Thumbnails Is this PIM/System Usage High?-img_00000331.png  
    Stwutter likes this.
    11-24-13 12:03 PM
  13. Stwutter's Avatar
    Thanks OP for posting this. I was having exactly the same issue and considering bumping back down to one of the 10.2.0 leaks. Higher than normal System/pim usage was puzzling me, since I don't run anything but native apps. After deleting the native twitter, things look much better.


    Posted via CB10
    Yeah. Twitter was notorious for that on earlier OS's. It seemed to have sorted itself out on the official 10.2, but is a killer on 1055.

    Posted via CB10
    11-24-13 12:16 PM
  14. meltbox360's Avatar
    And suddenly with no changes all is good!
    Is this PIM/System Usage High?-img_00000060.png

    Posted via CB10
    11-25-13 02:36 AM
  15. nnik's Avatar
    Cheers.

    I carry 4 spares. Overkill, but i have had one occasion where I got stuck somewhere, and by the time I was back by a charger I was 10% on battery no. 4....
    what the hell do you guys do? boost your car?

    .
    11-25-13 02:46 AM
  16. Stwutter's Avatar
    what the hell do you guys do? boost your car?

    .
    I run a nuclear power plant off it.

    Posted via CB10
    11-25-13 02:53 AM
  17. tcee-'s Avatar
    This was mine, and has been like this ever since upgrading to 1055.


    Is this PIM/System Usage High?-img_20131096.png

    Deleted twitter. Will report back

    Posted via CB10
    11-27-13 10:40 PM
  18. Norg's Avatar
    Same here, deleted twitter to see if this works for me too.

    Posted via CB10 using my handy dandy STL100-3 ~ 10.2.1.1055 ~ AT&T
    11-27-13 11:00 PM
  19. tcee-'s Avatar
    Did you guys restore data from an older os?

    Posted via CB10
    11-27-13 11:25 PM
  20. Stwutter's Avatar
    Did you guys restore data from an older os?

    Posted via CB10
    I did yes, but the alternative wasn't an option.

    Posted via CB10
    11-28-13 08:40 AM
  21. tcee-'s Avatar
    just wondering whether the data restored from twitter may be messing up our battery life. all my other accounts i had deleted and readded because of a buggy restore.
    11-28-13 08:43 AM
  22. Stwutter's Avatar
    just wondering whether the data restored from twitter may be messing up our battery life. all my other accounts i had deleted and readded because of a buggy restore.
    Possibly. I've always had a major issue with the native Twitter app., which is a shame, as I like being able to reply from the hub. I always got hundreds of old messages appearing in the hub whenever I reset the phone. Ironically, this was totally solved when the official 10.2 was released by my carrier, but came back again when I put the latest leak on - but this time it also caused a huge battery drain, as well as making my hub unresponsive and glitchy for 30-45 mins whenever I reset the phone (which you obviously have to occasionally).

    Happy to stick with Blaq for twitter for now. I'll be very interested to see if the problem still exists when the official .1055 or higher comes along.
    11-28-13 09:07 AM
  23. tcee-'s Avatar
    Not much of a difference after deleting twitter. Light/little usage today


    Is this PIM/System Usage High?-img_20131097.png

    Posted via CB10
    11-28-13 10:53 PM
  24. ThaMunsta's Avatar
    Is this PIM/System Usage High?-img_00001151.png

    I didn't restore. I always load the OS from scratch even with official releases. Seems to work much smoother and faster.

    Posted via CB10
    11-29-13 10:11 AM
  25. Akhter Rasool's Avatar
    mine also i purchased Z30 sme days before and i am crying all the day because i have to carry charger with me, so bad
    Is this PIM/System Usage High?-unnamed.png
    12-04-13 11:04 AM
27 12

Similar Threads

  1. Windows phone is now officially the third Platform. Makes me Sad
    By XyeD_R in forum General BlackBerry Discussion
    Replies: 83
    Last Post: 11-26-13, 09:24 AM
  2. Is it just for the keyboard that keeps you with BlackBerry?
    By AndrewMBaines in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 11-22-13, 03:11 PM
  3. This has Happened ever since I updated to 10.2.1.1055 leak
    By PEDRONUFC in forum BB10 Leaked/Beta OS
    Replies: 12
    Last Post: 11-22-13, 11:07 AM
  4. Goodbye... I'm Breaking this Addiction!
    By Anonymous2039 in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 11-22-13, 10:02 AM
  5. 10.2.1.1055: "Unable to create account at this time"
    By rflan7 in forum BB10 Leaked/Beta OS
    Replies: 4
    Last Post: 11-22-13, 09:19 AM
LINK TO POST COPIED TO CLIPBOARD