01-29-17 01:14 PM
29 12
  1. onlyoneromeo's Avatar

    For about 4 straight days I've gotten the pim svcs to stay at a minimum and today out of nowhere it starts up again! Battery is hot and draining like crazy. I'm running 1055 and i have all my synced settings to manual. This is driving me crazy.
    12-13-13 02:14 PM
  2. pkcable's Avatar
    Bug maybe in the beta?
    12-13-13 03:30 PM
  3. onlyoneromeo's Avatar
    I don't know what it is but they need to fix it. I want to make my z my daily driver but I can't if I can only get 3 hours of battery from it. I know it's a leak but cmon.
    12-13-13 04:16 PM
  4. ivo1969's Avatar
    Same issues here my friend I reinstalled the leak again after security wipe. Added accounts one at a time each day.used contact x to delete doubles I made sure not to copy of sim contacts since I am using exchange server.

    My battery went from 3 hours to more than 16. Same phone same battery but pin is no longer at 80 or 90 percent.

    Posted via CB10
    12-13-13 05:00 PM
  5. MobileMadness002's Avatar
    I don't know what it is but they need to fix it. I want to make my z my daily driver but I can't if I can only get 3 hours of battery from it. I know it's a leak but cmon.

    I would be extremely concerned if it affected everyone, but as it seems to only affect a few if not only one (you) I can't see how it is the result of the OS itself. What email account is it affecting? I have both hotmail and gmail on my device syncing both with PIM and I don't experience the issue you are having.
    12-13-13 05:17 PM
  6. mbranscum's Avatar
    So why are you dual posting in this forum and the beta forum?

    Posted via CB10
    12-13-13 05:19 PM
  7. onlyoneromeo's Avatar
    I didnt dual post. The post got moved.

    And its not only me. Ive read its happening to quite a few people.

    Ivo 1969 can you tell me where you downloaded your copy of the link from? Ill redownload it and do a security swipe and see what happens.
    12-13-13 05:51 PM
  8. heyjohnnybravo's Avatar
    If you've managed to keep it down and it suddenly spikes it would have to be something happening to whatever it's syncing..or something you're inadvertently doing.
    12-13-13 07:15 PM
  9. onlyoneromeo's Avatar
    I wish that was the case but it isnt. I was using it like normal. Browsing the web and looking at facebook when it started getting hot and I looked to see the pim climbing and battery disappear.smh...
    12-13-13 07:48 PM
  10. esuarks's Avatar
    I posted the below on a separate thread, but just thought it would be helpful to post here as well:

    I've got the same issue on both Z30 and Z10 with This just started about 3 days ago that I've noticed. Shutting down, rebooting, no luck. PIM Services is running 20-40 percent on both devices, and System is running at 20-40 percent, even hours after a reboot with nothing running.

    I upgraded both devices to the current '1055 when it was released (what, a month ago?) and both have been running great, good battery life, etc. Then, as mentioned, 3 days ago, *something* happened but I do not know what. I have been adding some of the "BB 25 days of gifts" on the Z30, and I thought maybe something there was causing the problem, but I have not installed any new apps (since maybe 2-3 weeks ago) on my Z10.

    I do not use my devices for Facebook, Twitter, or any social apps. My Z30 has my corporate/BES mail account plus Hotmail and Gmail. My Z10, just my corporate/BES mail account

    I also have a Q10 with, but no SIM, just WiFi. It has yet to experience this issue, but has no mail accounts or social apps in use. Just downloading a bunch of games/apps.

    I also downloaded Data Usage Counter, just to see if there was some data sneaking in or out, but none that it is indicating.

    I also turned off WiFi and mobile network to see if the devices would calm down, but no luck there either.

    I have absolutely no idea what is going on - as mentioned, these devices have been up and running for 3-4 weeks... if anybody has some thoughts out there, I am all ears (and I'm going on vacation in 3 days, and desperately need the battery life, although I'll have my trusty Anker 10,000 mAh charger...).

    Edit: In checking Device Monitor, Battery usage over the last 48 hours, "PIM Services" has consumed 184% of battery life on the Z30 and 169% of battery life on the Z10. What the hell!
    12-13-13 07:54 PM
  11. onlyoneromeo's Avatar
    Aha!!! So its not just me!!! You see!!!
    12-13-13 08:09 PM
  12. BGQ10's Avatar
    Just to share my experience on Q10SQN100-3/

    I have been using this OS ver for months, generally the battery can last me for the day for about 15 hours of above average user usage. I am encountering PIM service high CPU usage issue occasionally (once in 2 weeks) and it can be resolved after restarting the device. Somehow, my Q10 battery could last for more than 24 hours for the first time yesterday. The battery life goes up and down, totally no clue.

    Posted via CB10
    12-13-13 08:42 PM
  13. robsteve's Avatar
    My wife had a problem like this on her Q10. ( a few days ago. I think her PIM services were up to about 40%. I told her to reboot and it stopped happening. She is on a corporate email through EAS and I assumed it was just a problem with the mail server as their mail server has been acting up lately and is being replaced/upgraded today.

    Posted via CB10
    12-13-13 09:20 PM
  14. mf1982's Avatar
    My work email, through Exchange, clears itself off my device every so often. Sometimes I put in my device password (IT requirement), then the device asks again, but clears my email off.

    PIM is super high resyncing all my email. It sucks, but it is beta.

    I heard that 10.2.1 is still a "couple" months from carriers hands, but that newer builds have corrected some of these bugs. I'm looking forward to an official release that I can upgrade to without losing all my sideloaded Android stuff.

    Posted via CB10
    12-13-13 11:20 PM
  15. hverduyckt's Avatar
    Uninstall the native Twitter client

    Posted via CB10
    12-14-13 02:57 AM
  16. Akhter Rasool's Avatar
    I will share what i did
    Erase | Install | Erase
    i erased before install and after i erased again, it worked now i am getting 22 hour battery
    12-14-13 03:05 AM
  17. esuarks's Avatar
    For me, it was my Exchange account (not Gmail, Hotmail or social apps) that was killing the CPU on my two devices (I know this because my Z10 had none of that, just my corporate EAS account). I just deleted the account and reactivated it on my Z30, whereas on my Z10 I had done a full wipe and reactivation. It's very possible that just waiting it out would have worked, but after two days of serious battery drainage and high CPU, I decided to get aggressive on this.

    Edit: One side/interesting note is that the "System" service and "PIM Services" service, when the CPU percentage was added up, would almost always equal 50% of all CPU services. For example, I'd see constantly changing CPU percentages for both, along the lines of "38%" and "11%", "1%" and "49%", "22% and "27%", etc. And it would alternate between the two services. Just weird.
    Last edited by esuarks; 12-15-13 at 01:20 AM.
    12-15-13 01:01 AM
  18. guozhongyan's Avatar
    same issue when i try to sync my google contacts...83% pin service cpu usage!!!!
    12-24-13 11:57 PM
  19. Alberto8's Avatar
    Exchange active sync has always been problematic for me. My work account often freezes in the hub and it corresponds with system going to 50% and huge battery drain. After a few minutes, it resolved itself.

    Doing de digging with the system I found that whenever this happens the ip connection to the exchange server is listed as close_wait.

    We think there is a timing problem with out main firewall. The thing is that we don't have this issue with android or ios handsets.

    We've had this issue since 10.0. Hopefully blackberry devs will eventually correct this.

    Posted via CB10
    12-25-13 12:24 AM
  20. Gearheadaddy's Avatar

    For about 4 straight days I've gotten the pim svcs to stay at a minimum and today out of nowhere it starts up again! Battery is hot and draining like crazy. I'm running 1055 and i have all my synced settings to manual. This is driving me crazy.
    When you have synced settings to manual, you are telling your phone to sync EVERY time you check an email. Set it to 24 hours to save a lot more battery. That way it syncs once a day.

    Posted via CB10
    12-25-13 09:51 AM
  21. onlyoneromeo's Avatar
    Thanks for the tip
    I'll change my settings and see how that works.

    Posted via CB10
    12-27-13 12:50 AM
  22. bluelights's Avatar
    Just a stab in the dark, why don't you disable the requirement for a device password in the active sync policy on the exchange server!

    Mine was a slightly different issue with my exchange account, every so often the phone kept asking me to enter the pass code, so I disabled it on the exchange server and the last few days have been far more peaceful.

    Posted via CB10
    12-27-13 02:38 AM
  23. AmarBw's Avatar
    Lol. Funnily this problem now effects me after I did the official OS update.
    02-14-14 07:52 PM
  24. Akshay Borkar's Avatar
    03-11-14 02:48 PM
  25. katiepea's Avatar
    I've had this issue sporadically since I first got the phone, on every OS it's seen from official to leaked. Some days it's fine, others PIM services will rip through my battery in 3 hours without use. I've caught it happening and watched the data passing through my router, it seems to be caused by email attachments, specifically with my gmail accounts, as I have deleted specific messages and PIM idled down. I personally believe it to be some sort of bug with imap, though I can't verify that.
    DSS900 likes this.
    03-11-14 03:39 PM
29 12

Similar Threads

  1. Disappointed with Blackberry service
    By bapi3113 in forum BlackBerry Z30
    Replies: 17
    Last Post: 12-13-13, 09:06 PM
  2. Accessing the "My Service Canada " account from a BB10 phone
    By BlackberryCanada in forum BlackBerry Q5
    Replies: 8
    Last Post: 12-12-13, 08:35 PM
  3. Rocky Mountain Human Services Chooses BlackBerry
    By amazinglygraceless in forum News & Rumors
    Replies: 11
    Last Post: 12-11-13, 06:44 PM
  4. Replies: 2
    Last Post: 12-10-13, 02:32 AM
  5. TMO BES hosted service.
    By deremi in forum BES 10
    Replies: 2
    Last Post: 12-09-13, 02:19 PM