1. paulie_iwin's Avatar
    Hi!
    I am on 1925 with a z10. At night I always turn on flight mode until the morning.
    The problem is that sometimes the location services icon pops up and drains the battery quickly. Please see the attachment.
    This only happened to me in 1925. Anyone else experiencing this? Any fixes?
    Thanks!
    Location service battery drain-img_20140104_080559.png

    Posted via CB10
    01-04-14 02:46 AM
  2. Xoma's Avatar
    Turn them off.

    Z10STL100-2/10.2.1.1925
    01-04-14 03:26 AM
  3. paulie_iwin's Avatar
    If I turn them on I won't be able to use maps or runtastic. Bummer :/

    Posted via CB10
    01-04-14 04:57 AM
  4. Draven2666's Avatar
    If I turn them on I won't be able to use maps or runtastic. Bummer :/

    Posted via CB10
    Turn off when not using said apps. Turn on as needed.

    Posted via CB10
    01-04-14 04:58 AM
  5. Chuck Foltz's Avatar
    Gotta be app requesting updates

    Posted from Z10@10.2.1.1259#ATT via CB10
    01-04-14 12:32 PM
  6. paulie_iwin's Avatar
    As you can see it happens again... guess I am the only one
    Location service battery drain-img_20140105_084652.png

    Posted via CB10
    01-05-14 12:47 AM
  7. balenax's Avatar
    You might have some app open that uses location constantly, maybe some android sideloaded app that runs headless? Take a look at the device monitor tool and see the cpu tab, if you have something there that shouldn't be around.
    Here's my usage, mind i have location turned on all the time, but the other two options there switched off.

    Location service battery drain-img_20140105_115043.png
    Location service battery drain-img_20140105_115432.png

    Posted via CB10
    01-05-14 03:56 AM
  8. magsasaka's Avatar
    Check if foursquare is running on the background. If you're seeing the location icon even if there's no open application running it, location service is still open and running.

    For me, foursquare is the one causing the location service to not automatically shutdown. So I need to manually clause foursquare on the device monitor.

    Posted via CB10
    01-05-14 05:09 AM
  9. Thesmartmale's Avatar
    I have this issue too on 10.2, it's on a lot of times and it's not foursquare, but I have diagnostic turned on, could be it.

    Posted via CB10
    01-05-14 07:02 AM
  10. backfire101's Avatar
    Location services is turned on uses less then 0,01%
    01-05-14 07:12 AM
  11. paulie_iwin's Avatar
    Foursquare is not running in the background adds and diagnostics are turned off.
    I suspect runtastic or waze... also I will turn off wifi and network instead of using flight mode.
    If anything changes I will let you know.

    Posted via CB10
    01-05-14 11:27 AM
  12. Thesmartmale's Avatar
    Foursquare is not running in the background adds and diagnostics are turned off.
    I suspect runtastic or waze... also I will turn off wifi and network instead of using flight mode.
    If anything changes I will let you know.

    Posted via CB10
    It's not waze or Runtastic cause I didn't have those when the issue started appearing.

    Posted via CB10
    01-05-14 12:58 PM
  13. QWKSNKE's Avatar
    Are you continously running apps that use location services throughout the day?

    Posted via CB10. 10.2.1.1925 with 1259 camera/clock
    01-05-14 04:21 PM
  14. howards's Avatar
    I use quick settings to turn it on when I need it and turn it off otherwise.

    Z30 / STA 100-3 / 10.2.1.1259
    01-05-14 05:26 PM
  15. Chuck Foltz's Avatar
    Look what apps have permission to location and u can find what one is using it

    Posted from Z10@10.2.1.1259#ATT via CB10
    01-05-14 07:22 PM
  16. Chuck Foltz's Avatar
    Also check to make sure you turn off location ads. Sometimes it will cause your device to keep updating your location.


    Location service battery drain-img_20140105_202432.png

    Posted from Z10@10.2.1.1259#ATT via CB10
    01-05-14 07:25 PM
  17. jverdera's Avatar
    I have 13 android applications with location permissions, and none of them will allow me to configure turning them off.

    Luckily, I was able to add Location on/off in quick settings. It's a little annoying, but it's actually helped my battery a little. With Android apps come Android drain.

    Posted via CB10
    01-07-14 02:32 PM
  18. magsasaka's Avatar
    With Android apps come Android drain.

    Posted via CB10
    With the Android apps come with the Android problems.

    Posted via CB10
    jverdera likes this.
    01-07-14 05:16 PM
  19. 07thking's Avatar
    Or it could be the fact that almost every app request location services to run. I'm shocked and curious why some apps having nothing to do with your location would request that permission.

    Edit: especially android ones, and the setting for location cannot be disabled.

    Photos captured using BlackBerry devices - C00016D81
    01-08-14 04:16 PM

Similar Threads

  1. Q5 battery saving tips if any ?
    By AmarC84 in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 01-10-14, 11:48 PM
  2. .1925 makes my battery down?
    By arifbsantoso in forum Legacy Leaked/Beta OS
    Replies: 12
    Last Post: 01-07-14, 03:13 PM
  3. Replies: 3
    Last Post: 01-03-14, 10:29 AM
  4. Help! BBLink exe Unable to Locate Component!
    By dgjackson40 in forum BlackBerry Link
    Replies: 2
    Last Post: 01-03-14, 10:28 AM
  5. High usage on system if using twitter- battery drainage
    By migalmeyhmeyhhh in forum BlackBerry Q5
    Replies: 3
    Last Post: 01-02-14, 11:48 PM
LINK TO POST COPIED TO CLIPBOARD