10-19-13 02:51 AM
74 123
tools
  1. anon(4242931)'s Avatar
    OS Delta 4537 to 4633, STL100-2/3 (19MB)
    http://cdn.fs.sl.blackberry.com/fs/q...0_1_0_4537.bar

    Radio Delta 4538 to 4634, STL100-2/3 (13MB)
    http://cdn.fs.sl.blackberry.com/fs/q...0_1_0_4538.bar

    And don't thank me for these links, thank Sacha for figuring it out.


    Obviously, you can't alter the binary file... so did sacha figure out how the 'delta' API on the update server works?


    edit: i forgot to thank you for posting the links! **THANKS!**
    07-26-13 03:41 PM
  2. canu900's Avatar
    I don't even know what this thread is about

    Posted via CB10
    tetonica likes this.
    07-26-13 03:43 PM
  3. anon(4242931)'s Avatar
    Crap. I turned on dev mode, but i keep getting "Error: failure 500 cannot determine Package-Id" when trying to load the OS and radio.

    From what I remember, this happens when the devices does not like the signature of the bar. Can somebody point me in the direction of a solution?
    07-26-13 03:57 PM
  4. DarcyTallGuy's Avatar
    Obviously, you can't alter the binary file... so did sacha figure out how the 'delta' API on the update server works?


    edit: i forgot to thank you for posting the links! **THANKS!**
    I don't know how he figured it out initially, I know I've seen them in url logging when upgrading over wifi, but with just one example it's easy to figure out all possible versions as long as you know what is an official version, like 4633, 4537, 2420, 2354, and so on. Deltas don't exist for leaks.

    Posted via CB10
    07-26-13 03:57 PM
  5. anon(4242931)'s Avatar
    ... but with just one example it's easy to figure out all possible versions as long as you know what is an official version, like 4633, 4537, 2420, 2354, and so on. Deltas don't exist for leaks.

    Posted via CB10

    yup . So am i getting the error 500 because the os i initially installed was a leak?
    07-26-13 04:12 PM
  6. DarcyTallGuy's Avatar
    yup . So am i getting the error 500 because the os i initially installed was a leak?
    If you are on 4537 then it shouldn't matter if it was a leak or not. Make sure you have the latest sachesi version. If that doesn't work, then you may have to get the upgrade files for 4633 and use those. They work the same (they do not wipe the data from your phone), just larger files to download.



    Posted via CB10
    07-26-13 04:17 PM
  7. anon(4242931)'s Avatar
    I've got the linux b5 of sachesi. I'll try out the 4633 files. *fingers crossed*.
    07-26-13 04:22 PM
  8. d3rd's Avatar
    Would love to see a delta from 4543 to 4633 STL100-3. So this is essentially the same as a OTA update? No security wipe required?

    Posted via CB10
    07-26-13 05:34 PM
  9. DarcyTallGuy's Avatar
    Would love to see a delta from 4543 to 4633 STL100-3. So this is essentially the same as a OTA update? No security wipe required?

    Posted via CB10
    There is no delta for 4543. But you can get the upgrade bars for 4633 using sachesi and upgrade your phone using those. No data is lost. The deltas are meant to just be a smaller download because you're only getting what's changed.

    Posted via CB10
    07-26-13 06:28 PM
  10. uaegangster111's Avatar
    There is no delta for 4543. But you can get the upgrade bars for 4633 using sachesi and upgrade your phone using those. No data is lost. The deltas are meant to just be a smaller download because you're only getting what's changed.

    Posted via CB10
    The OS version does not change right?

    Posted via CB10
    07-26-13 06:36 PM
  11. DarcyTallGuy's Avatar
    The OS version does not change right?

    Posted via CB10
    If you get all the files from the upgrade screen then that does include the OS so the OS version should change after its been installed. Just make sure you're using sachesi beta 5 or later as there were some bugs in earlier versions.



    Posted via CB10
    07-26-13 06:46 PM
  12. DarcyTallGuy's Avatar
    The OS version does not change right?

    Posted via CB10
    And if you meant using the deltas, then the version should also change. If it hasn't changed then the delta didn't apply correctly and you should move on and use the upgrade bars until xsacha gets a chance to look at it and see what's happening.

    Posted via CB10
    07-26-13 06:49 PM
  13. uaegangster111's Avatar
    If you get all the files from the upgrade screen then that does include the OS so the OS version should change after its been installed. Just make sure you're using sachesi beta 5 or later as there were some bugs in earlier versions.



    Posted via CB10
    I installed the os delta and radio delta for the Q10 using the sachesi beta 3 and the OS version did not change. Should I redo it using sachesi beta 5?

    Posted via CB10
    07-26-13 06:50 PM
  14. midknightz's Avatar
    Yes, use the '2342 for Q10'.

    Q10 and Z10 firmware is the same. It's just that most Z10 users are on 2354.

    However, I don't have a delta radio linked up there. Just use original 4633 radio -- it's about same size.
    Thanks! Worked like a treat!

    Posted via CB10
    07-26-13 08:00 PM
  15. DarcyTallGuy's Avatar
    I installed the os delta and radio delta for the Q10 using the sachesi beta 3 and the OS version did not change. Should I redo it using sachesi beta 5?

    Posted via CB10
    Yes, probably, b3 had a bug that xsacha has fixed. If it still doesn't change, use the upgrade bars from sachesi for 4633

    Posted via CB10
    07-26-13 08:27 PM
  16. uaegangster111's Avatar
    Yes, probably, b3 had a bug that xsacha has fixed. If it still doesn't change, use the upgrade bars from sachesi for 4633

    Posted via CB10
    Ok I am trying the delta for OS and radio using sachesi Beta 5. Will report back after.

    Posted via CB10
    07-26-13 08:32 PM
  17. uaegangster111's Avatar
    Can't use the sachesi Beta 5. There is a connection problem with the sachesi beta 5

    Posted via CB10
    07-26-13 08:53 PM
  18. xsacha's Avatar
    Can't use the sachesi Beta 5. There is a connection problem with the sachesi beta 5

    Posted via CB10
    What's the connection issue that you are having?
    If you are getting the 'Try again' prompt, that means the phone reported an error. Just click 'Try again' or maybe restart Sachesi.
    Seems to be an issue with new firmwares. This will happen, randomly, with all Sachesi's.
    I will have a workaround when I get back after the weekend.
    07-27-13 09:08 AM
  19. AnimalPak200's Avatar
    I'm getting an error 500 'invalid action' when trying to load the Verizon radio (original). I've been running on 2354 with the 1881 radio. The OS loaded up nicely, but I can't seem to get the radio file on there (I tried both the original and delta). I've tried rebooting a couple times, etc. without any luck.

    Any advice?

    Edit: Oh, and I'm using a freshly-downloaded version of Sachesi b5
    Last edited by AnimalPak200; 07-27-13 at 12:40 PM. Reason: more info
    07-27-13 12:38 PM
  20. uaegangster111's Avatar
    I am using the delta OS and delta radio for Q10. I just got update notification for application update 368MB

    Posted via CB10
    07-29-13 03:22 PM
  21. Lawmen23's Avatar
    Yes, use the '2342 for Q10'.

    Q10 and Z10 firmware is the same. It's just that most Z10 users are on 2354.

    However, I don't have a delta radio linked up there. Just use original 4633 radio -- it's about same size.
    I am also coming from .2342 on the Z10. Installed the OS like it says above and it worked. Trying to update the radio now and it's won't take the radio original or the radio delta. Any advice on the next step? The error is "failure 500 invalid action install" always at 49%.
    07-30-13 02:00 AM
  22. xsacha's Avatar
    Updated for 4651.
    07-30-13 09:17 AM
  23. mobileroundup's Avatar
    I've installed 4633 with Delta Upgrades! It works nice!
    07-30-13 09:41 AM
  24. Lawmen23's Avatar
    I am also coming from .2342 on the Z10. Installed the OS like it says above and it worked. Trying to update the radio now and it's won't take the radio original or the radio delta. Any advice on the next step? The error is "failure 500 invalid action install" always at 49%.
    also, my gmail no longer works...#regretsinstallingdeltas
    07-30-13 09:53 AM
  25. backfire101's Avatar
    Solution, grab entire version with sachup for version 4633 and install. Reboot and add Google account again.

    Posted via CB10
    07-30-13 03:15 PM
74 123

Similar Threads

  1. Replies: 13
    Last Post: 07-26-13, 07:38 AM
  2. What's the latest version of STL-4
    By gainoo in forum BlackBerry Z10
    Replies: 6
    Last Post: 07-25-13, 01:50 PM
  3. Replies: 2
    Last Post: 07-25-13, 10:37 AM
  4. OTA upgrade question
    By torchuser1 in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-25-13, 07:17 AM
  5. Battery Issue Since Upgrade
    By jordonshaw in forum BlackBerry Z10
    Replies: 3
    Last Post: 07-24-13, 09:00 PM
LINK TO POST COPIED TO CLIPBOARD