1. Samuele1996's Avatar
    Hey guys!

    Today I have not one, but two problems!

    I'm running BB 10.3.1.1949 on my Z10STL100-2 and I'm having some problems connecting it to my PC. First things first.

    First part: Windows geeks

    Since I've installed my firts 10.3.x leak I cannot connect my BB to my PC anymore. In 10.3.0 I had solved it simply by manually setting "Connect to a Windows PC" in the phone settings, but now I can't find that option anywhere. The BB Link doesn't recognize my phone and shows me the option to Reload Software.
    I've already tried to uninstall and reinstall it several times, with both rebooting and accurate cleaning every time, but nothing worked. I'm unable to use both BB Link and Blend now.
    An interesting fact could be that every time I had installed/uninstalled BB Link I'd lost my internet connection and this makes me think it's something related to the Network Interface Card drivers... I've tried to remove BB ones, but nothing...
    Can someone help me? I'd really like to start using BB Blend a perform some backups now...

    Second part: Linux "gurus"

    Because of all problems written above, I've tried to use Sachesi under my Netrunner 14 (Ubuntu/Debian based) virtual machine (which does support direct hardware control), but, despite I've Qt Creator installed for other purposes, it won't let me run Sachesi (v. 1.9.9) giving the following error: ./Sachesi: error while loading shared libraries: libQt5Quick.so.5: cannot open shared object file: No such file or directory

    Can someone help me, please? Any suggestion will be much appreciated
    01-26-15 12:39 PM
  2. thurask's Avatar
    From the GitHub page for Sachesi:

    sudo apt-get install qt5-qmake libqt5network5 libqt5qml5 qtdeclarative5-settings-plugin qtdeclarative5-controls-plugin qtdeclarative5-dialogs-plugin qtdeclarative5-quicklayouts-plugin qtdeclarative5-window-plugin qtdeclarative5-qtquick2-plugin

    All of those installed?

    Posted via CB10
    01-26-15 12:40 PM
  3. Samuele1996's Avatar
    Thanks thurask you've solved a part of the Linux problem, even if now VMware reports an error while connecting the device to the virtual machine (it only says: "Driver error"), but, at least, Sachesi starts

    Any idea for the Windows related part?
    01-26-15 12:52 PM
  4. Dodger52's Avatar
    Hey guys!

    Today I have not one, but two problems!

    I'm running BB 10.3.1.1949 on my Z10STL100-2 and I'm having some problems connecting it to my PC. First things first.

    First part: Windows geeks

    Since I've installed my firts 10.3.x leak I cannot connect my BB to my PC anymore. In 10.3.0 I had solved it simply by manually setting "Connect to a Windows PC" in the phone settings, but now I can't find that option anywhere. The BB Link doesn't recognize my phone and shows me the option to Reload Software.
    I've already tried to uninstall and reinstall it several times, with both rebooting and accurate cleaning every time, but nothing worked. I'm unable to use both BB Link and Blend now.
    An interesting fact could be that every time I had installed/uninstalled BB Link I'd lost my internet connection and this makes me think it's something related to the Network Interface Card drivers... I've tried to remove BB ones, but nothing...
    Can someone help me? I'd really like to start using BB Blend a perform some backups now...

    Second part: Linux "gurus"

    Because of all problems written above, I've tried to use Sachesi under my Netrunner 14 (Ubuntu/Debian based) virtual machine (which does support direct hardware control), but, despite I've Qt Creator installed for other purposes, it won't let me run Sachesi (v. 1.9.9) giving the following error: ./Sachesi: error while loading shared libraries: libQt5Quick.so.5: cannot open shared object file: No such file or directory

    Can someone help me, please? Any suggestion will be much appreciated
    Please check device manager in Windows to see if the drivers of the RIM network and USB adapters are properly installed and are working correctly. A yellow 'bang' indicates a problem.

    I've had issues with those RIM network and/ or USB devices before. Uninstalling them than unplugging and reinserting the USB-cable of the BlackBerry. (after a reboot of you're Windows machine) might do the trick.


    It might be that the driver is missing if that's the case this topic will lead you to the page where you can download the appropriate driver:
    https://supportforums.blackberry.com...7/td-p/2104289

    Posted via CB10
    Last edited by Dodger52; 01-26-15 at 02:10 PM.
    01-26-15 01:58 PM
  5. lycan666's Avatar
    Also you can delete all usb devices from device manager and then plug in your phone it will reinstall the drivers

    Posted via CB10
    01-26-15 02:07 PM
  6. Dodger52's Avatar
    Also you can delete all usb devices from device manager and then plug in your phone it will reinstall the drivers

    Posted via CB10
    That was part of the message I was trying to get across but didn't state clearly enough

    Posted via CB10
    01-26-15 02:12 PM
  7. Samuele1996's Avatar
    Hey guys,

    I've partially solved my problem. Now the PC is able to communicate with the BB device again, but BB Blend still doesn't work. I'm gonna dive on this as soon as I've enough time, so stay tuned as I could need some more help.

    These are the steps I've followed so far:
    1. Uninstall BlackBerry Desktop Software
    2. Remove leftover files from common directories (C:\Program Files\, %appdata%\..\, ...)
    3. Open Device Manager and proceed as following:
    ........a. Find leftover devices related to BlackBerry that could be the reason of the problem
    ........b. Right-click on them and Install Software Driver
    ........c. Manually choose drivers and make the procedure install the drivers below
    ........d. Now you should be able to uninstall these devices permanently
    4. Full cleaning with CCleaner
    5. Reboot and wait for rebooting complete
    6. Connect the BlackBerry 10 device to the computer and follow the procedure shown by the devices to install the Desktop Suite
    7. Open BlackBerry Link, configure the account and it should go back working again

    For the records, I leave a zip file containing the intructions and the driver I've used to solve my problem. I hope this will help someone else

    Stay tuned: I'll try to get everything back

    P.S.: It's late here in Italy, so don't complain for the kilo of grammar/spelling/everythingelse mistake I've made or for the fact that I've created this document with notepad and it's disgustingly indented
    Attached Files
    01-26-15 03:50 PM
  8. blueyestm's Avatar
    As someone pointed out to me if you are unaware, Blend requires IPV6 to be on and running. Do you have that on?
    01-26-15 04:34 PM
  9. Samuele1996's Avatar
    Really? IPv6? On both devices? When on WiFi? I absolutely didn't know, but I've been able to use it with my iPad some time ago...

    I'll try soon and let you know

    Thank you very much!

    P.S.: does it need IPv6 even when connecting remotely through the mobile network?

    Posted via CB10
    01-27-15 08:37 AM
  10. blueyestm's Avatar
    I know the desktop needs IPV6 - the phone will get be on IPV6 if you connect to that wifi but I don't know what will happen if you try to use the mobile network.
    01-27-15 01:29 PM

Similar Threads

  1. Passport really just needs call send and end buttons
    By eabbq10 in forum BlackBerry Passport
    Replies: 49
    Last Post: 06-03-16, 06:04 PM
  2. Replies: 11
    Last Post: 01-27-15, 02:29 PM
  3. WIND MOBILE USERS, I need your help!
    By BB30000 in forum BlackBerry Passport
    Replies: 11
    Last Post: 01-26-15, 08:40 PM
  4. who can help in this case??
    By roobert doodaj in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 01-25-15, 01:57 PM
  5. Need new free stickers on my bbm, can't download vd paid ones
    By lordtenyson in forum Ask a Question
    Replies: 1
    Last Post: 01-25-15, 06:42 AM
LINK TO POST COPIED TO CLIPBOARD