01-08-15 09:11 PM
29 12
tools
  1. cybersaga's Avatar
    The windows firewall differentiates between public networks and private networks for wireless networks. (yeah, wifi affects blend) and somehow it makes it so that a usb-connected blackberry won't work when I am using a private wifi network. I went into the firewall interface an enabled everything, but there is still issues.
    Even when you do a USB connection, if it notices that both your computer and your Blackberry are on the same network, it seems to abandon the USB connection and use the wifi. In Blend on your desktop, when you try to connect, you'll see a USB icon inside the picture of a phone. At a certain step, you'll see it change to a wifi icon.

    Try turning off the wifi on your Blackberry, then try Blend over USB. If that works, then you know it can't communicate over wifi for some reason (firewall on your desktop or router maybe).

    I had a ton of trouble with this. For me, it turned out to be Check Point VPN blocking IPv6 traffic even when it wasn't running (this particular version of Check Point installs a firewall driver).
    01-08-15 03:27 PM
  2. OneofLittleHarmony's Avatar
    Even when you do a USB connection, if it notices that both your computer and your Blackberry are on the same network, it seems to abandon the USB connection and use the wifi. In Blend on your desktop, when you try to connect, you'll see a USB icon inside the picture of a phone. At a certain step, you'll see it change to a wifi icon.

    Try turning off the wifi on your Blackberry, then try Blend over USB. If that works, then you know it can't communicate over wifi for some reason (firewall on your desktop or router maybe).

    I had a ton of trouble with this. For me, it turned out to be Check Point VPN blocking IPv6 traffic even when it wasn't running (this particular version of Check Point installs a firewall driver).
    Is there a way to delete the firewall exception so windows will re-enable the dialog box?


    Posted via CB10
    01-08-15 06:24 PM
  3. cybersaga's Avatar
    I don't know about that, but you can explicitly add an exception to the Windows Firewall for an application: Allow a program to communicate through Windows Firewall - Windows Help

    You'll have to add exceptions for the programs listed under the "Overview" section here: KB34794-BlackBerry desktop applications and Internet connectivity
    01-08-15 08:05 PM
  4. lyrian64's Avatar
    I would think the firewall issue is probably due to blackberry ID authentication check instead of it using the Wifi connection to your device when connected via USB. No insider information or actual testing yet, but that's what I would expect when setting up blend for first time. I think the PC /tablet and BlackBerry device authenticate independently to blackberry ID service to ensure a secure connection.

    Just some thoughts...

    Posted via CB10
    01-08-15 09:11 PM
29 12

Similar Threads

  1. Replies: 2
    Last Post: 02-08-15, 07:47 PM
  2. Personal Assistant slow to load?
    By Zetai in forum BB10 Leaked/Beta OS
    Replies: 13
    Last Post: 01-10-15, 11:07 PM
  3. Can't connect to internet?
    By Lawrence Gan in forum BlackBerry Passport
    Replies: 4
    Last Post: 01-05-15, 07:34 AM
  4. How to hide icons?
    By Chrisy in forum Ask a Question
    Replies: 3
    Last Post: 01-04-15, 07:43 PM
  5. Replies: 0
    Last Post: 01-04-15, 08:18 AM
LINK TO POST COPIED TO CLIPBOARD