08-16-15 05:53 PM
99 1234
tools
  1. LP_Rigg's Avatar
    Z10 stl 100-3 on AT&T for me
    05-29-14 11:21 AM
  2. dablessing's Avatar
    Sure.

    The SD/XC cards use a different internal flash management algorithm to handle the bank switching and spare allocation than the HCs. They have to; it's the nature of trying to fit that much storage in the available space.

    The controller's algorithm is incompatible with how FAT32 wants to concentrate I/O during write cycles. If you reformat such a card to FAT32 from exFAT it will eventually fail when written to. You can read from it all day long, but you want to put your camera files on there, right? That means the phone will be writing to it.

    The card's internal management routines will eventually clash with the FAT32 filesystem and you will one day find the card corrupted. Then you'll ***** that the card is defective. It's not.

    Sandisk warns not to reformat these cards off exFAT and so do all the other reputable manufacturers.

    They're not kidding and the requirement to use exFAT on these cards is real.
    Tickerguy:

    Sounds like I had this very issue happen per my thread:

    http://forums.crackberry.com/showthread.php?t=934723

    Now my card won't format at all. I even tried to reformat it in ubuntu using gparted with no luck. Does it sound permanently damaged? Thanks for your help!

    Posted via CB10
    05-29-14 11:51 AM
  3. Lawmen23's Avatar
    I have 3175 and the exFAT drives didn't work for me. Am I missing something?
    05-29-14 10:38 PM
  4. NickMcBride's Avatar
    When i got a 64gb card i dont think i had to format it before it would work in my device. Is there a reason you guys are formatting?

    Posted via CB10 on my ? Q10
    05-29-14 10:44 PM
  5. Gearheadaddy's Avatar
    I took out my SD card, put it into my computer, formatted to exFAT and put it back into my Z30. The driver prompt kicked in then.

    Posted via CB10
    Good to know, thanks again for all your hard work!

    Trusted Member Genius on Verizon 10.3.0.296/442
    05-30-14 04:40 AM
  6. tickerguy's Avatar
    Tickerguy:

    Sounds like I had this very issue happen per my thread:

    SD Card Crash - BlackBerry Forums at CrackBerry.com

    Now my card won't format at all. I even tried to reformat it in ubuntu using gparted with no luck. Does it sound permanently damaged? Thanks for your help!

    Posted via CB10
    Possibly.

    Find someone with a Windows LAPTOP that has an SD card slot and see if you can reformat it to exFAT in there. If you can't then you're probably hosed.

    Plug-in card readers that are commonly built into or added to desktop machines are notoriously buggy and have enough timing slop in them to cause problems. Laptop makers tend to pay better attention to that because getting a machine back as defective due to a 50 cent component is bad for business....
    05-30-14 07:47 AM
  7. tickerguy's Avatar
    When i got a 64gb card i dont think i had to format it before it would work in my device. Is there a reason you guys are formatting?

    Posted via CB10 on my ? Q10
    Said card in the package new does not need to be formatted as it's already exFAT. Because flash-based anything has a limited number of writes formatting shouldn't be done unless necessary, because otherwise you're using up writes for no purpose.
    05-30-14 07:50 AM
  8. Brian Smith22's Avatar
    Hi, has anyone managed to successfully download & install the drivers on the 10.3 leak?

    I keep getting the download failed message

    Posted via CB10
    06-01-14 01:59 AM
  9. hectorchavez@earthlink.net's Avatar
    I use Windows 7 explorer frequently to copy files from my Q10 (OS version 10.2.1.3175) to specific folders on my PC. I previously used a Kingston 16 gb micro card with FAT file format in my Q10 which worked as expected. I just bought a Sandisk microSDXC UHS-1 card, 64 gb (exFat format) which is recognized by my Q10, and seems to work OK in terms of Q10’s file manager and app access. However, when connected to my PC by USB, my PC’s Windows explorer is unable to access the Sandisk card to copy or paste files, or other modifications. This occurs when USB mass storage set to OFF. The Sandisk card is visible in Windows explorer; however, when I click to access the card I get the following Error Message: “Y:\ is not accessible. The handle is invalid.” I did not get this error message or have this problem with the Kingston 16 gb FAT card. Windows explorer accessed the Kingston card as Y: drive without any problem.

    I reformatted the Sandisk card with Q10’s reformat option, and also with my PC to exFAT formatting defaults however the problem persists.

    However, I can access the Sandisk card with Windows explorer to copy, etc. when the Q10's USB mass storage option is turned ON. This is not as convenient and may suggest a compatibility problem. Has anyone else encountered the above error message and resolved it. Suggestions are appreciated.
    06-01-14 08:48 PM
  10. peter0328's Avatar
    I use Windows 7 explorer frequently to copy files from my Q10 (OS version 10.2.1.3175) to specific folders on my PC. I previously used a Kingston 16 gb micro card with FAT file format in my Q10 which worked as expected. I just bought a Sandisk microSDXC UHS-1 card, 64 gb (exFat format) which is recognized by my Q10, and seems to work OK in terms of Q10s file manager and app access. However, when connected to my PC by USB, my PCs Windows explorer is unable to access the Sandisk card to copy or paste files, or other modifications. This occurs when USB mass storage set to OFF. The Sandisk card is visible in Windows explorer; however, when I click to access the card I get the following Error Message: Y:\ is not accessible. The handle is invalid. I did not get this error message or have this problem with the Kingston 16 gb FAT card. Windows explorer accessed the Kingston card as Y: drive without any problem.

    I reformatted the Sandisk card with Q10s reformat option, and also with my PC to exFAT formatting defaults however the problem persists.

    However, I can access the Sandisk card with Windows explorer to copy, etc. when the Q10's USB mass storage option is turned ON. This is not as convenient and may suggest a compatibility problem. Has anyone else encountered the above error message and resolved it. Suggestions are appreciated.
    This happens with everyone right now. I emailed Michael Clewley and his team is already aware and looking into it.

    Posted via CB10
    ordigas likes this.
    06-01-14 11:28 PM
  11. hectorchavez@earthlink.net's Avatar
    Hi Peter0328,

    Thanks for the info. Guess I'll wait for an OS fix rather than return the Sandisk card. I want to take this opportunity to thank ALL the "usual suspects" for all their valuable help and time. I've been lurking in the forums for 6 months learning how to optimize the two Q10s and a Z30 in this household. Verizon (in So. California) is extremely slow to roll out OS updates. Didn't wait and used Sachesi to update. We are now at 10.2.1.3175 love the BB phones even more!!

    Hector
    eldricho and peter0328 like this.
    06-02-14 02:26 AM
  12. yeek's Avatar
    The exFAT support on 10.2.1.3175 is very limited. I recommend not to format you SD Card in exFAT yet.

    As I tested, even though the system recognize the Sd Card, also you can shoot picture and videos on it, but you won't be able to access them directly using apps like Pictures, Videos. Only File manager works.
    06-04-14 11:11 AM
  13. thurask's Avatar
    The exFAT support on 10.2.1.3175 is very limited. I recommend not to format you SD Card in exFAT yet.

    As I tested, even though the system recognize the Sd Card, also you can shoot picture and videos on it, but you won't be able to access them directly using apps like Pictures, Videos. Only File manager works.
    Not really, all of these are on my (exFAT) SD.


    exFAT drivers from 10.2.1.3175 on 10.3.0.296 leak-img_20140604_121643.png
    exFAT drivers from 10.2.1.3175 on 10.3.0.296 leak-img_20140604_121835.png
    exFAT drivers from 10.2.1.3175 on 10.3.0.296 leak-img_20140604_121848.png
    exFAT drivers from 10.2.1.3175 on 10.3.0.296 leak-img_20140604_121955.png

    Posted via CB10
    MrMousey likes this.
    06-04-14 11:20 AM
  14. yeek's Avatar
    Interesting, I am on the official 10.2.1.3175, seems either my BB Pictures or Video apps is able to see my exFAT sd card. Will give it another try using different tool to format and see.
    06-04-14 02:54 PM
  15. HotFix's Avatar
    I keep running into music files that error out while playing, the error is something about the file, and then I press play again and the so G that just three an error plays fine.

    I have to agree that the ExFAT implementation isn't 100% solid yet and wish I had left my card FAT32 formatted.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-04-14 07:51 PM
  16. tickerguy's Avatar
    I keep running into music files that error out while playing, the error is something about the file, and then I press play again and the so G that just three an error plays fine.

    I have to agree that the ExFAT implementation isn't 100% solid yet and wish I had left my card FAT32 formatted.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    If your card is a SD/xc and previously was used FAT32 formatted it may be damaged by having been written to while formatted FAT32.

    I have no problems using my Sandisk card formatted exFAT...
    06-05-14 06:57 AM
  17. Carterbits's Avatar
    All my phone apps work fine.

    It does appear that Link doesn't recognize the card in my wife's phone during media sync.

    I will have to confirm on mine, but if this is the case, it sounds like BlackBerry needs to fix their file system redirection driver.

    Download Noted, my 5-star rated, native BB10 notepad app.
    06-05-14 08:31 AM
  18. HotFix's Avatar
    If your card is a SD/xc and previously was used FAT32 formatted it may be damaged by having been written to while formatted FAT32.

    I have no problems using my Sandisk card formatted exFAT...
    I'm not sure how the card being "damaged" would give random and inconsistent file media type not supported errors. If it was truly damaged I would imagine there were parts of the NVRAM that would never work, not randomly not work and then start working again. Either that or the card wouldn't work at all.

    Then again I am not an expert in SD cards, and lord knows anything is possible.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-05-14 05:11 PM
  19. Heinz Katchup's Avatar
    This is extremely annoying and inconvenient. I was having some ghost files I wanted to get rid of. Reformatted my card through BB10 settings and now I can't access my SD card like before. Only through USB mass storage. How does BlackBerry not diagnose a fix to these issues before releasing to the public. Times like these I see why their sales are so low. People want software that works.
    06-05-14 11:52 PM
  20. buwee's Avatar
    This is extremely annoying and inconvenient. I was having some ghost files I wanted to get rid of. Reformatted my card through BB10 settings and now I can't access my SD card like before. Only through USB mass storage. How does BlackBerry not diagnose a fix to these issues before releasing to the public. Times like these I see why their sales are so low. People want software that works.
    I have had no such problems with my Sandisk Ultra 64GB
    06-06-14 01:51 AM
  21. Heinz Katchup's Avatar
    I have had no such problems with my Sandisk Ultra 64GB
    Good for you. Now move along. This thread is for people trying to resolve this issue.

    Posted via CB10
    06-06-14 02:32 AM
  22. sayf777's Avatar
    So tickerguy, if I got my sd xc formatted fat32 and it's working fine, do you suggest I format it to exFat?

    Edit: Reread through the thread and I gather I rather reformat it to exFat, as the damage could occur at anytime when it's written to on Fat32.

    Posted via CB10
    06-07-14 11:25 AM
  23. HotFix's Avatar
    So tickerguy, if I got my sd xc formatted fat32 and it's working fine, do you suggest I format it to exFat?

    Edit: Reread through the thread and I gather I rather reformat it to exFat, as the damage could occur at anytime when it's written to on Fat32.

    Posted via CB10
    Just a word of caution, I did that to mine and am now regretting it because I am getting random I/O errors. I wish I had left mine as it was.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    sayf777 likes this.
    06-07-14 12:50 PM
  24. sayf777's Avatar
    Just a word of caution, I did that to mine and am now regretting it because I am getting random I/O errors. I wish I had left mine as it was.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    Thanks for that, I'll just back up mine on my external hd and keep my sd as it is.

    Posted via CB10
    06-07-14 02:13 PM
  25. Guyzer's Avatar
    Now that the official update has been released and it brings support for SD cards with the exFAT format, is there a way to extract the driver from the OS and apply it to 10.3.0.296?

    Posted via CB10 on my White Z30
    were you ever able to get it work? i to have latest 10.3 leak and it wont load the drivers for my 64 gb kingston exfat. ive read I could format it to fat32 but here it can cause stability issues in the future.

    would like to get this to work without having to load 10.2.1 then having to reload 10.3

    edit: got impatient and loaded 10.2.1. put in new kingston 64 gb micro sd xc and it formatted and added all the folders and stuff. loaded it into my win8.1 machine and copy and pasted my music into the music folder.

    loaded up 10.3 and put in the card. came up, d/l'n media driver... then failed. gave me same error as before. its weird. it looks like it only works in 10.2.1 but its not available in 10.3

    looks like I got to go back to my 32 gb card till 10.3 fixed exfat support
    Last edited by Guyzer; 06-10-14 at 01:17 AM.
    06-10-14 12:03 AM
99 1234

Similar Threads

  1. Saving pics to media card on Q10
    By keetguy in forum New to the Forums? Introduce Yourself Here!
    Replies: 4
    Last Post: 05-30-14, 07:10 AM
  2. Floppy Bird on PlayBook now
    By miguel89to in forum PlayBook Apps & Games
    Replies: 4
    Last Post: 05-28-14, 08:23 PM
  3. Audio quality of Streaming since 10.2
    By svo4turbo in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 05-28-14, 08:37 AM
  4. Replies: 2
    Last Post: 05-27-14, 09:02 PM
  5. Can't watch streaming videos on facebook
    By Pei Chai Wee in forum BlackBerry Z10
    Replies: 5
    Last Post: 05-27-14, 08:36 PM
LINK TO POST COPIED TO CLIPBOARD