05-12-15 01:58 PM
32 12
tools
  1. shafiq01's Avatar
    Have any of you genius guys figured out how to fix below:

    Default setting in antenna diversity is blank, check yours if you like.

    ('blank' is like the one in evdo and cdma antenna diversity, look at the attached screendump)

    But after I selected one of the 4 options (in this case 'primary & secondary') I can't go back to 'blank'

    I won't recommend you to do this, hence it's draining the battery a lot.

    Path to the diversity setting:
    Escreen\genral radio\antenna diversity\lte (or any of the other frequencys)

    And now if my device has rebooted (as it does for many of us), then I have to enable the data manually from path: Escreen\3gpp\utilities\ps attach
    And then select the 'press' button.

    I've tried to load different os's 10.2's, 10.1's and some home brewed os's as well, wiped the device. Sideloaded Escreen.bar from another os, you name it.

    Seems like there's no way "back"

    Could be nice though if there was a secret swipe gesture in the Escreen, like we have the 5 swipe gesture for hub reset, 3 swipe gesture for battery on dev devices, 2 finger swipe for Escreen and etc.

    Just, hoping :-)

    PS. Don't mess with the antenna diversity, unless you know how to go back default!!!

    Escreen LTE antenna diversity ruined-img_00000012.png

    Posted via CB10
    07-08-13 03:15 PM
  2. shafiq01's Avatar
    Oh sorry, it's my first post from the CB app from my Z10, maybe it's in the wrong section. Anyway I thought this section was the most advanced so to speak, hence I posted here. Hope it's okay!?

    Posted via CB10
    07-08-13 03:18 PM
  3. ealvnv's Avatar
    Reboot the device and it will go back to default
    07-08-13 03:25 PM
  4. HaTaX's Avatar
    Have you tried a security wipe to get back to normal? That clears out quite a bit more then even just reloading the OS, might bring your 'blank' back as well...
    07-08-13 06:18 PM
  5. shafiq01's Avatar
    Tried both wiping the device (also with wet napkins hehe) and reboots and batt. Pulls. No more blanks :-(

    Posted via CB10
    07-09-13 01:49 AM
  6. Drew Oswalt's Avatar
    How does one get to the escreen?

    Posted via CB10
    07-09-13 02:36 AM
  7. Drew Oswalt's Avatar
    Never mind. I forgot about the CB article that was published a while back.

    Posted via CB10
    07-09-13 02:53 AM
  8. Gambit_DE's Avatar
    If you could gibt me the Sourcecode of the escreen, i could try building a xss for this.
    Just in case this is possible (which i hope is not!), sending a NULL parameter should fix your issue.

    Posted via CB10
    07-09-13 03:33 AM
  9. xsacha's Avatar
    If you could gibt me the Sourcecode of the escreen, i could try building a xss for this.
    Just in case this is possible (which i hope is not!), sending a NULL parameter should fix your issue.
    You can't modify the escreen app becuase it requires a special permission.
    07-09-13 04:04 AM
  10. Gambit_DE's Avatar
    You can't modify the escreen app becuase it requires a special permission.
    I just thought about the possibility to cross site script with the escreen. If its not possible, thats good to hear

    Posted via CB10
    07-09-13 04:16 AM
  11. xsacha's Avatar
    I just thought about the possibility to cross site script with the escreen. If its not possible, thats good to hear

    Posted via CB10
    It's not a website. It's on-device settings that are exposed through special escreens API calls that require an escreens permission
    The app only exposes the settings that are already there.
    I'd suggest the app is a bit buggy.
    07-09-13 06:27 AM
  12. shafiq01's Avatar
    Yeah, it's buggy.
    Anyway, when you flash an android phone, there is the rom, kernel and something with the boot as well, I don't remember now, it's along time ago I was active on xda.

    When we reload the os on a bb10 device with autoloader, then I know so far that it's the os and the radio which is flashed, if so to say. But is there other parts, that can be flashed?

    Because if I send the device, to repair, how will rim/blackberry fix it?

    Posted via CB10
    07-09-13 04:40 PM
  13. xsacha's Avatar
    Yeah, it's buggy.
    Anyway, when you flash an android phone, there is the rom, kernel and something with the boot as well, I don't remember now, it's along time ago I was active on xda.

    When we reload the os on a bb10 device with autoloader, then I know so far that it's the os and the radio which is flashed, if so to say. But is there other parts, that can be flashed?

    Because if I send the device, to repair, how will rim/blackberry fix it?
    There is a tool called 'CFP' which allows them to test hardware and change escreens settings while the device is dead.
    Other than that, they have to chuck it in the bin.
    It's quite difficult to kill though. I have only heard of 1 or 2 devices that were actually bricked.

    By the way, the bootloader (that is the boot partition) is flashed with the OS.
    07-09-13 09:47 PM
  14. shafiq01's Avatar
    Okay, good one.
    I can try that!

    But is the CFP tool a rim tool or a home brewed tool? Have you have tried it yourself?

    Posted via CB10
    07-10-13 09:15 AM
  15. qwang's Avatar
    Reboot the device and it will go back to default
    the escreen setting in BB10 is different than BB OS.

    it's active after you reboot or out of esreen period
    07-10-13 10:18 AM
  16. ealvnv's Avatar
    the escreen setting in BB10 is different than BB OS.

    it's active after you reboot or out of esreen period
    Only enough it gas reverted back on mine but haven't checked lately though.

    The app us built with air sdk that's why feels so buggy
    07-10-13 05:45 PM
  17. xsacha's Avatar
    But is the CFP tool a rim tool or a home brewed tool? Have you have tried it yourself?
    It's a RIM tool.
    07-10-13 11:44 PM
  18. shafiq01's Avatar
    I tried last night, I get it now, it's a command line tool in-build also in all autoloader files, we use to flash the device.

    However, it seems like the old commands such as wipe and nuke is not possible in the version 3.10.x.x of cfp I found on the Web. And if I use the old one 3.9.x.x then the error message says I have to use a newer version of cfp/aoutload.

    I tried to download darcys BlackBerry tool, but it's temp unavail. on mega!

    I was thinking to try extracting cfp from the different os's I have, perhaps 10 versions or something :-)

    And then try the different versions and see if the old command are allowed.

    If that could help at all, in the first place?


    Posted via CB10
    07-11-13 01:49 AM
  19. xsacha's Avatar
    Autoloader don't contain CFP. They have a different app called CAP which only does LOAD.
    Newer CFPs do everything on bb10. I will integrate their ability to Sachesi later.

    The way it works is by uploading a signed RAM image containing an instruction. I don't think we have the 'RMA' or repair image.
    07-11-13 06:19 PM
  20. shafiq01's Avatar
    Yeah, sorry I noticed that as well cap
    Wow, it could be great with a ram image.
    Will you let me know when you've changed the thing from your side, thx.

    Posted via CB10
    07-12-13 03:06 AM
  21. wagnerescanio's Avatar
    I have the same problem with the antenna diversity

    Posted via CB10
    Last edited by wagnerescanio; 05-06-15 at 06:50 AM.
    09-12-13 06:49 PM
  22. BitPusher2600's Avatar
    Bumping an old thread? @OP, I did this recently myself just looking about, and I haven't noticed any change in battery drain. I live in a Sprint 4G area though I don't have it all the time. If you are still worrying about this, I'm sure you've noticed by now it's ok yeah?
    12-15-13 08:55 AM
  23. Z10pack's Avatar
    does this only work on z10? i have a bb Q10 and looks when i put my code in the escreen it doesnt do much and cant unlock my lte antena
    10-15-14 10:49 AM
  24. sabalex's Avatar
    has any one find a solution to this antenna diversity problem, pls
    04-24-15 01:02 PM
  25. Arth Patel's Avatar
    Ya I had that happen to me when I tried the tethering via escreen and had to restore from BlackBerry link and it fixed it

    Posted via CB10
    04-29-15 06:05 AM
32 12

Similar Threads

  1. 10.1.0.4543 Capped My LTE Speed!!
    By WhiteSpir1t in forum BlackBerry Z10
    Replies: 24
    Last Post: 07-08-13, 07:06 PM
  2. LTE Speed cmparison
    By rblee26 in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-06-13, 08:57 PM
  3. Does LTE logo disappear when making calls?
    By BlackberryFan2009 in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 07-06-13, 12:10 AM
  4. Does LTE logo disappear when making calls?
    By BlackberryFan2009 in forum T-Mobile
    Replies: 4
    Last Post: 07-06-13, 12:10 AM
  5. What OS Version is your LTE Playbook Running?
    By JJStripes in forum BlackBerry PlayBook OS
    Replies: 4
    Last Post: 07-05-13, 07:02 PM
LINK TO POST COPIED TO CLIPBOARD