1. horyel's Avatar
    Hi everybody,

    I need some help, ASAP. I just received an update for Whatsapp through BlackBerry World. But when I open Whatsapp it says I am running a OS that is not being supported.

    I really need it for work, which starts in an hour. How can I downgrade guys?

    Thanks a whole lot guys!

    BTW I am running .296
    Attachment 291700

    Posted via CB10
    Jhon Chen Strike's back? Pal thats weird, im on 10.3.0.700 and my whatsapp is up and running.
    08-19-14 12:25 PM
  2. abjater's Avatar
    WhatsApp is going down a very stupid road, limiting if and when users can use their app on a device. They should shut up and just allow their puny little app to run on whatever, afterall, they do get revenue from it.
    08-19-14 01:14 PM
  3. anon8656116's Avatar
    WhatsApp is going down a very stupid road, limiting if and when users can use their app on a device. They should shut up and just allow their puny little app to run on whatever, afterall, they do get revenue from it.
    Nobody is asking you to download an unreleased OS, quite the opposite. There is a reason why 10.3 has only been released for developers so far. Use 10.3 all you want, but dont expect developers to provide support.
    olaf_d and RedxD like this.
    08-19-14 01:22 PM
  4. olaf_d's Avatar
    Actually that's not really the reason. 296 is a full (but extremely early) 10.3 leak. The reason whatsapp isn't supporting it is because it's a leaked os and was not intended for the public. They did on the other hand support .700 because it was released by BlackBerry for devs.

    Posted via CB10
    Actually, that is the reason. You fabricated your reason based on what you "feel" and "think". Your argument is invalid.

    *edit: typo
    KermEd likes this.
    08-19-14 01:27 PM
  5. abjater's Avatar
    I dont expect or ask support! I understand that when I load a beta/unreleased version and things start going whack, its my own fault and i should deal with it.
    However I dont ask you, nor any app developer, to decide that I may not run an app on my device. Less bring out an update (which is supposedly to better the app) and lock me in/out in terms of operational versions of the OS. If the previous version worked, they should not "update" to lock out certain versions, and sorry, but this is a planned action on WA's part.
    They should at this point in time make sure the app is perfect to run on 10.3 when it goes live, and and not exclude devices already on any 10.3.* version.
    So sorry for them, I still have my beloved BBM (which is still the KING of IM apps), so GTH WhatsApp!
    08-19-14 01:31 PM
  6. BlackScorpion3's Avatar
    I dont expect or ask support! I understand that when I load a beta/unreleased version and things start going whack, its my own fault and i should deal with it.
    However I dont ask you, nor any app developer, to decide that I may not run an app on my device. Less bring out an update (which is supposedly to better the app) and lock me in/out in terms of operational versions of the OS. If the previous version worked, they should not "update" to lock out certain versions, and sorry, but this is a planned action on WA's part.
    So sorry for them, I still have my beloved BBM (which is still the KING of IM apps), so GTH WhatsApp!
    Well, you may NOT complain but as a developer, there are plenty of people who DO complain about things not working on apps, when they are running a leaked OS.
    Don't blame the developer for stepping up to try to avoid having to deal with the onslaught if emails.
    I do NOT blame the developer at all and actually am very supportive of this decision.

    Check out PillPad http://appworld.blackberry.com/webst...ntent/19042021 Now Built For BlackBerry Certified, BB10 App developer, Cystic Fibrosis Advocate.
    LP_Rigg likes this.
    08-19-14 01:34 PM
  7. anon8656116's Avatar
    However I dont ask you, nor any app developer, to decide that I may not run an app on my device. Less bring out an update (which is supposedly to better the app) and lock me in/out in terms of operational versions of the OS. If the previous version worked, they should not "update" to lock out certain versions, and sorry, but this is a planned action on WA's part.
    It is perfectly legitimate for them to do so. You don’t know what’s happening within the app itself. It’s possible that some part of the code is not executed properly when interacting with, say, the back-end server. This could pose security risks or some other issues. 10.3 has only been released as a basic OS that accompanies the new SDK; it’s purely meant for developers to test their apps, not to be used as a daily driver. It’s strictly speaking not even a beta yet.
    BlackScorpion3 and RedxD like this.
    08-19-14 01:40 PM
  8. eaburger's Avatar
    Is it ok if I download new version while using 10.2.2 OS?

    Posted via CB10
    Confirmed, you can download this without any problem!
    08-19-14 01:41 PM
  9. andrewwdai's Avatar
    Folks, if anyone has the older bar file.... Highly appreciate it!
    08-19-14 04:32 PM
  10. pguarache's Avatar
    I did this. I made a backup of the Whatsapp using Blackberry Link (ONLY WHATSAPP) <-I did this part to avoid losing my lastest conversations, then I proceded to delete the application manually. After I deleted the application I restored Whatsapp from an older backup (ONLY WHATSAPP) and after that I restored the backup I made before I delete the application. Done! Whatsapp is working again.

    Hope this work for most of you.
    08-19-14 04:40 PM
  11. Numero12's Avatar
    I had to downgrade from 10.3.0.296 to 10.2.2.1531

    Bugs with BlackBerry World, Beta Zone and WhatsApp made Me crazy!
    08-19-14 04:59 PM
  12. rockebb's Avatar
    Hello pguarache

    You open the backup file with 7-zip and delete the data file of WhatsApp, not the bin file!
    Because you restore WhatsApp with Blackberry Link with the data file, you can't restore your last history backup, because you will not get the request in WhatsApp for restore history.
    Search for gYABgD934jlePGCrd74r6jbZ7jk.app.data and delete this file in 7-zip. Restore Whatsapp with this modified backup file in Blackberry Link.

    Have fun
    08-19-14 05:48 PM
  13. pguarache's Avatar
    Hello pguarache

    You open the backup file with 7-zip and delete the data file of WhatsApp, not the bin file!
    Because you restore WhatsApp with Blackberry Link with the data file, you can't restore your last history backup, because you will not get the request in WhatsApp for restore history.
    Search for gYABgD934jlePGCrd74r6jbZ7jk.app.data and delete this file in 7-zip. Restore Whatsapp with this modified backup file in Blackberry Link.

    Have fun
    Dude. I did what I told you. I made a backup before I delete the app... then restored the whatsapp from an older backup file, I got whatsapp again. Then I proceed to restored the most recently bakup... It restored just the data. Trust me...

    Btw. I'm not talking about restoring a Whatsapp's backup file using the Whatsapp application. I talking about making a backup and restoring Whatsapp using BlackBerry Link.

    Got it?
    08-19-14 06:50 PM
  14. bloodyrek's Avatar
    Meanwhile in the land of official os...
    Numero12 likes this.
    08-19-14 07:50 PM
  15. VR6's Avatar
    Damn it!!! I'm using the Android version and it's hurting!
    pastycat likes this.
    08-19-14 07:51 PM
  16. andrewwdai's Avatar
    Please be advised that from now on I can be contacted via BBM only. I have decided to dump Whatsapp for good.
    08-19-14 08:32 PM
  17. BlackScorpion3's Avatar
    Please be advised that from now on I can be contacted via BBM only. I have decided to dump Whatsapp for good.
    Because we all had you on Whatsapp and BBM? I guess I'm missing the point of why you are telling us this. Dumping an IM client because the developers decided not to support an unapproved OS that is missing API functions?
    I'm sure they won't miss you with all the users they have.

    Check out PillPad http://appworld.blackberry.com/webst...ntent/19042021 Now Built For BlackBerry Certified, BB10 App developer, Cystic Fibrosis Advocate.
    mainely_linux likes this.
    08-19-14 08:49 PM
  18. Numero12's Avatar
    Meanwhile in the land of official os...
    By the way, Z30 runs better over 10.2 than 10.3 leaks and betas! Just for nice icons it doesn't justify migrating to those 10.3......

    Posted via CB10
    08-19-14 09:00 PM
  19. mainely_linux's Avatar
    By the way, Z30 runs better over 10.2 than 10.3 leaks and betas! Just for nice icons it doesn't justify migrating to those 10.3......

    Posted via CB10

    It's all personal preference. I have excellent working results with the 296/700 blend. The radio is simply amazing where I live in rural Maine on the z30.

    Posted via CB10
    Numero12 likes this.
    08-19-14 09:55 PM
  20. omaktl's Avatar
    I had the same issue this morning what I did was uninstall WhatsApp then from a complete backup I restore only WhatsApp it's working fine now is the last version that worked with 10.3.0.296 don't know how to extract bar from backup but I won't go back to 10.2.

    Posted via CB10
    08-19-14 11:12 PM
  21. sangsuryo's Avatar
    Is it ok if I download new version while using 10.2.2 OS?

    Posted via CB10
    Work as it should be. Both, either from betazone or bbw. Q10SQN100-3/10.2.2.1531

    Posted via CB10
    08-19-14 11:29 PM
  22. cbosdell's Avatar
    Same. Apparently a leak and the SD will be released sometime this week (not weekend). Confirmed by N4BB and DHabkirk (on their BBM channels)

    Posted via CB10
    That would be really nice if it does happen. I leave Friday for a vacation and won't have computer access for a few weeks so I'm hoping!
    08-20-14 12:21 AM
  23. Daveensannie's Avatar
    People stop complaining who are running a 10.3. Leak! WA is not official ready for 10.3 so stop acting like it's a fault from WA. If you want it to run stable then go back to a stable official 10.2 and stop crying

    Posted via CB10
    olaf_d likes this.
    08-20-14 12:51 AM
  24. 0xiangjiao0's Avatar
    People stop complaining who are running a 10.3. Leak! WA is not official ready for 10.3 so stop acting like it's a fault from WA. If you want it to run stable then go back to a stable official 10.2 and stop crying
    Posted via CB10
    But before upgrading, it worked well, so I think they can fix it, the point is: they don't want to do that.
    08-20-14 01:11 AM
  25. olaf_d's Avatar
    But before upgrading, it worked well, so I think they can fix it, the point is: they don't want to do that.
    No, that's not the point at all. The point is that as far as an API standpoint, 296 is significantly lacking compared to later builds. That being said, in order to actually support 10.3 properly, the OS needs to be able to handle it. 296 cannot so that build is unsupported. 700 and newer will run the latest WhatsApp without issue.
    Daveensannie likes this.
    08-20-14 01:19 AM
112 12345

Similar Threads

  1. Suggestion on which Android app store to install?
    By chudypee in forum Android Apps (Amazon Store & APK Files)
    Replies: 8
    Last Post: 08-20-14, 04:47 PM
  2. Viewing through home Web cam on Z10?
    By targnik in forum BlackBerry Z10
    Replies: 5
    Last Post: 08-19-14, 10:13 PM
  3. Hands-on with ARKick v2.0
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 08-19-14, 04:00 AM
  4. Connection Problem on Android Apps
    By GaleWindsar in forum BlackBerry Q10
    Replies: 2
    Last Post: 08-19-14, 03:49 AM
  5. Fed up with several ignorant reviews on BlackBerry World...
    By Sir_Augie in forum BlackBerry 10 Apps
    Replies: 3
    Last Post: 08-19-14, 01:20 AM
LINK TO POST COPIED TO CLIPBOARD