1. pratik aryan's Avatar
    Hi..
    Can anyone confirm me if the battery calibration issue goes away on 10.3.1?

    I am really not liking my phone getting turned off at various percentages..

    Should I change the phone to stl 100-2 or some other version.. I do like my z10 and this is the only thing thats hurting me

    Thanks in advance..

    Posted via CB10
    10-06-14 05:09 PM
  2. Gearheadaddy's Avatar
    To change the phone to another version takes a carrier change also...

    Crackberry Genius on Verizon 10.3.1.632
    10-06-14 06:09 PM
  3. dikku11's Avatar
    Yeah its fixed at least for me.always try a clean format(autoloader) when you update your OS

    Posted via CB10
    10-06-14 10:03 PM
  4. prithvi64's Avatar
    to me also, my Z10 STL-1 is being shut down at various percentages after updating to 10.3.1.634. Even I was experiencing freezing of screen randomly. It 2-3 times since last 3-4 days. I did restore from 1154. Today morning, I did security wipe and installed all missing bars from 632. Continuing without restore. let's see whether it solves battery shutdown & freezing issues.
    10-06-14 10:23 PM
  5. Thesmartmale's Avatar
    I'm starting to think this is a hardware problem and BlackBerry can't admit it!

    I hate you Thorsten Heins!

    Posted via CB10
    10-07-14 01:55 AM
  6. pappu thakkar's Avatar
    How can I update ma z10 stl100-1?

    Posted via CB10
    10-07-14 02:29 AM
  7. LostOnThePianoRoll's Avatar
    How can I update ma z10 stl100-1?

    Posted via CB10
    Just don't.. 10.3.1.634 is soo full of bugs.. apps not working.. apps missing even after loading bars.. android doesn't 100% work (more like 50%). The phone freezes and reboots randomly.. I've managed to have all previous sdk oses as daily drivers but I've never seen one that bad..

    Posted via CB10 on my Z10STL100-1/10.3.1.634
    10-07-14 07:01 AM
  8. garg2k7's Avatar
    Install 10.3.0.1052 on z10 stl100-1. I am running it since it uploaded. Working good for me. No lag no freeze no restart even battery calibration problem is very less. Before it came after 3-4charges but now after 10-12

    Z10STL100-1/10.3.0.1052 / C004DE3E2
    10-07-14 07:14 AM
  9. pratik aryan's Avatar
    To change the phone to another version takes a carrier change also...

    Crackberry Genius on Verizon 10.3.1.632
    My phone is an unlocked version..
    I think I may not necessarily have to switch network operator.

    Posted via CB10
    10-07-14 12:44 PM
  10. pratik aryan's Avatar
    Yeah its fixed at least for me.always try a clean format(autoloader) when you update your OS

    Posted via CB10
    When did you update?
    How long have you been without the problem? Its not a daily problem.. may be once a month.. but now after so many months I don't like doing it every month..

    Posted via CB10
    10-07-14 12:45 PM
  11. pratik aryan's Avatar
    to me also, my Z10 STL-1 is being shut down at various percentages after updating to 10.3.1.634. Even I was experiencing freezing of screen randomly. It 2-3 times since last 3-4 days. I did restore from 1154. Today morning, I did security wipe and installed all missing bars from 632. Continuing without restore. let's see whether it solves battery shutdown & freezing issues.
    Ok.. let me know if it works for you..

    Posted via CB10
    10-07-14 12:46 PM
  12. pratik aryan's Avatar
    I'm starting to think this is a hardware problem and BlackBerry can't admit it!

    I hate you Thorsten Heins!

    Posted via CB10
    Actually I too think its a hardware problem..

    Posted via CB10
    10-07-14 12:47 PM
  13. pratik aryan's Avatar
    Install 10.3.0.1052 on z10 stl100-1. I am running it since it uploaded. Working good for me. No lag no freeze no restart even battery calibration problem is very less. Before it came after 3-4charges but now after 10-12

    Z10STL100-1/10.3.0.1052 / C004DE3E2
    Thanks.. I will search for it.

    Posted via CB10
    10-07-14 12:53 PM
  14. prithvi64's Avatar
    after clean install without restore, solves battery issue. Today I could see battery going below 20% and save battery option was enabled automatically.
    10-07-14 10:30 PM
  15. ronaksuper's Avatar
    You don't really need to update stl-1 to 10.3.1 to fix the battery issue. I had the same issue, then later found a method to calibre. Follow these steps

    1 - Charge the phone to 100%.

    2 - After phone is fully charged, drain the phone. completely and do not charge the phone in this period.

    3 - When the phone fully discharged and turns off, remove the battery and insert it again.

    4 - Now charge the phone to 100% in one shot, do not disconnect charger till it is fully charged.

    5 - Repeat

    Battery will get calibrated gradually, may be atleast 3-5 try. Btw when you install a new os using autoloader you lose the calibration.

    Good luck :P

    Posted via CB10
    10-07-14 11:00 PM
  16. akOnalangBFmo's Avatar
    You don't really need to update stl-1 to 10.3.1 to fix the battery issue. I had the same issue, then later found a method to calibre. Follow these steps

    1 - Charge the phone to 100%.

    2 - After phone is fully charged, drain the phone. completely and do not charge the phone in this period.

    3 - When the phone fully discharged and turns off, remove the battery and insert it again.

    4 - Now charge the phone to 100% in one shot, do not disconnect charger till it is fully charged.

    5 - Repeat

    Battery will get calibrated gradually, may be atleast 3-5 try. Btw when you install a new os using autoloader you lose the calibration.

    Good luck :P

    Posted via CB10
    Do I have to do the step 1 before going to step 2?
    Co'z step 1 is not working... it ended up charging in 88%
    With that, can't do the step 2 & 3.
    10-08-14 07:10 AM
  17. ronaksuper's Avatar
    Do I have to do the step 1 before going to step 2?
    Co'z step 1 is not working... it ended up charging in 88%
    With that, can't do the step 2 & 3.
    Yes you can continue.

    Posted via CB10
    10-08-14 01:18 PM
  18. LostOnThePianoRoll's Avatar
    Alright one update from me, I posted earlier how I was having a lot of troubles, now is the first day I don't get the freezing and reboot bug and I've noticed a reduced cpu average so I assume os indexing is done

    Does 10.3.1 fix battery calibration on Z10 STL100-1?-img_20141008_192928.png

    I've originally took the plunge for one reason "battery saving mode" and today after the indexing settled down I must say I'm impressed, with my normal usage same as everyday a full charge NEVER lasted more than 8 hours.. never on any OS version. Now it's really surprising!! I must say that started out weighing all my previous issues.. MY Z10 ACTUALLY LASTED A DAY!

    Halleuloyah!

    Does 10.3.1 fix battery calibration on Z10 STL100-1?-img_20141008_192721.png

    Posted via CB10 on my Z10STL100-1/10.3.1.634
    10-08-14 01:33 PM
  19. poomslike's Avatar
    Best calibration method worked for me is:

    1.Remove the Battery from your Blackberry

    2.Plug in original charger into your blackberry without the battery inserted, VIA PC. Do not connect it by the wall socket .

    3. Leave it there plugged in for 30 Mins.

    4.After, insert the battery without removing the charger

    5.Let the blackberry charge to 100%

    6.When the battery is fully charged. Remove the charger

    7.Let your Z10 drains to 0%(Discharge) ( Do intensive CPU usage tasks, Playing games, streaming videos etc.)

    >Repeat these step twice.

    The battery will subsequently receives it?s charging cycle.

    Posted via CB10
    10-08-14 09:36 PM
  20. pratik aryan's Avatar
    after clean install without restore, solves battery issue. Today I could see battery going below 20% and save battery option was enabled automatically.
    Ok.. will try it then but I must tell you that after I recalibrate with the the older method of battery pull the phone works ok for another couple of weeks. Then one day it gets back.
    I mean if you go without the trouble for a month then its safe to say that the problem is no more but judging it only on two weeks is a bit early.

    Posted via CB10
    10-10-14 04:20 PM
  21. pratik aryan's Avatar
    Alright one update from me, I posted earlier how I was having a lot of troubles, now is the first day I don't get the freezing and reboot bug and I've noticed a reduced cpu average so I assume os indexing is done

    Click image for larger version. 

Name:	IMG_20141008_192928.png 
Views:	230 
Size:	82.4 KB 
ID:	304187

    I've originally took the plunge for one reason "battery saving mode" and today after the indexing settled down I must say I'm impressed, with my normal usage same as everyday a full charge NEVER lasted more than 8 hours.. never on any OS version. Now it's really surprising!! I must say that started out weighing all my previous issues.. MY Z10 ACTUALLY LASTED A DAY!

    Halleuloyah!

    Click image for larger version. 

Name:	IMG_20141008_192721.png 
Views:	231 
Size:	72.6 KB 
ID:	304188

    Posted via CB10 on my Z10STL100-1/10.3.1.634
    Is this version stable?

    Posted via CB10
    10-10-14 05:15 PM
  22. LostOnThePianoRoll's Avatar
    Is this version stable?

    Posted via CB10
    No, it's horrible.. but battery life is great to give credit where it's due

    Posted via CB10 on my Z10STL100-1/10.3.1.634
    10-10-14 06:07 PM
  23. Mr Mozi's Avatar
    Yeah this works, but only for a week. On the other hand, the phone shows fully charged at 82% so it's just the number shifted back.
    10-15-14 06:24 AM
  24. varunhmahesh's Avatar
    I'm starting to think this is a hardware problem and BlackBerry can't admit it!

    I hate you Thorsten Heins!

    Posted via CB10
    I too have been facing Calibration issue since 4 months, finally last month I went to Authorized services centre and they replaced my battery, post replacement it was working perfectly, but day-before yesterday I found that my Phone's time resets itself to the Software Build Date, so I went back to to service centre. They collected my handset and said its a Hardware issue and they will give me a New Replacement for the Same in 20 working Days.
    10-15-14 06:42 AM
  25. IamMilesValdez's Avatar
    Have tgis issue for a month.still the computer charging methods works.but only twice.i think I need to brink back the phone to the service center.

    Posted via CB10
    10-22-14 01:51 AM

Similar Threads

  1. How To Make Free North American Calls On Z30 Using Gmail?
    By Carmen Dixon in forum BlackBerry Z30
    Replies: 8
    Last Post: 10-07-14, 10:03 PM
  2. Does passport's back wear off easily ?
    By Nikolay Konov in forum BlackBerry Passport
    Replies: 5
    Last Post: 10-07-14, 08:56 AM
  3. Blackberry 10.3/10.3.1 Maps?
    By kevinzupp in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 10-06-14, 09:48 PM
  4. Will official 10.3 fix my Z10 Notifications bug?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 10-06-14, 08:13 PM
  5. Why is my Z10 randomly shutting off?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-06-14, 07:04 PM
LINK TO POST COPIED TO CLIPBOARD