1. 00stryder's Avatar
    I didn't do anything particularly special. Bing, Google and Yahoo were there the whole time. Wikipedia was going to the English Wikipedia main page and adding it to search with the right-hand menu.

    I did do a security wipe after install, and I didn't restore from a backup, if that did anything.
    Thanks, I was referring to the Wikipedia option, I have everything else available.

    Posted via CB10 on my white Z10 & lovin' it!
    08-06-13 01:25 PM
  2. acschnitzersport's Avatar
    Did a battery pull but no help so I extracted the .bar files for the search and browser from the 10.2.0.1047 autoloader using Darcy's tool and reloaded it using Sachesi. Still missing Yahoo, Bing, Google as extended search options!

    So I extracted the .bars from .810 and tried loading those, but that also didn't help restore the extended search engines!

    I do not want to do a full reinstall and wipe again to fix this, especially if there's no guarantees it will do anything.
    I am having the same issue. Did you end up reinstalling the leak without any restore? Did that resolve the missing feature?

    Posted via CB10
    08-08-13 10:04 PM
  3. andorejunior's Avatar
    Did a battery pull but no help so I extracted the .bar files for the search and browser from the 10.2.0.1047 autoloader using Darcy's tool and reloaded it using Sachesi. Still missing Yahoo, Bing, Google as extended search options!

    So I extracted the .bars from .810 and tried loading those, but that also didn't help restore the extended search engines!

    I do not want to do a full reinstall and wipe again to fix this, especially if there's no guarantees it will do anything.
    Any luck? I loaded up 10.2 on my Q10 to see what would happen without bothering my main device and its like everyone else, the search options are there until doing a restore, then theyre gone. After wiping the Q10 theyre back. Im gonna try the different restore options and see what happens.
    08-08-13 10:06 PM
  4. nah.uhh's Avatar
    Any luck? I loaded up 10.2 on my Q10 to see what would happen without bothering my main device and its like everyone else, the search options are there until doing a restore, then theyre gone. After wiping the Q10 theyre back. Im gonna try the different restore options and see what happens.
    If you restore app data from 10.1, it will break your Android player. If you were running a 10.2 OS, you can restore app data.
    Media is can be restored without issue.

    But please, don't take my word for it. Try for yourself and let us know how it goes.
    08-08-13 10:32 PM
  5. andorejunior's Avatar
    Thanks for that. I'm trying just app data now to see but I'm pretty sure you're right. Problem is the app data is exactly what I need restored. Settings is easy enough and media is all on my micro SD. Anyways I'll post back once this is all done. Most likely tomorrow.

    Posted via CB10
    08-08-13 10:47 PM
  6. nah.uhh's Avatar
    Thanks for that. I'm trying just app data now to see but I'm pretty sure you're right. Problem is the app data is exactly what I need restored. Settings is easy enough and media is all on my micro SD. Anyways I'll post back once this is all done. Most likely tomorrow.

    Posted via CB10
    Np, forgot to add, settings is what will break your search. But again, please confirm.
    08-08-13 10:58 PM
  7. andorejunior's Avatar
    I just did applications data only and the search remains. I haven't been able to test the Android player bit if it's like my Z10 it'll be messed up too.

    Does anyone know what exactly application data and settings each handle?

    Posted via CB10
    08-08-13 11:15 PM
  8. Gearheadaddy's Avatar
    I can search right from my home screen
    Cant change the default Search Engine in 10.2.0.1047-img_20130809.png
    Cant change the default Search Engine in 10.2.0.1047-img_20130811.png

    Posted via CB10
    08-08-13 11:28 PM
  9. Gearheadaddy's Avatar
    I do not restore! It messes up too many things...I start fresh...

    Posted via CB10
    08-08-13 11:30 PM
  10. nah.uhh's Avatar
    I just did applications data only and the search remains. I haven't been able to test the Android player bit if it's like my Z10 it'll be messed up too.

    Does anyone know what exactly application data and settings each handle?

    Posted via CB10
    A couple things to note. Bookmarks and smart tags are a part of app data. I'm 90% sure that besides settings, 'settings' includes remember, password keeper, contacts, text messages.

    Obviously there is more, but I can't tell you off hand where it is stored.
    08-08-13 11:47 PM
  11. VR6's Avatar
    I am having the same issue. Did you end up reinstalling the leak without any restore? Did that resolve the missing feature?

    Posted via CB10
    No I need all my settings cuz I don't want to set them all again and I like my saved WiFi networks. I'll just live with no quick search until someone finds a fix.

    Fired from my Z10
    Last edited by VR6; 08-10-13 at 12:28 PM.
    08-09-13 04:06 AM
  12. andorejunior's Avatar
    No I need all my settings cuz I don't want to set them all again and I like my saved WiFi networks. I'll just like with no quick search until someone finds a fix.

    Fired from my Z10
    Same here. As much as I used the search, which is every time I searched anything online, I can't have things changing up on me at all. The price of playing with leaks I guess.

    Posted via CB10
    08-09-13 10:39 AM
  13. stardomains's Avatar
    So is there officially no cure for this problem other than reinstalling the OS and not restoring settings?

    Posted via CB10
    08-10-13 10:22 PM
  14. Gerii's Avatar
    Some people got it back by trying around (resetting the search engines, adding new ones etc) but nobody really knows what in the end really brought them back.

    Posted via CB10
    08-11-13 06:02 AM
  15. VR6's Avatar
    So is there officially no cure for this problem other than reinstalling the OS and not restoring settings?

    Posted via CB10
    Correct, we're still waiting for a confirmed fix. Maybe a new leak will come out next week and this issue will be gone!

    Fired from my Z10
    08-11-13 11:53 AM
  16. acschnitzersport's Avatar
    I ended up wiping and just reloading everything manually versus loading a backup. The extended browser search is back for me and now I am able to make a backup for 10.2 which should keep the feature around for the next restore. A bit tedious, but I hate not having all features available.

    Posted via CB10
    08-11-13 12:31 PM
  17. andorejunior's Avatar
    I ended up wiping and just reloading everything manually versus loading a backup. The extended browser search is back for me and now I am able to make a backup for 10.2 which should keep the feature around for the next restore. A bit tedious, but I hate not having all features available.

    Posted via CB10
    This is what I want to do but I want to make sure my contacts and remember notes are saved. Is that possible? What specific backup could be used without losing the search engine functionality. I've done this so many times now I don't know what's what :S

    Posted via CB10
    08-11-13 06:45 PM
  18. acschnitzersport's Avatar
    This is what I want to do but I want to make sure my contacts and remember notes are saved. Is that possible? What specific backup could be used without losing the search engine functionality. I've done this so many times now I don't know what's what :S

    Posted via CB10
    If you have your contacts backed up to say, google contacts or a server, once you reconnect to the service, your contacts will reload. If you don't have that option, I am not sure how well the sync works with Blackberry Link, but that's your only other option, outside of reentering them manually.

    Your remember notes are in a default folder that do not save to evernote automatically. Move the notes in your unfiled notebook to an evernote notebook and you'll have them when you sync with evernote after the wipe.

    Unfortunately, backing up and restoring from the backup when you have issues will most likely result in the same issue occurring. Restoring app data corrupted the android runtime, and restoring settings resulted in the browser issue topic at hand. Restoring media hasn't been reported as helpful or hurtful, but I had everything on my SD card, so I didn't worry about loading that database.

    My personal opinion is: If it didn't work 100% with my backup, I'll wipe and use it from scratch. It's a beta, not much to complain about!

    Give media a shot if you're short an SD card. If you choose to restore media, check to see if the browser extended search is back before restoring media. That way you'll at least know the issue was caused by a backup or not. Then load the media and check again.

    Good luck.

    Posted via CB10
    Edit: Spelling and Grammer.
    Last edited by acschnitzersport; 08-14-13 at 05:33 PM.
    08-14-13 05:20 PM
  19. Gherard's Avatar
    1047 here on a STL2
    1- head over to the lite version of duckduckgo (i.e. : https://duckduckgo.com/lite)
    2- type at least 2 chars in it
    3- "create search" the option is back in the tripledot
    Last edited by Gherard; 08-16-13 at 11:30 AM. Reason: was missing some info
    08-16-13 11:26 AM
  20. VR6's Avatar
    DAMN 10.2.0.1323 does NOT fix this issue!
    nah.uhh likes this.
    08-17-13 08:53 PM
  21. nah.uhh's Avatar
    DAMN 10.2.0.1323 does NOT fix this issue!
    Yep :/
    08-17-13 09:04 PM
  22. andorejunior's Avatar
    Great. Thanks for the heads up.

    Posted via CB10
    08-18-13 12:01 AM
  23. adamlau's Avatar
    DAMN 10.2.0.1323 does NOT fix this issue!
    Confirmed. Installed, wiped, did not restore, manual reconfig, no web options in extended search.
    08-19-13 12:31 AM
  24. nah.uhh's Avatar
    Confirmed. Installed, wiped, did not restore, manual reconfig, no web options in extended search.
    Assuming you did not restore (specifically settings) if simply opening the browser does not fix the search app Web search, you should be able to recover the search by pressing "reset search engines" within the browser - but only if you did not restore settings
    08-19-13 02:21 AM
  25. adamlau's Avatar
    No go when 'Reset Search Engines' within the Browser settings. Restarted and reset multiple times, no search engines available under 'Extended'. Added DuckDuckGo and 'Reset Search Engines'. Still no go. Perhaps this is pushed by the carrier as I am missing several AT&T-specific apps. Is there a way to request service books as there was with BlackBerry OS?
    08-19-13 10:21 AM
102 12345

Similar Threads

  1. Spotify on 10.2.0.1323 Tutorial (no need for Spotify on PC)
    By syplex in forum BB10 Leaked/Beta OS
    Replies: 53
    Last Post: 04-16-14, 09:28 PM
  2. SMS in Hub on both sides of Balance?
    By adrian.turner@harveyworld.co.nz in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 09-23-13, 09:05 AM
  3. Nokia will get instagram before BlackBerry 10.
    By ronniell in forum General BlackBerry Discussion
    Replies: 15
    Last Post: 08-23-13, 10:25 PM
  4. Do you think if even Blackberry had all the important apps people need...
    By Speedygi in forum General BlackBerry Discussion
    Replies: 49
    Last Post: 08-23-13, 10:16 PM
  5. Display all images/pictures in a Thread
    By Andrew4life in forum Site Feedback & Help
    Replies: 1
    Last Post: 08-22-13, 11:43 PM
LINK TO POST COPIED TO CLIPBOARD