1. advcomputer's Avatar
    I seem to have an odd bluetooth bug that started to present itself on the 10.3.1.X o/s.

    I have been able to replicate the bug on both an unlocked Z10 and an unlocked Z30 running on TMO in the US. It seems to happen when using the iheart radio application.

    The head unit in my car is a JVC KWAV60BT that obviously supports Bluetooth. The unit are properly paired and are setup for bluetooth connectivity for BOTH a phone and streaming media. After streaming for 10 / 15 minutes the unit seems to disconnect bluetooth and then 1-2 minutes later seems to reconnect back to the JVC unit without issue.

    I would think that it's an issue with the JVC unit except I tried the same scenerio with iheart radio and my Galaxy Note 3 and no issue whatsoever. With the Note 3 it is solid for hours without issue, so it must be with either the iHeart App for BB or the BB10 O/S

    Each time a new o/s was installed on the Z10 or Z30 it was done via a destructive mechanism and I did everything from scratch as if new, no did not upgrade that leaves things in-tact. On both phones I have tried every version of 10.3.X and / also various radio files and still the same thing.

    Any help would be appreciated.

    -Jeff Goldstein
    03-31-15 11:44 AM
  2. kbz1960's Avatar
    Don't know what to suggest beyond bb fix it. I use tune in radio app but that seems to constantly pause and buffer. Drives me mad.
    03-31-15 11:52 AM
  3. Cranky's Avatar
    No issues with my Chevy Impala. I'm on 10.3.1.2582 running Apollo.
    03-31-15 01:56 PM
  4. tickerguy's Avatar
    I have no issues with my Passport and Pioneer 4000-NEX.


    Posted via CB10
    03-31-15 03:05 PM
  5. advcomputer's Avatar
    So the question for now is, how do I get this as a reported BUG to the development folks at Blackberry?

    -Jeff
    04-01-15 10:42 AM
  6. joekavorski's Avatar
    Does this happen only when streaming from iHeart radio? Or even if you stream via the native media player or a different radio app?

    If it only happens with iHeart radio, the app is at fault.

    Posted via CB10
    04-01-15 01:08 PM
  7. advcomputer's Avatar
    I thought it might be just the app itself but the same thing happens with Slacker.

    I read somewhere that these Bluetooth issues started in 10.3

    Jeff

    Posted via CB10
    04-01-15 05:57 PM
  8. kbz1960's Avatar
    TuneIn seems to be doing it bluetooth or not.
    04-01-15 06:04 PM
  9. amirnabilkamelsaad's Avatar
    It's a bluetooth bug, been around as you said since 10.3.1.X. Just hold tight and wait for them to fix it, and believe me...they know.
    04-01-15 06:08 PM
  10. joekavorski's Avatar
    Sorry to hear it's a bug - and sorry to all those dealing with it! I know that Bluetooth is a necessity to me to and from work and with even mild quirks before it drove me crazy. I NEED my music so I can't imagine how you all must feel!

    Posted via CB10
    04-01-15 06:16 PM
  11. syplex's Avatar
    TuneIn seems to be doing it bluetooth or not.
    Are you using tune in from BlackBerry World or from android store? Android version buffers like mad and stutters when minimized for me. BlackBerry world version works great. Only annoyance is the Javascript warning you have to hit ok on before playing anything.

    Posted via CB10
    04-01-15 08:45 PM
  12. kbz1960's Avatar
    Are you using tune in from BlackBerry World or from android store? Android version buffers like mad and stutters when minimized for me. BlackBerry world version works great. Only annoyance is the Javascript warning you have to hit ok on before playing anything.

    Posted via CB10
    Was using the bbworld one but it started doing the same so I tried the android one.
    04-01-15 09:07 PM
  13. priceless819's Avatar
    I've been having the same bug since 10.2...
    Whenever I stream to my car radio, or a Bluetooth speaker, no matter what app, tunein BlackBerry version, media player, radio station apps, it will play, then pause, or stop then play quicker like I'm listening to the chipmunks...lol
    Also when using Netflix and streaming to a speaker, there is a lag as well.

    Is there a radio file I can attempt to reinstall to try and correct this, I would fairly say mine is bad.

    Posted via CB10
    04-02-15 10:06 AM
  14. joekavorski's Avatar
    I've been having the same bug since 10.2...
    Whenever I stream to my car radio, or a Bluetooth speaker, no matter what app, tunein BlackBerry version, media player, radio station apps, it will play, then pause, or stop then play quicker like I'm listening to the chipmunks...lol
    Also when using Netflix and streaming to a speaker, there is a lag as well.

    Is there a radio file I can attempt to reinstall to try and correct this, I would fairly say mine is bad.

    Posted via CB10
    My girlfriend has a Dodge. Her Bluetooth plays really slow through the garbage Uconnect - that's the only thing I've personally experienced. Have you tried the bluetooth file from any other OS versions? I've had to do that for my Dad's passport as he had a problem where his Bluetooth wouldn't connect when the connected device is turned off/out of range (so phone calls via handset still default to Bluetooth even though there's no device).

    For reference, the filename structure for the bluetooth radio file is: bluetooth-10.3.2.483-nto+armle-v7+signed.bar
    04-02-15 10:48 AM
  15. priceless819's Avatar
    Thanks... now I have to fish for it. Stop me if I'm wrong, I should DL a leak, and just install that particular file via scachesi method or is there a better way?


    Posted via CB10
    04-02-15 12:12 PM
  16. joekavorski's Avatar
    What OS are you running? I don't mind posting one but I believe I only have 2559, 2582, or 10.3.2.281 to choose from. I'll upload them all for you right now and post links once they're on Box (via PM if you don't mind)

    EDIT: PM'd you a link

    Posted via CB10
    04-02-15 01:55 PM
  17. D3C0D3R's Avatar
    I've been using Stingray Music for the past few months with my headunit and haven't had too many issues other than the text/artist/songname not showing sometimes!

    Been using it with 10.2.1, 10.3.0 on a Z10, then 10.3.0 and 10.3.1 on my Passport, both have worked well.

    Neither have had buffering issues either :P

    Praise be unto our Lord, Squircle | Passport SQW100-1/10.3.1.2558
    04-02-15 02:33 PM
  18. advcomputer's Avatar
    I have tried all of them on both my Z10 and Z30 and still the same problem.

    -Jeff
    04-02-15 02:33 PM
  19. D3C0D3R's Avatar
    I have tried all of them on both my Z10 and Z30 and still the same problem.

    -Jeff
    Do you have another Bluetooth receiver device that you can test this with?

    If it's persistent across devices, I'd say seems to be a faulty hardware component, but if it's not, it could just be your head unit having compatibility issues...

    Praise be unto our Lord, Squircle | Passport SQW100-1/10.3.1.2558
    04-02-15 02:43 PM
  20. advcomputer's Avatar
    Yes, I have tried this out with my Samsung Galaxy Note running iHeart radio several times for hours without issue.

    -Jeff
    04-02-15 03:26 PM
  21. priceless819's Avatar
    I'm using 1767.

    Posted via CB10
    04-02-15 10:37 PM
  22. D3C0D3R's Avatar
    Yes, I have tried this out with my Samsung Galaxy Note running iHeart radio several times for hours without issue.

    -Jeff
    To clarify, I mean testing your BlackBerry on a different bluetooth receiving device, like a head unit or bluetooth-enabled speaker :P

    Praise be unto our Lord, Squircle | Passport SQW100-1/10.3.1.2558
    04-02-15 11:51 PM

Similar Threads

  1. Replies: 7
    Last Post: 04-05-15, 01:41 AM
  2. Autoloader for official 10.3.1 update for my TMobile Z10
    By ggap10 in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 04-01-15, 11:18 PM
  3. How do I swap the location of the Word Prediction on my Q10?
    By CatchTwentyTwo in forum BlackBerry Q10
    Replies: 7
    Last Post: 04-01-15, 12:44 AM
  4. Z10 usrrs don't update to slow 10.3.1
    By Labba Labbala in forum BlackBerry Z10
    Replies: 18
    Last Post: 03-31-15, 06:02 PM
  5. Can u get snapchat on blackberry 10
    By richmaz3333 in forum Ask a Question
    Replies: 3
    Last Post: 03-31-15, 08:53 AM
LINK TO POST COPIED TO CLIPBOARD