09-08-13 10:11 PM
43 12
tools
  1. Jeandry Brito's Avatar
    I was wondering, now that Android has or going to upgrade to a newer version, will we when buying an Z30 able to upgrade to this Version??

    To read more about these Android Versions:
    http://gigaom.com/2013/09/03/give-me...kitkat-tie-in/

    Posted via CB10 app on my Z10 Stl100-1 on 10.2.0.1047
    09-03-13 11:02 PM
  2. rizaru_rin's Avatar
    I was wondering, now that Android has or going to upgrade to a newer version, will we when buying an Z30 able to upgrade to this Version??

    To read more about these Android Versions:
    http://gigaom.com/2013/09/03/give-me...kitkat-tie-in/

    Posted via CB10 app on my Z10 Stl100-1 on 10.2.0.1047
    Android platform is known for their slow software adaptation, due to brand specific updates. This 4.4 won't reach any device (unless nexus and Google play version) until a few months after it's announced. Heck, even some android flagships right now will stuck either on 4.2/4.3. So I don't see why BlackBerry should update their runtime to this 4.4, at least until 6-9 months from now.

    Posted via CB10
    q649 likes this.
    09-03-13 11:07 PM
  3. wildbanger's Avatar
    5.5 is chicken noodles or what. Lol

    Channel : C000FA856 | Z10STL100-3/10.2.0.1047
    09-03-13 11:11 PM
  4. Jeandry Brito's Avatar
    Android platform is known for their slow software adaptation, due to brand specific updates. This 4.4 won't reach any device (unless nexus and Google play version) until a few months after it's announced. Heck, even some android flagships right now will stuck either on 4.2/4.3. So I don't see why BlackBerry should update their runtime to this 4.4, at least until 6-9 months from now.

    Posted via CB10
    I understand, but my question still remains unanswered.
    One more time, if BlackBerry Z30/A10 (as known) comes with the Android runtime version 4.2, when this 4.4 updates come out (whether it takes a year or a month) will we be able to update our runtime?

    Posted via CB10 app on my Z10 Stl100-1 on 10.2.0.1047
    09-03-13 11:19 PM
  5. Tre Lawrence's Avatar
    5.5 is chicken noodles or what. Lol

    Channel : C000FA856 | Z10STL100-3/10.2.0.1047
    Not a bad dessert idea.

    I think the innate problem with the runtime is becoming exposed.
    09-03-13 11:23 PM
  6. Pdinos3's Avatar
    What makes you think we wouldn't be able to and why are you so worried?

    Via CB10 Rockin 10.2.0.1443 and proud member of "The Squircle of Trust" Group
    09-03-13 11:23 PM
  7. wu-wei's Avatar
    I understand, but my question still remains unanswered.
    One more time, if BlackBerry Z30/A10 (as known) comes with the Android runtime version 4.2, when this 4.4 updates come out (whether it takes a year or a month) will we be able to update our runtime?

    Posted via CB10 app on my Z10 Stl100-1 on 10.2.0.1047
    The first iteration of 10.0 and 10.1 had 2.3.3. 10.2 runtime is 4.2.2. Logic tells me that 4.4 will be implemented at some point, across all devices.
    09-03-13 11:28 PM
  8. rizaru_rin's Avatar
    I understand, but my question still remains unanswered.
    One more time, if BlackBerry Z30/A10 (as known) comes with the Android runtime version 4.2, when this 4.4 updates come out (whether it takes a year or a month) will we be able to update our runtime?

    Posted via CB10 app on my Z10 Stl100-1 on 10.2.0.1047
    I couldn't give you a definitive answer for that, but the most probable answer is no. They won't see any big difference for app support compatibility between 4.2.2 and 4.4. Also this runtime implementation on BB10 OS is not a 'plug and play' feature, so it'll be another hassle for them to tweak here-and-there in order for it to work properly. The cost is just not justifiable, considering their financial condition now.

    Posted via CB10
    09-03-13 11:32 PM
  9. bobshine's Avatar
    They are already updating it now to 4.2, I don't see why they won't do it again. Also, since the only difference is OS features between 4.2 and 5.0 (or whatever new version it will be)... there is no advantage for BlackBerry to upgrade now. Very few rare apps will use the latest android version.

    Posted via CB10
    09-03-13 11:33 PM
  10. rizaru_rin's Avatar
    The first iteration of 10.0 and 10.1 had 2.3.3. 10.2 runtime is 4.2.2. Logic tells me that 4.4 will be implemented at some point, across all devices.
    For me, it'll be more than likely for BBRY to update their runtime from 4.2.2 to 5.1, or even 5.3. They still have a lot other important things to do, rather than android runtime slight update.

    Posted via CB10
    ggrassl likes this.
    09-03-13 11:34 PM
  11. wu-wei's Avatar
    For me, it'll be more than likely for BBRY to update their runtime from 4.2.2 to 5.1, or even 5.3. They still have a lot other important things to do, rather than android runtime slight update.

    Posted via CB10
    Yes, like figure out a way to make money from cross platform BBM? If they want to stay relevant, they keep current with Android. End of story.

    That's just my opinion, but I could blather on for a long time about why I hold that opinion.

    BerryLeaks co-founder | myver
    09-03-13 11:39 PM
  12. rizaru_rin's Avatar
    Yes, like figure out a way to make money from cross platform BBM? If they want to stay relevant, they keep current with Android. End of story.

    That's just my opinion, but I could blather on for a long time about why I hold that opinion.

    BerryLeaks co-founder | myver
    Being on 4.2.2 when latest android is still 4.4 can be considered as current, no? As all apps available now can run on 4.1++. When Android 5.0 became a mainstream OS for most android devices out there (and apps requirement increase to minimum 4.4++/5.0), it's time for BBRY to update their runtime again.

    Posted via CB10
    09-03-13 11:44 PM
  13. wu-wei's Avatar
    Being on 4.2.2 when latest android is still 4.4 can be considered as current, no? As all apps available now can run on 4.1++. When Android 5.0 became a mainstream OS for most android devices out there (and apps requirement increase to minimum 4.4++/5.0), it's time for BBRY to update their runtime again.

    Posted via CB10
    True, I'm not saying immediate adoption is necessary, but resources are better spent in that general vicinity.

    BerryLeaks co-founder | myver
    09-04-13 12:14 AM
  14. MasterOfBinary's Avatar
    5.5 is chicken noodles or what. Lol

    Channel : C000FA856 | Z10STL100-3/10.2.0.1047
    Some people think 6 will be Milkshake

    Given the jump from version 2.3 to 4.2, I'm guessing we'll see another big jump in a year or two.
    Last edited by MasterOfBinary; 09-04-13 at 12:32 AM. Reason: Wrong version number
    09-04-13 12:32 AM
  15. emprize's Avatar
    i guess it would depends on how many new sdk api they added in new android version
    09-04-13 01:34 AM
  16. ravipiero's Avatar
    I prefer BB enhance the current runtime first rather than keep updating to latest. The current runtime manage to run most of my apps, but it's still lag even compare to cheap android phone.

    Posted via CB10
    09-04-13 03:01 AM
  17. f0xG3's Avatar
    I prefer BB enhance the current runtime first rather than keep updating to latest. The current runtime manage to run most of my apps, but it's still lag even compare to cheap android phone.

    Posted via CB10
    But you gotta admit though, running BOTH BB10 and Android apps in a single phone is probably more impressive. Though I really hope BB can squeeze more performance on their Android player future builds.
    09-04-13 04:11 AM
  18. whatsever's Avatar
    No prob most will stay behind with 2.x or 4.1

    Posted via CB10
    09-04-13 04:51 AM
  19. anon(5818411)'s Avatar
    The funny thing is the majority of the new android devices will get 4.2.2 after we get the 10.2 with 4.2.2 runtime. Meaning why would there be many developers making apps for 4.4 when barely any are making 4.0 and above apps.

    So, don't worry we'll most likely have 4.4 before the majority of the android devices do. You'll probably see it in 10.3 leaks

    Posted via CB10
    09-04-13 07:09 AM
  20. bnwg's Avatar
    Compatibility of android port app running on runtime is the key.
    The android port of CallVibrate (That is, vibrated when call is connected. It even can be configured to vibrate when call is placed and ended) works flawlessly in 2.3.3 runtime. Once it is configured, closes it and it works "headless". But it totally fails in 4.2.2 runtime.
    The latest doesn't mean the best. 4.3 is not yet as stable as 4.2.2 even on Android itself.
    Just my 2cents though
    Its Spade likes this.
    09-04-13 07:50 AM
  21. cjmcmillion's Avatar
    5.5 Toasted Marshmallows

    Posted via CB10
    09-04-13 08:19 AM
  22. pkcable's Avatar
    4.2.2 isn't even officially out yet on BB10!
    toobs623 likes this.
    09-04-13 09:01 AM
  23. SHADOW's Avatar
    The first iteration of 10.0 and 10.1 had 2.3.3. 10.2 runtime is 4.2.2. Logic tells me that 4.4 will be implemented at some point, across all devices.
    If 10.0 and 10.1 had 2.3.3 and 10.2 has 4.2.2 I think 10.3 will also have 4.2.2 and then 10.4 and 10.5 will have 8.1.1

    The Gamer's Network- C00015A3 || From my Z on .1047
    09-04-13 02:45 PM
  24. ARWestenberger's Avatar
    I'm not sure why having 4.3 matters. Most Android developers at least at the moment aren't going to make an app for a version that most devices can't handle/wont be upgraded to. With 4.2.2 they have a pretty safe bet that a lot of people will be able to use their application.

    BlackBerry Z10 | Verizon | 10.2.0.1371 | In Squircle We Trust
    09-04-13 07:57 PM
  25. JoBudden's Avatar
    Only of bbry intends to support their products after a sell. Which I do t see happening.

    Posted via CB10
    09-04-13 08:44 PM
43 12

Similar Threads

  1. BBM android and ios available yet?
    By siong23 in forum General BBM Chat
    Replies: 15
    Last Post: 09-06-13, 04:49 PM
  2. PlayBook froze and now it will not restart or reboot
    By gp2002 in forum BlackBerry PlayBook
    Replies: 9
    Last Post: 09-05-13, 06:44 AM
  3. Blackberry Q10: First-class Citizen or Not?
    By OJ Tibi in forum BlackBerry Q10
    Replies: 3
    Last Post: 09-03-13, 10:51 PM
LINK TO POST COPIED TO CLIPBOARD