06-02-15 03:50 PM
65 123
tools
  1. Croberry1989's Avatar
    I think there is something really screwed in this new Android Runtime. Some of my Android apps are not working at all, which worked without problem on 10.2.1. For example Medscape app is completely unstable. I use other banking apps which don't work properly. So what's updated in this "new" version?
    And don't tell me it's a leak.10.3.1.1154. is an official version on BlackBerry Classic. What are they doing?

    I'm running 10.3.1.1154. on Z30.

    Posted via CB10
    PatrickMJS likes this.
    12-21-14 06:40 AM
  2. Legal Eagle's Avatar
    And don't tell me it's a leak.10.3.1.1154. is an official version on BlackBerry Classic. What are they doing?
    Yes, and for every one person having this issue there are thousands of others who are not.

    Law of averages dictates that a small percentage of people may have issues with any OS for whatever reason, but just because you happen to be one of those people doesn't mean that BlackBerry have released a crappy OS.

    An yes, it is a leaked OS for your device, it is only Official on the Classic which is a whole different device to your Z30.
    12-21-14 06:46 AM
  3. BigBadWulf's Avatar
    1) I don't think the OS was ready for the Classic, let alone any other model, but they had to get it released to market.
    2) There are too many android apps to guarantee stability on every official android OS, let alone running on a BlackBerry.
    3) If you're not happy put the official OS back on.
    Dodger52 and diegonei like this.
    12-21-14 07:18 AM
  4. Croberry1989's Avatar
    Yes, and for every one person having this issue there are thousands of others who are not.

    Law of averages dictates that a small percentage of people may have issues with any OS for whatever reason, but just because you happen to be one of those people doesn't mean that BlackBerry have released a crappy OS.

    An yes, it is a leaked OS for your device, it is only Official on the Classic which is a whole different device to your Z30.
    Well Medscape is a pretty popular app being used by a lot of people. And most of us have problems with 10.3.1. I haven't said BB have released a crappy OS. I'm wondering why fix something if it ain't broken.

    Posted via CB10
    PatrickMJS and Trauma Surgeon like this.
    12-21-14 08:05 AM
  5. Croberry1989's Avatar
    1) I don't think the OS was ready for the Classic, let alone any other model, but they had to get it released to market.
    2) There are too many android apps to guarantee stability on every official android OS, let alone running on a BlackBerry.
    3) If you're not happy put the official OS back on.
    Yes. But all those apps worked on 10.2.1. I am just wondering why they do not work now. On 10.3.1.

    Posted via CB10
    12-21-14 08:07 AM
  6. BigBadWulf's Avatar
    Yes. But all those apps worked on 10.2.1. I am just wondering why they do not work now. On 10.3.1.

    Posted via CB10
    Because you aren't supposed to have installed it! It's a leak, aka stolen property of BlackBerry's. Would you complain if you stole a TV from Walmart, and it gave you a bad picture on certain channels?

    I don't mind helping people with issues, but I do mind seeing this be a sounding board for gripe sessions on leaks. If you'd like help, ask.
    bluetroll, thedose and Hedi Regaya like this.
    12-21-14 08:24 AM
  7. Croberry1989's Avatar
    Because you aren't supposed to have installed it! It's a leak, aka stolen property of BlackBerry's. Would you complain if you stole a TV from Walmart, and it gave you a bad picture on certain channels?

    I don't mind helping people with issues, but I do mind seeing this be a sounding board for gripe sessions on leaks. If you'd like help, ask.
    Haha. You are funny.
    I was hoping to see if someone can explain the reason for this not to complain about stolen property of BlackBerry. And as I was saying, it is not a leak if it is on some official devices. It is official on Classic, and 10.3.0 is official on Passport. So I was wondering have they noticed the same problems I have?


    Posted via CB10
    12-21-14 09:31 AM
  8. bluetroll's Avatar
    The key is not to complain about it...

    You can't complain about a beta OS. It's not even supposed to be for the general public.

    You can try sideloading the Android player bar from 10.3.1.10xx

    I know that Simpsons Tapped Out would load on my Z10, but it wouldn't load on 1154.

    Hope that helps.

    Posted via CB10
    BigBadWulf likes this.
    12-21-14 09:35 AM
  9. BigBadWulf's Avatar
    Haha. You are funny.
    I was hoping to see if someone can explain the reason for this not to complain about stolen property of BlackBerry. And as I was saying, it is not a leak if it is on some official devices. It is official on Classic, and 10.3.0 is official on Passport. So I was wondering have they noticed the same problems I have?


    Posted via CB10
    Those phones never had 10.2 on them to compare and contrast.
    12-21-14 09:39 AM
  10. vbdwork's Avatar
    Yes. But all those apps worked on 10.2.1. I am just wondering why they do not work now. On 10.3.1
    Just roll back to 10.2.x and wait for the official release of 10.3.x for your device. Other option is to call BlackBerry Customer Support and ask them the very same question why specific Android app is not running properly on a leaked BB10 OS you have loaded on your phone. I'm pretty sure you are going to have a very short conversation with them.
    BigBadWulf likes this.
    12-21-14 11:39 AM
  11. dbmalloy's Avatar
    Do not get people.... do a bit of research... I own 2 android devices and I can tell you straight up that not all apps I download from Google Play work on my devices... I run into same issue BB users have.. many times it depends on the version of the App... I had a number of instances with Instagram especially where an newer version would not work on my tablet... I have an Samsung tabllet running 4.31 and my wife has a tablet runing 4.4,,, can download on app on mine and the same on hers and have one not work... I think as Android hardware is so fragmented and forked in so many ways.... it seems to be a crap shoot as to what works.... I think this is what BB users are up against.. Have to agree how frustrating it is to hear all these generalization that "If it is an issue to me... it must be an issue for all" .... the epitome of the "me" generation... face facts... you bought a BB phone... not an Android... BB has never push nor said Android is 100 percent compatible ...for that matter never really pushed Android compatability at all in its promotion material in the NA and European markets.... Perhaps it is time those who complain about Android not running on BB correctly.. admit they made a mistake and switch to s shiny new Android and quit bothering us.... all would be quieter this holiday season....
    slotime and BigBadWulf like this.
    12-21-14 11:57 AM
  12. Croberry1989's Avatar
    Why so angry about this simple question?
    I bought a BlackBerry device but it is lacking in some of the apps ,problem which they try to overcome by embedding Android runtime in their BB10 OS.
    I am in Leaks part of the Crackberry forum, so I think that I can discuss about problems in those leaks. It is completely stupid to come here and lecture me about this version being a leak and that I cannot comment on shortcomings of this said Leak because it is not official. It is nonsense.
    These fanboys. If someone who doesn't own BB device would point to you that the BlackBerry 10 App world is too small you would boast to them that it CAN RUN ANDROID APPS, and that people are ignorant and volatile aagainst BB. Haha. Terrible.

    Posted via CB10
    12-21-14 12:49 PM
  13. vbdwork's Avatar
    What fanboys? What are you talking about?
    People are telling you that there is NO GUARANTEE an Android app will work on BB10 OS!
    will308, BigBadWulf and thedose like this.
    12-21-14 01:29 PM
  14. Croberry1989's Avatar
    What fanboys? What are you talking about?
    People are telling you that there is NO GUARANTEE an Android app will work on BB10 OS!
    Read man. That is not what i said im my first post. I am just wondering why some apps worked great on 10.2.1. And not on 10.3.1.That's too much to even mention here.

    Posted via CB10
    MobileMadness002 likes this.
    12-21-14 01:33 PM
  15. vbdwork's Avatar
    Because of changes in Android Runtime, probably?
    meltbox360 likes this.
    12-21-14 01:40 PM
  16. WArcher's Avatar
    I think there is something really screwed in this new Android Runtime. Some of my Android apps are not working at all, which worked without problem on 10.2.1. For example Medscape app is completely unstable. I use other banking apps which don't work properly. So what's updated in this "new" version?
    And don't tell me it's a leak.10.3.1.1154. is an official version on BlackBerry Classic. What are they doing?

    I'm running 10.3.1.1154. on Z30.

    Posted via CB10
    There are a lot of issues when you move to a new leaked OS instead of "starting from scratch" (especially if you are physically changing handsets at the same time as you upgrade). Although 1154 is officially only for the Classic there are obviously versions out there in beta test for the other devices - but 10.3.1 was always just for the Classic and "other devices to follow".

    Please try deleting the app and then re-installing it using SNAP or the Amazon store and seeing if that helps.

    Also - I checked on https://play.google.com/store/apps/d...dscape.android to see what the app was all about and there are certainly issues with it that may also explain why you're having problems..

    The way SNAP works there is probably an older .APK file saved on your Z30 in the downloads folder on the device (not SD card) - that might be another thing to try.
    BigBadWulf likes this.
    12-21-14 01:57 PM
  17. ChrisAmbrose's Avatar
    Good point... I wonder if Passport / Classic could run 10.2/2.1 OS if it had said radio file... they must have had it running on that in testing back in the start of this year

    PassportSQW100-1/10.3.1.1016
    12-21-14 01:59 PM
  18. clipskid's Avatar
    What fanboys? What are you talking about?
    People are telling you that there is NO GUARANTEE an Android app will work on BB10 OS!
    John Chen is! haha
    12-21-14 03:18 PM
  19. BigBadWulf's Avatar
    Why so angry about this simple question?
    I bought a BlackBerry device but it is lacking in some of the apps ,problem which they try to overcome by embedding Android runtime in their BB10 OS.
    I am in Leaks part of the Crackberry forum, so I think that I can discuss about problems in those leaks. It is completely stupid to come here and lecture me about this version being a leak and that I cannot comment on shortcomings of this said Leak because it is not official. It is nonsense.
    These fanboys. If someone who doesn't own BB device would point to you that the BlackBerry 10 App world is too small you would boast to them that it CAN RUN ANDROID APPS, and that people are ignorant and volatile aagainst BB. Haha. Terrible.

    Posted via CB10
    You as I said before are more than welcome to ask for help. That's not what you did.

    As pointed out, it's a different ART, and android is a mess unto itself. BlackBerry can run most apps not requiring Google services well, and with some manipulation even many that require that, but it's going to take some research and effort on your part. Overall, I'd say 10.3.1 runs android much better than 10.2.
    thatwiztidkid likes this.
    12-21-14 05:01 PM
  20. bmoney1229's Avatar
    Did you backup your previous OS and restore it after you upgraded your OS to 10.3.1?

    Posted via CB10
    12-21-14 07:18 PM
  21. luckyphil88's Avatar
    Can someone please upload the runtime before 10.3.1.1154? I got this problem with "no Internet connection" on all android apps I usually using

    Posted via CB10
    12-22-14 12:57 AM
  22. Croberry1989's Avatar
    You as I said before are more than welcome to ask for help. That's not what you did.

    As pointed out, it's a different ART, and android is a mess unto itself. BlackBerry can run most apps not requiring Google services well, and with some manipulation even many that require that, but it's going to take some research and effort on your part. Overall, I'd say 10.3.1 runs android much better than 10.2.
    Yes. But I cannot understand why something works on previous versions and not on the newer ones. I am worried if the official version would also have this problem. Then I'm literally stuck on 10.2.1. Because I need those apps.

    Posted via CB10
    12-22-14 06:06 AM
  23. Croberry1989's Avatar
    Did you backup your previous OS and restore it after you upgraded your OS to 10.3.1?

    Posted via CB10
    No. I never restore. Always clean autoload.

    Posted via CB10
    12-22-14 06:06 AM
  24. BigBadWulf's Avatar
    Yes. But I cannot understand why something works on previous versions and not on the newer ones. I am worried if the official version would also have this problem. Then I'm literally stuck on 10.2.1. Because I need those apps.

    Posted via CB10
    I don't know how we could explain it any better for you. The chances of a newer ART being a negative are low, but for any given app a possibility. If android apps are the priority, maybe BlackBerry isn't the right platform for you.
    12-22-14 09:33 AM
  25. bloodyrek's Avatar
    Well if they work on 10.2.1, stay on it? It's a leak.

    Posted via CB10
    12-22-14 06:26 PM
65 123

Similar Threads

  1. OS 10.3.1.1154 Experience Questionnaire V2
    By grahamf in forum BB10 Leaked/Beta OS
    Replies: 17
    Last Post: 12-29-14, 09:46 AM
  2. How can I downgrade from developers OS 10.3 to official OS 10.2?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-21-14, 06:42 AM
  3. How do I upgrade to 10.3 without an autoloader?
    By CrackBerry Question in forum Ask a Question
    Replies: 12
    Last Post: 12-21-14, 06:03 AM
  4. No Notification after 10.3.1.1016 update???? Pls help
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-21-14, 05:45 AM
  5. Does the 10.3 update will have call blocking options?
    By arlene_t in forum BlackBerry Q10
    Replies: 1
    Last Post: 12-21-14, 05:02 AM
LINK TO POST COPIED TO CLIPBOARD