01-11-14 12:41 PM
34 12
tools
  1. Joe_zhouzhenren's Avatar
    Does anyone has the same problem like me?

    Posted via CB10
    12-27-13 06:02 PM
  2. anon6113468's Avatar
    My battery life actually seems to be a little bit better actually
    12-27-13 06:08 PM
  3. howards's Avatar
    Does anyone has the same problem like me?

    Posted via CB10
    How long have you had it loaded on your phone? Generally takes a day or so to settle down after an OS install.

    Z30 / STA 100-3 / 10.2.1.1259
    Jamie Wooten likes this.
    12-27-13 06:20 PM
  4. Jamie Wooten's Avatar
    Sorry, I'd have to say this is the best battery life I've ever had.

    Posted via CB10
    meltbox360 and dragon1234 like this.
    12-27-13 06:22 PM
  5. sickyute's Avatar
    If you recently installed this leak OS and restored from a back up. You will experience abnormal battery drains. In my experience it totally settles after 4-5 days.

    Posted via CB10
    12-27-13 06:31 PM
  6. anon(1035135)'s Avatar
    I agree with previous poster. For me, this has been the best. I have found myself confused at times over the Christmas break wondering why it has lasted as long with the same usage. Thought maybe I was doing it wrong... lol

    Posted via CB10
    12-27-13 06:33 PM
  7. sonicmerlin's Avatar
    Unfortunately for me my battery life, particularly while on standby, hasn't changed ever since 10.0. Even with the screen off and all radios except the cell radio off, "System" uses 3 times as much as "Standby" overnight according to Device monitor. Something keeps running in the background and sucking up battery power. I'm getting tired of it after seeing so many others don't have this issue.
    12-27-13 07:00 PM
  8. Moacirusa's Avatar
    I am on 1925. Today my battety lasted from 07am to 05 pm with heavy usage. I was impressed, because usually it only lasts for no more them 4 hours. Z10 - 3
    12-27-13 07:11 PM
  9. anon6113468's Avatar
    Unfortunately for me my battery life, particularly while on standby, hasn't changed ever since 10.0. Even with the screen off and all radios except the cell radio off, "System" uses 3 times as much as "Standby" overnight according to Device monitor. Something keeps running in the background and sucking up battery power. I'm getting tired of it after seeing so many others don't have this issue.
    Have you ever tried reloading the OS and not restoring the settings folder on BlackBerry Link ? Or installing a leaked OS without the settings ?
    You may have a corrupt file that is sucking up your battery.

    It can also be an android port. I would recommend that you uninstall any android port you have (if you have one) and see if there is any difference.

    Anyway, it is not normal that you don't have at least 10h of battery with the radio off.

    Posted via CB10
    12-28-13 05:40 PM
  10. DrePizzle's Avatar
    I have the Q10 and my install had the old radio attached to it, my battery life wasn't what it used to be. I flashed the new recommended radio ( I think 1899) and my battery life I much better.... so I guess what I am saying is.... check what radio version you have installed.

    Posted via CB10
    12-28-13 06:04 PM
  11. bennyph's Avatar
    Use escreen to disable LTE, only allow 4G connection, and turn off "Fast Dormancy" will save you tons of battery juice.

    Posted via CB10
    12-28-13 06:17 PM
  12. Matthew Hicks1's Avatar
    Not much of a problem here and the only tuning I've done is changing the screen brightness, white saturation, and screen timeout. I'm fairly amazing at the battery life compared to my other handset I've been using (Galaxy Nexus).
    12-28-13 06:36 PM
  13. tickerguy's Avatar
    Use escreen to disable LTE, only allow 4G connection, and turn off "Fast Dormancy" will save you tons of battery juice.

    Posted via CB10
    Uh, "fast dormancy"? Where?

    LTE can be turned off from the network page and it does help as the LTE bug is still there.
    flacrack likes this.
    12-28-13 06:41 PM
  14. nickdollimount's Avatar
    I actually got 2 days out of mine which is unheard of for mine. And it hasn't been on here long.

    Posted via CB10
    12-28-13 07:31 PM
  15. Joe_zhouzhenren's Avatar
    I reloaded the os and wiped os yesterday, and the battery life is strong like 1809's os.

    Posted via CB10
    12-28-13 08:25 PM
  16. imadorkx's Avatar
    Nope. My Q10 still running strong since yesterday.


    1925's battery life is worse than 1809-img_20131229_104609.png
    12-28-13 08:46 PM
  17. hammer40's Avatar
    The 10.2.1 leaks have been best for battery for me. I've installed almost every available leak.


    Posted via CB10
    12-28-13 08:47 PM
  18. BennyX's Avatar
    what I want to know is what OS version has been and remains the best for battery life? Only because Z10's battery life is enough to incite crowds into laughter of the mocking kind.
    12-28-13 09:21 PM
  19. Coffee Shampoo's Avatar
    Maybe there's something consuming your battery because mine is in its best shape since I bought the phone in September (Q10). This leak slightly improved the battery, not by much, but it did and I also feel like it charges faster!

    Star Wars fan? Come join us C00121E8E
    12-28-13 09:44 PM
  20. flacrack's Avatar
    Uh, "fast dormancy"? Where?

    LTE can be turned off from the network page and it does help as the LTE bug is still there.
    Perhaps you can turn off LTE on T-Mobile, but I don't think I can on ATT. Love the blog! Looking to be validated in the New Year!!!
    01-05-14 09:50 PM
  21. sickyute's Avatar
    I've added the new radio and I'm seeing significant improvement. Will post a pic later.

    Z10STL100-1/10.2.1.1925

    Posted via CB10
    01-08-14 08:48 AM
  22. dicks-webos's Avatar
    You must install the latest radio 1926 because the battery life is indeed bad with leak 1925 (+1899 radio). With the radio 1926 you will see significantly improved battery life.
    01-08-14 09:08 AM
  23. sickyute's Avatar
    Battery Life
    1925's battery life is worse than 1809-img_20140108_125150.png

    Posted via CB10
    01-08-14 10:57 AM
  24. yellowhammer's Avatar
    Does anyone has the same problem like me?

    Posted via CB10
    Not here - battery life is as good or better than 1809. Maybe you need to reload the OS.

    Posted via CB10
    01-08-14 11:41 AM
  25. Al Ranson's Avatar
    Battery life was way better on the z30 running 1925 with an older radio. Since I flashed in the new radio ive noticed a faster drain. (either that or I'm using my phone more haha)

    Posted via CB10
    01-08-14 12:48 PM
34 12

Similar Threads

  1. .1925 "Unknown Error"
    By Danny Ocean in forum BB10 Leaked/Beta OS
    Replies: 21
    Last Post: 12-25-14, 09:44 PM
  2. Does anyone facing battery issue with last leak 10.2.1.1925?
    By scatteril in forum BlackBerry 10 OS
    Replies: 33
    Last Post: 01-05-14, 08:53 AM
  3. Replies: 3
    Last Post: 12-29-13, 10:59 AM
  4. 10.2.1.1925 Music Import text error in media player
    By Michael Santoro in forum BB10 Leaked/Beta OS
    Replies: 4
    Last Post: 12-28-13, 09:51 PM
  5. Why is Viber a paid app in BB World?
    By Claude Mouawad in forum BlackBerry World
    Replies: 3
    Last Post: 12-27-13, 03:19 PM
LINK TO POST COPIED TO CLIPBOARD