1. DCHammer's Avatar
    So I've had a Z10 since launch day in Manitoba. I've been incredibly impressed with this bloody thing. I've dropped it, abused it and generally treated it relatively poorly. If it had been an iPhone or even a Samsung, I'd have had to replace it 3 times already. One day, it fell from 5 feet onto a tile floor landing flat on its back. Bounced the back cover off and and SIM card partway out of position. Reboot and all was good. The final straw was getting it wet one time at the lake this summer. Since then, it regularly drops network connection and generally drove me nuts.
    So I went looking on Kijiji and found a replacement. Nice clean 100-3 with 10.3.1.747 already on it.
    Well, I'm not sure if the guy that sold it to me really needed the cash or needed to get rid of it after putting a leak on it and screwing it up and not knowing what to do about it.

    I'm downgrading to 10.2.1.x. Whatever Wind Mobile's current standard is. 10.3.1.747 is causing this phone to run so hot I could literally use it as a handwarmer if I keep it in my pocket. With absolutely nothing running, it's eating a battery in 90 minutes to 2 hours.

    Wondering if anyone else has had similar problems with that leak version on their Z10.
    01-24-15 12:30 PM
  2. Easy-G's Avatar
    I haven't had that issue, but it's been a while since that leak has been on the go. Let us know if things cool off. Maybe it's an issue with the battery itself?

    Posted via CB10
    01-24-15 12:43 PM
  3. DCHammer's Avatar
    Definitely not the battery. First thing I tried. I had two batteries from my old phone so I marked them so I knew which was which and kept track. I'm assuming it's something with the OS. It's entirely possible there is something seriously wrong with the hardware itself and I just blew $150 but such is life.
    01-24-15 01:05 PM
  4. howards's Avatar
    Could very well be the OS. Try reverting as you suggested to your official 10.2.1 OS. I think you'll see a difference.

    Z30 / STA 100-3 / 10.2.1.3289
    01-24-15 01:21 PM
  5. DCHammer's Avatar
    Just finished the downgrade. Phone is rebooting now. I should know in the next 30 minutes. I'll let everyone know.
    01-24-15 01:38 PM
  6. WimpySr's Avatar
    I have my wife's z10 running on 10.3.1.2072 now. Very stable with no battery issues so I'd recommend that if you don't like going back to the 10.2.x.x.

    Posted via CB10
    Last edited by WimpySr; 01-26-15 at 06:49 PM.
    01-24-15 03:06 PM
  7. garrett1972's Avatar
    I'm on Wind. Even from Winnipeg but been living in Calgary for years now. I didn't know that Wind is in Manitoba...

    I've run most leaks and some have been really hard on the battery. Hard to remember what the exact cause is. May be due to account issues or certain Android apps.

    I'm on Z10STL100-3/10.3.1.1949 with Wind right now and overall quite stable with decent battery performance.

    Planning the bump up to the newest leak this weekend possibly.

    I have 2 batteries too. One always heats up and dies faster too, but the OS and app assortment probably are the biggest issues.
    I do like the battery saving mode. Kept my phone from completely being out of juice when the charger came out overnight.

    Posted via the CrackBerry App for Android
    01-24-15 09:09 PM

Similar Threads

  1. Is BlackBerry 10 OS a unix system
    By Ashraf Altayeb in forum BlackBerry 10 OS
    Replies: 33
    Last Post: 02-07-18, 06:15 PM
  2. BlackBerry Link and Blend on Windows 10
    By Benbb10qnx in forum Desktop Software
    Replies: 7
    Last Post: 05-18-17, 08:36 AM
  3. Replies: 13
    Last Post: 01-24-15, 10:35 AM
  4. How can I update my Z10 OS to 10.3?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-24-15, 02:25 AM
LINK TO POST COPIED TO CLIPBOARD