1. Ertank's Avatar
    My device is not recognizable after the update by BlackBerry Link. Chrome Extension is not able to connect device either.

    Anybody could side load any app?
    08-21-14 04:22 PM
  2. Paul Ogorzow's Avatar
    Yes I'm able to do so. If BlackBerry Link isn't recognising your device try to upgrade BlackBerry device manager.

    Posted via CB10
    08-21-14 04:27 PM
  3. Ertank's Avatar
    Yes I'm able to do so. If BlackBerry Link isn't recognising your device try to upgrade BlackBerry device manager.

    Posted via CB10
    And how do I do that?
    08-21-14 04:31 PM
  4. Cobalt232's Avatar
    You can also sideload Snap using Snap Installer. Just follow the steps described for WiFi transfer if you have problems with USB.
    http://forums.crackberry.com/android...taller-902493/
    08-21-14 04:35 PM
  5. kye2000's Avatar
    Cannot connect to link properly after loading this build

    Posted via My Z30 running 10.3.0.1052
    08-21-14 04:40 PM
  6. isp23's Avatar
    Yes I'm able to do so. If BlackBerry Link isn't recognising your device try to upgrade BlackBerry device manager.

    Posted via CB10
    This worked for me when I had the same issue after installing 10.3.

    I actually got the new device manager by using the link when the BlackBerry Blend menu comes up - it will say something about check your internet connection and there an option to install drivers there as well. Once I did that it updated the device manager for me and then everything worked as it should.
    jose_trevizo likes this.
    08-21-14 04:42 PM
  7. josh74's Avatar
    This worked for me when I had the same issue after installing 10.3.

    I actually got the new device manager by using the link when the BlackBerry Blend menu comes up - it will say something about check your internet connection and there an option to install drivers there as well. Once I did that it updated the device manager for me and then everything worked as it should.
    Yep it will work after loading the drivers.
    08-21-14 05:19 PM
  8. The Big Picture's Avatar
    No problem here

    Posted via CB10
    08-21-14 05:56 PM
  9. dpw09's Avatar
    And how do I do that?
    Unplug device
    Uninstall all BlackBerry items in control panel on pc
    Plug device in and a popup will appear prompting you to install blend
    If popup is not there open my computer and select BlackBerry
    Launch file and install

    Z10STL100-3/10.3.0.1052
    08-21-14 07:02 PM
  10. LostOnThePianoRoll's Avatar
    To make your device connect just go settings > storage and access and change it from auto detect to connect to windows.. it should work right away

    Posted via CB10
    Carjackd and Signhere like this.
    08-21-14 07:09 PM
  11. jsmall999's Avatar
    I needed to reinstall link from the device before it would recognize the z30

    Posted via CB10
    08-21-14 07:33 PM
  12. evergray's Avatar
    I installed it via google chrome

    Posted via CB10
    08-21-14 08:50 PM
  13. GP540's Avatar
    Mine works fine.

    Posted via CB10
    08-21-14 09:48 PM
  14. cptpeachfuzz's Avatar
    no problems here
    08-21-14 09:58 PM
  15. Supa_Fly1's Avatar
    Cannot connect to link properly after loading this build

    Posted via My Z30 running 10.3.0.1052
    try a direct and different USB port ... avoid using hubs. That's your first line of troubleshooting before wasting time downloading and installing the BB Link client.
    Second if that doesn't resolve, check all your network connections, make sure non are disabled (two are for BB installed by BB Link), Then check your firewall rules are allowing those BB connections to work and not blocked. Those are VERY quick to check and can be done while downloading the latest BBLink sw.
    08-21-14 10:01 PM
  16. RADEoN1337's Avatar
    You need to hook the phone up, go into device manager on your pc, find the BlackBerry devices under networking, and delete the drivers. Next, reboot, and plug your phone in.

    Posted via CB10
    08-21-14 10:24 PM
  17. Stupified's Avatar
    To make your device connect just go settings > storage and access and change it from auto detect to connect to windows.. it should work right away

    Posted via CB10
    This is the quick fix which I have to do after every leak install. It should resolve any USB connection issues that you're having

    Posted via CB10
    08-21-14 10:57 PM

Similar Threads

  1. 10.3.0.1052 borrows Android UI elements?
    By BerryManUK85 in forum BB10 Leaked/Beta OS
    Replies: 20
    Last Post: 08-10-15, 11:53 AM
  2. Does WhatsApp work on 10.3.0.1052?
    By Samuele1996 in forum BB10 Leaked/Beta OS
    Replies: 5
    Last Post: 08-28-14, 03:23 PM
  3. 10.2.1.3247 to 10.3.0.1052 question
    By xXXXMELLORXXXx in forum BB10 Leaked/Beta OS
    Replies: 10
    Last Post: 08-22-14, 01:09 AM
  4. 10.3.0 and older device confusion
    By Jakob Greve in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 08-21-14, 04:31 PM
  5. 10.3.0.1052 os
    By sam bulushi in forum Ask a Question
    Replies: 1
    Last Post: 08-21-14, 02:35 PM
LINK TO POST COPIED TO CLIPBOARD