1. djhaggarty's Avatar
    I have set up the latest gold ndk and simulator and im keen to get started on writing my first app. The 'hello world' new cascades app builds and runs ok in the simulator and i have also built and run a simple app dispaying a button, text box, slider etc.
    However, when I download a sample app such as 'quotes', build it and run it, I get the error message saying no binaries.
    Ive searched google for answers and tried to fix it including cleaning the files, checking and rechecking the ndk set up, but all to no avail.
    Any help from you experts would be much appreciated.
    Thanks, from a keen newbie !
    12-24-12 02:32 AM
  2. Brian Scheirer's Avatar
    If you are getting a no binaries error it is because you don't have binaries for the specific type of launch you are trying to do, in your case it sounds like simulator-debug. (Default is device-debug)

    What you should try doing:
    1. Right click your project... Build Configurations > Set Active > Simulator-Debug
    2. Build
    3. Run
    djhaggarty likes this.
    12-24-12 10:25 AM
  3. djhaggarty's Avatar
    Thanks very much for your reply bcs925. I have the project set to active > Simulator - Debug and I still get the no binaries error. I have noticed that the sample "quotes" project file structure has changed recently (different paths for two of the .qml files) however loading the newer project version still gives the same problem. I then discovered the cascades "getting started" which teaches you to build up the quotes app. I did this, built it and ran the program. This time it compiled ok and ran on the simulator.
    Well it partly works, 2 files (QuoteBubble.qml and QuotePage.qml) dont display in the horizontal split mode, and I get the error "Problem loading qml file, EditContols is not a type". So I cant access these pages on the simulator.
    So I still dont know why I cant run the sample apps (I even followed the guide for migrating an existing old project from an older version of cascades), and the errors above are stopping me from going any further. Any further help would be much appreciated!
    01-04-13 11:09 AM
  4. jeroen_13's Avatar
    Could you please send over the files so one of us here can test it on the simulator/dev alpha
    01-04-13 12:20 PM
  5. djhaggarty's Avatar
    Thanks. How do I add attachments?, can I attach the project file?
    01-04-13 01:01 PM
  6. jeroen_13's Avatar
    Thanks. How do I add attachments?, can I attach the project file?
    Just use dropbox/box.net to upload your project files. You might want to store future projects on your dropbox as backup
    djhaggarty likes this.
    01-04-13 03:17 PM
  7. djhaggarty's Avatar
    Hi there, the quotes project is in the dropbox link below:
    The program partly works on the simulator, 2 files (QuoteBubble.qml and QuotePage.qml) dont display in the SDK horizontal split mode, and I get the error "Problem loading qml file, EditContols is not a type". So I cant access these pages on the simulator.
    Some help in getting these pages to work would be great, as I cant wait to start building my application which will have a similar structure to this example!
    Also any ideas why I still get the error "no binaries" when I import some of the other sample apps. Stamp collector works ok, as does a new blackberry C++ Hello world, but Weatherguesser and Quotes give the no binaries error when I import them and try to build them.
    01-04-13 06:07 PM
  8. djhaggarty's Avatar
    Hi there jeroen_13
    Have you had a chance to run my app on the dev_alpha/simulator yet?
    I am so keen to move forward on this.
    01-11-13 11:22 AM
  9. jeroen_13's Avatar
    I dont own a dev alpha, but my BB10 simulator won't run a single Sample made my rim.. Keep getting errors. Maybe someone with a dev alpha can help out
    01-11-13 12:05 PM
  10. djhaggarty's Avatar
    Hi jeroen_13
    I have just reinstalled the gold SDK, and simulator (I noticed the simulator build had changed) and loaded up the quotes app. I did a qml preview of the main.qml and all the other .qml files. three of the qml files showed errors and would not display, the other .qml files did display ok. I then ran it on the simulator and hey presto it all worked!
    So in summary,
    1. Its worth reinstalling the SDK and the simulator (I'd noticed a few other problem reports were fixed by doing this)
    2. Follow the SDK set up precisely.
    3 The SDK qml viewer dosent always display the view even though the simulator does!
    4. The simulator takes ages to run (on my laptop anyway) so wait a while if you just get a blank display. Now I see why a dev alpha is so handy!
    01-11-13 04:00 PM
  11. jeroen_13's Avatar
    reinstalling the Gold SDK also worked for me !
    01-12-13 07:55 AM
  12. djhaggarty's Avatar
    Thats good to hear, thank you for all your help. Onwards and upwards!
    01-12-13 05:46 PM
  13. KermEd's Avatar
    You still need this tested? I can run it across my alpha.

    Sent from my BlackBerry Veedu using Tapatalk 3
    01-16-13 08:49 AM
  14. djhaggarty's Avatar
    Hello KermEd
    Thanks for the offer but I got the quotes app running on the simulator (eventually) without any further problems.
    I have since tried to run another sample project (HttpContactList) and got the same problem when I tried to run it on the simulator (error - no binaries). The only way I could get it to work was to:
    1. build and run a new blackberry cascades project (helloworld), these always seem to build and run ok on the simulator
    2 then add the changes to create the new program.

    So do you get a new bb10 to replace the dev alpha? - I'm pretty jealous if you do!
    01-17-13 02:14 PM
  15. KermEd's Avatar
    I got lucky and won 2 more as well . So I'm very lucky!

    But I have some cases where OS+SDK bugs have plagued me too lol.

    Anywho, congrats on learning cascades!!

    Sent from my BlackBerry Veedu using Tapatalk 3
    djhaggarty likes this.
    01-17-13 06:55 PM
  16. djhaggarty's Avatar
    Thanks to everyone above for your help in solving this newbies problem.

    As I find it pretty frustrating to read some messages for help that just get cryptic or incomplete replies, I thought I'd make a summary of the solution.

    If you try to run a sample app and get the message "no binaries", the following steps seem to solve the problem:
    1. Build the sample program
    2 If using the simulator, choose the build configuration / select active / simulator-debug
    3. Delete the simulator in the project explorer and reinstall the target using the wizard
    4. Reset the vmware simulator
    5. Run the program, it should now install on the simulator.
    I have tried the above method on 3 sample apps now so I think I've cracked it.

    PS. For the time its taken me to sort this out, its a good job I'm not part of the BB10 development team!
    01-19-13 06:40 PM

Similar Threads

  1. Have a problem with the new free app called crackberry smash
    By TaZ52083 in forum BlackBerry OS Apps
    Replies: 2
    Last Post: 03-13-09, 12:31 AM
  2. Have a problem with the new free app called crackberry smash
    By TaZ52083 in forum BlackBerry Storm
    Replies: 2
    Last Post: 03-13-09, 12:31 AM
  3. I have a problem with the ringtone and with the msn and aim
    By Katherine1989 in forum BlackBerry Curve 83xx
    Replies: 0
    Last Post: 12-02-08, 04:34 PM
  4. Accepting you have a problem is the first step
    By m.wolfgang in forum BlackBerry Curve 83xx
    Replies: 4
    Last Post: 07-11-08, 12:32 AM
  5. I have a problem installing the 8800 CD...
    By chill636 in forum BlackBerry 8800, 8820
    Replies: 5
    Last Post: 06-12-07, 03:43 PM