1. B11zzard's Avatar
    Hey community,
    Here I am once again in need of your awesome help
    So I got a Z30 around half a year ago and I absolutely love this phone Never had any issues.. well until now :S

    So just a couple of minutes ago my phone stopped to rotate into landscape mode. I tried testing the sensor with BBVE and also in there the motion sensor doesn't work anymore. Actually the only thing happening in BBVE when I try to test the sensor, is that it's telling me to put the phone vertically all the time until I stop the test.

    Since than I tried to restart my phone and do the reset using the volume up and down keys.
    What may be interesting is, that the screen rotates in Apps that work in landscape mode (e.g. BlackBerry Express when presenting)
    Other than that my screen won't rotate in e.g. videos, photos or writing texts.
    And no I don't have the rotation lock activated
    I would really appreciate any help and thank you in advance

    My OS is 10.3.0.738 and I have not had any issues with it yet

    Awesome = Z30
    12-07-14 05:22 PM
  2. Himanagendra Janjanam's Avatar
    Try the latest leak or better wait for the official release

    Posted via CB10
    12-07-14 05:26 PM
  3. B11zzard's Avatar
    Try the latest leak or better wait for the official release

    Posted via CB10
    Hmm maybe I should, it's just bothering me that it happened all of a sudden, after not having any problems for such a long time

    Awesome = Z30
    12-07-14 05:27 PM
  4. Himanagendra Janjanam's Avatar
    Actually I had the 10.3.1.1154.
    Beginning it was fine.
    But after installing call recorder I some trouble. So I went back to 10.2.
    10.3 is awesome
    Soo,try the latest leak or roll back to 10.2
    Posted via CB10
    12-07-14 05:31 PM
  5. B11zzard's Avatar
    Yes I like it as well that's why I would prefer not to go back I also searched the Internet and there seem to be other people with similar problems, but I have yet to find a solution :S

    Awesome = Z30
    12-07-14 05:33 PM
  6. silversmith75's Avatar
    Just restart you phone that fixes that issue a lot of time.

    Posted via CB10
    12-07-14 06:29 PM
  7. B11zzard's Avatar
    Just restart you phone that fixes that issue a lot of time.

    Posted via CB10
    Yes I had already done that twice but it didn't help before. So I simply turned the phone off for the entire night and now it seems to work again

    Awesome = Z30
    12-08-14 02:27 AM
  8. cycle_wala's Avatar
    Yes I had already done that twice but it didn't help before. So I simply turned the phone off for the entire night and now it seems to work again

    Awesome = Z30
    This really sounds like a hardware failure. Revert to official os and send it for repairs.

    Posted via CB10
    12-08-14 02:45 AM
  9. B11zzard's Avatar
    This really sounds like a hardware failure. Revert to official os and send it for repairs.

    Posted via CB10
    Well I think I'm going to give it another chance now, that it's working again, but if it happens again I will go with your option

    Awesome = Z30
    12-09-14 01:11 AM
  10. Himanagendra Janjanam's Avatar
    Try the new leak instead.
    New leak is fine

    Posted via CB10
    12-09-14 05:12 AM
  11. B11zzard's Avatar
    Alright let's go BlackBerry!

    Awesome = Z30
    12-09-14 07:35 AM
  12. Himanagendra Janjanam's Avatar
    Wt happened??
    Rolling back or using 10.3

    Posted via CB10
    12-09-14 12:41 PM
  13. B11zzard's Avatar
    Hey so it seems it's not clear how the problem continued or actually was solved and I really do appreciate your information in what has been going on.

    So quite some time back I posted this :
    Yes I had already done that twice but it didn't help before. So I simply turned the phone off for the entire night and now it seems to work again

    And basically that's it For now I'm still staying with my current Version of 10.3 and I think I'm going to wait for the official release to be my next upgrade.

    I don't really know what exactly solved the problem, but in my case just turning the phone off for a longer period of time (over night in my case) seemed to work for me. Anyways thank you all for your advice and keep on enjoying your BlackBerry!!

    Awesome = Z30
    12-16-14 04:59 PM
  14. bd69's Avatar
    Well, I'll try that then. Mine doesn't rotate anymore either...

    Posted via CB10
    12-17-14 05:48 AM
  15. moody's Avatar
    Interesting. I have noticed there a a few instances when mine won't rotate either.

    Here I thought it was just the photos or page I was viewing was locked. Never thought it might be my phone. Especially when it works most of the time.

    I am.... Mrs Peevishlicious
    12-17-14 06:19 AM
  16. B11zzard's Avatar
    Interesting. I have noticed there a a few instances when mine won't rotate either.

    Here I thought it was just the photos or page I was viewing was locked. Never thought it might be my phone. Especially when it works most of the time.

    I am.... Mrs Peevishlicious
    Yes when mine stopped working I couldn't believe it as well, since it's perfectly fine most of the time. But as long as everything gets back to how it used to be I can live with some issues ever once in awhile

    Awesome = Z30
    12-17-14 05:12 PM
  17. B11zzard's Avatar
    Well, I'll try that then. Mine doesn't rotate anymore either...

    Posted via CB10
    Yes definitely try it Maybe I should also mention that I took my phone and shook it quite hard when it was turned off, just in case something inside the sensor got stuck or something.. Most likely it's not what helped after all(I don't even know how those sensors work) but I figured I could might as well mention it. So if turning your device off for a longer period of time doesn't help you can try it out.

    P.S: don't tell me I'm stupid I already know that ^^

    Good luck mate!

    Awesome = Z30
    moody likes this.
    12-17-14 05:16 PM
  18. bd69's Avatar
    B11zzard, no luck on your solution...funny thing is that the animation of the compass does follow the tilting and lifting of the device. That seems to suggest that the sensor itself still is functioning and that the problem might be due to a software bug...right?

    Posted via CB10
    12-18-14 06:36 PM
  19. B11zzard's Avatar
    B11zzard, no luck on your solution...funny thing is that the animation of the compass does follow the tilting and lifting of the device. That seems to suggest that the sensor itself still is functioning and that the problem might be due to a software bug...right?

    Posted via CB10
    Hmm that is weird...
    Honey I don't know what you can do but since the Sensor itself seems to work it could indeed be a software problem. Which Version are you running? Maybe try up / downgrading. Have you tried the BlackBerry Virtual Expert Application to check if your sensor works? Wish you good luck!

    Awesome = Z30
    12-20-14 08:24 PM
  20. bd69's Avatar
    I think I prefer "mate" over "honey", but that aside, the security wipe was needed to do the trick. Thanks for thinking along. Cheers hon.

    Posted via CB10
    moody likes this.
    12-21-14 07:02 PM
  21. B11zzard's Avatar
    I think I prefer "mate" over "honey", but that aside, the security wipe was needed to do the trick. Thanks for thinking along. Cheers hon.

    Posted via CB10
    Nice! Glad it worked out for you in the end, "mate"

    Awesome = Z30
    12-23-14 04:58 PM

Similar Threads

  1. My Z30 running android apps very slow!!
    By Easypants in forum BlackBerry 10 OS
    Replies: 8
    Last Post: 12-15-14, 04:34 PM
  2. Need Z30 HELP adding mobile # to e xisting contact.
    By tcherewka in forum Ask a Question
    Replies: 6
    Last Post: 12-08-14, 01:42 PM
  3. Does Here Drive work on a Z30?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-14, 04:28 PM
  4. File system failed SD Card - BlackBerry z30
    By Francesco Bontempo in forum Ask a Question
    Replies: 3
    Last Post: 12-07-14, 03:02 PM
  5. Can I use a prepaid credit card for apps on Playbook?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-14, 09:47 AM
LINK TO POST COPIED TO CLIPBOARD