1. CrackBerry Question's Avatar
    I have my z30 for 3 years now, I was still able to use it awhile ago. I plugged in in for charging then when I needed to use it, (since it was locked, i had to swipe up) but no response so i pushed the locked button but still no response. I connected the charger and the screen went alive and it's really charging (almost 60% battery) but the touch screen and the buttons are still not working. So i cant do soft reset coz the button is not working also.

    What do i do (
    04-22-17 12:26 AM
  2. Jerome Cuevas's Avatar
    This is still me btw:
    I asked my friends to call my phone and apparently it won't connect. The texts are not being received either.
    04-22-17 12:30 AM
  3. Lostboy5151's Avatar
    Hold down the ON/OFF button for as long as it takes for the red light to appear (about 5-15 seconds)
    Chances are you upgraded, downloaded or updated something. Whenever you do this you should always reboot. It's needed (more than not) to complete an installation. You should reboot your device once a day in any case.

    Give this a shot.
    04-22-17 12:49 AM

Similar Threads

  1. Favorite earphones don't work on PP
    By markmall in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 04-27-17, 10:39 AM
  2. Replies: 12
    Last Post: 04-26-17, 03:21 PM
  3. Blackberry Priv and Zen 2 Watch no blue tooth link
    By Dusty Boy in forum BlackBerry Priv
    Replies: 4
    Last Post: 04-24-17, 07:04 PM
  4. Reply me dev team and testing team
    By Manimaran 279 in forum BlackBerry Q10
    Replies: 2
    Last Post: 04-22-17, 05:47 AM
  5. So long z30, it's been fun!
    By markf in forum BlackBerry Z30
    Replies: 2
    Last Post: 04-21-17, 08:09 PM
LINK TO POST COPIED TO CLIPBOARD