1. CrackBerry Question's Avatar
    I am using Blackberry z10 from last 2 years. From last one month, its loosing network frequently, showing "emergency calls only" message and Cross sign. It comes back in 20-30 seconds.

    Missing many calls due to this, also not able to make the calls and during call phone gets disconnected...

    One of my friend facing the same issue. we both bought phone at the same time and now facing the issue at the same time

    In same area, other phones with same network (airtel) works just fine. I wonder its the problem with software or hardware.

    Model: STL100-1
    Software: 10.3.2.2474
    01-25-16 12:26 AM
  2. jaydee5799's Avatar
    more than likely its the software. have you tried reloading it?
    01-25-16 05:46 AM
  3. raino's Avatar
    Under Settings>Networks and Connections>Mobile Network, try setting Network Mode to just 2G. See if that stops signal loss.

    And when you say non-Z10 phone owners aren't seeing this problem, what kind of phones do they have:

    4G capable phones? If so, have they made any calls in front of you while you were experiencing network signal loss?
    Any other BB10 phone owners?
    01-25-16 03:38 PM
  4. paulwallace1234's Avatar
    Sounds similar to my Z30 after the 10.3.2 update, the Radio is awful on 10.3.2

    Posted via CB10
    01-25-16 05:24 PM
  5. manish2410's Avatar
    more than likely its the software. have you tried reloading it?
    Yeah, I reloaded the software and still the same problem.
    01-27-16 04:03 AM
  6. manish2410's Avatar
    Under Settings>Networks and Connections>Mobile Network, try setting Network Mode to just 2G. See if that stops signal loss.

    And when you say non-Z10 phone owners aren't seeing this problem, what kind of phones do they have:

    4G capable phones? If so, have they made any calls in front of you while you were experiencing network signal loss?
    Any other BB10 phone owners?
    No 4G, its 3G only for now.
    Also all others are having non BB phone, android or windows. And there is no network loss. whereas for both of us (having z10 phones) its loosing the network completely and showing emergency calls only.

    Will try to switch to 2G.
    01-27-16 04:05 AM
  7. manish2410's Avatar
    Sounds similar to my Z30 after the 10.3.2 update, the Radio is awful on 10.3.2

    Posted via CB10
    Yeah, I think so, because i am seeing this problem from last month or so.
    01-27-16 04:08 AM
  8. rthonpm's Avatar
    Have you tried re-seating the SIM?

    Posted via CB10
    01-27-16 05:43 AM
  9. manish2410's Avatar
    No 4G, its 3G only for now.
    Also all others are having non BB phone, android or windows. And there is no network loss. whereas for both of us (having z10 phones) its loosing the network completely and showing emergency calls only.

    Will try to switch to 2G.
    Switched to 2G, and its working fine and smooth. Thanks

    But in the time of 4G, going from 3G to 2G is bad for me..

    Here in Jaipur(india) having connectivity issue, as location chagnes network switches from 3G to 2G many a times. I guess after recent updates Blackberry is not able to switch to 2G option when loosing 3G network (even after having 3G+2G settings in Mobile network). Whereas other phones do the same.

    Switching to 2G no network loss and atleast i am not missing any calls. Only problem is when you want to use internet when you dont have WIFI (luckily i have Wifi at home and office both )

    Thanks for solution. Hoping the fix in next update...
    01-29-16 03:11 AM
  10. manish2410's Avatar
    Have you tried re-seating the SIM?

    Posted via CB10
    Yes, i did that.
    01-29-16 03:11 AM
  11. raino's Avatar
    Switched to 2G, and its working fine and smooth. Thanks

    But in the time of 4G, going from 3G to 2G is bad for me..

    Here in Jaipur(india) having connectivity issue, as location chagnes network switches from 3G to 2G many a times. I guess after recent updates Blackberry is not able to switch to 2G option when loosing 3G network (even after having 3G+2G settings in Mobile network). Whereas other phones do the same.

    Switching to 2G no network loss and atleast i am not missing any calls. Only problem is when you want to use internet when you dont have WIFI (luckily i have Wifi at home and office both )

    Thanks for solution. Hoping the fix in next update...
    Well, when it comes to the STL100-1, 4G is irrelevant--the phone is just not capable of it.

    But 3G to 2G hand-offs (and vice-versa) should be happening smoothly. If I was in your shoes and experiencing this issue, it would be a big enough deal to have me manually downgrade my OS back to whatever the last build was. So consider an OS downgrade.
    01-29-16 11:17 AM

Similar Threads

  1. Replies: 5
    Last Post: 01-26-16, 03:14 AM
  2. No mobile network
    By Luke Antwi in forum Ask a Question
    Replies: 2
    Last Post: 01-25-16, 03:41 PM
  3. Google sign in for Clash of Clans for BlackBerry Z10?
    By CrackBerry Question in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 01-25-16, 03:48 AM
  4. Is it possible to root my BB Z10/30 and install AndroidOS on it?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 01-24-16, 08:03 PM
LINK TO POST COPIED TO CLIPBOARD