1. CrackBerry Question's Avatar
    Freeeeeeeze screens. Constantly
    02-08-17 11:33 PM
  2. Bla1ze's Avatar
    Based on what little info you gave, hard to help you.
    02-08-17 11:42 PM
  3. Dunt Dunt Dunt's Avatar
    If you have a browser that allows it....

    1) Use an Ad Blocker
    2) Disable running scripts
    3) Block all images from this domain

    And pages will load fast with no issues at all.

    That said, the site is supported by ad revenues, if you don't support it in that way...
    02-09-17 07:46 AM
  4. howarmat's Avatar
    no issues with freezing here
    02-09-17 07:54 AM
  5. mrfreeze's Avatar
    no issues with freezing here
    No issue here either.

    CB is the best website ever!
    02-09-17 09:05 AM
  6. Uzi's Avatar
    Are you using bb10 browser?

    Posted via CB10
    02-09-17 09:10 AM
  7. JAS0NB0URNE's Avatar
    No issue here either.

    CB is the best website ever!
    If even mrfreeze has no issues with freezing, I think you should be good

    Posted with my  Classic
    02-09-17 11:34 AM
  8. mrfreeze's Avatar
    If even mrfreeze has no issues with freezing, I think you should be good

    Posted with my  Classic
    Exactly!
    02-09-17 11:48 AM
  9. zephyr613's Avatar
    I thought Kevin said no ads for the Anniversary month?

    I am running ad-blocker anyway..
    02-09-17 11:57 AM
  10. thurask's Avatar
    I thought Kevin said no ads for the Anniversary month?

    I am running ad-blocker anyway..
    Ads might be off, but UBlock Origin and Ghostery are still picking up trackers.
    zephyr613 likes this.
    02-09-17 12:18 PM
  11. Bla1ze's Avatar
    Ads might be off, but UBlock Origin and Ghostery are still picking up trackers.
    Right, analytic trackers are still running. Plus, OP never mentioned if he was logged in and I'm assuming not since they seemingly don't have an account. Ads are only off for logged in users.
    zephyr613 likes this.
    02-09-17 12:30 PM
  12. zephyr613's Avatar
    Thank yo gentlemen (using that term very loosely)
    02-09-17 12:41 PM
  13. JuiciPatties's Avatar
    Surprised Bla1ze even responded to this message. The title of the post looks like s/he was loading up for battle (Bring in da choppers). Perhaps Bla1ze wanted release some steam.
    02-09-17 01:16 PM
  14. mrfreeze's Avatar
    Surprised Bla1ze even responded to this message. The title of the post looks like s/he was loading up for battle (Bring in da choppers). Perhaps Bla1ze wanted release some steam.
    Bla1ze is always up for battle.
    02-09-17 01:20 PM
  15. to boldly go's Avatar
    OK its me not you, if other people are not having a problem. Here's my latest detailed explanation:
    Z30, using Zeus (might have been stock browser when I posted, but it's usually Zeus or I switch to Browsie with the hatches battened when I remember or am having a bad day.)

    Which device I use does vary with no apparent difference but for now on Z30. And sometimes, like this morning, no problem at all except the person's name and icon in all replies after the first section of ads disappears for the rest of the thread, a new problem.

    I have posted in frustration about this site many times before, and yes I was extremely frustrated when posting this new thread. Things were freezing up so bad I couldn't do anything, seems to be more severe when trying to post, and the forum makes 'corrections' as I type, highlighting and cutting and then freezing up and THEN pasting two or three letters at a time, often having to do with when I tyoe the letter 'i' as the first letter of a word, it changes it to 'I' and proceeds to freeze snd cut and paste as described. So ALMOST ALWAYS, I type my words in my text program and then paste the finished post in here. Seriously.

    This post's replies indicating other people are NOT having a problem is interesting, because I usually hear agreement that the problem is with the site, so it must be me and my BB10's...

    Today I typed my entire reply here with no problem, so the Gremlins are sleeping.

    I see a couple typos but the cursor box leaps around and won't let me maneuver back through the post so I am hitting SEND while I can and must leave. Thanks!
    02-10-17 10:10 AM

Similar Threads

  1. Replies: 17
    Last Post: 10-22-17, 07:43 AM
  2. What's Your Favorite BlackBerry of ALL TIME?
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 9
    Last Post: 02-11-17, 09:38 PM
  3. my z3 is unlocked but sim not detected
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 02-08-17, 11:22 PM
  4. Anyone else find 10.3.3 runs slower than 10.3.1?
    By shawnreum in forum BlackBerry Passport
    Replies: 2
    Last Post: 02-08-17, 11:21 PM
  5. Promity sensor is not working
    By baby_dinesh in forum BlackBerry Z10
    Replies: 1
    Last Post: 02-08-17, 12:18 PM
LINK TO POST COPIED TO CLIPBOARD