1. CrackBerry Question's Avatar
    When i plug in my z10 to charge it wont turn on , no red light, when i plug it in the computer there isnt any devices connected, when i plug it in without the battery theres a red light, i tried holding all those buttons and ish, i tried autoloader and blackberry link but my device cant connect, i have no warranty aswell so someone help me out.
    11-17-14 08:08 PM
  2. SnapzGEG's Avatar
    Random guess is that you have a dead logic board.
    11-17-14 09:07 PM
  3. Jimberry Storm's Avatar
    Might be your battery, but first try this. Take out the battery, put it on the charger, insert battery while on charger see if that does the trick. If it doesn't buy a battery from amazon or ebay they can be cheap, before you just scrap it. Or see if anyone you know, or your carrier can swap a batteyr for you to see if that is the issue.
    11-18-14 10:24 AM

Similar Threads

  1. Asphalt 8 help
    By bluexxx in forum BlackBerry Z10
    Replies: 17
    Last Post: 11-25-14, 10:33 PM
  2. I bought a brand new black Z10 today
    By DenimAndLeather in forum BlackBerry Z10
    Replies: 6
    Last Post: 11-18-14, 08:33 PM
  3. Z10 charger bundle not charging to 100%
    By Diogo Cardoso in forum Ask a Question
    Replies: 2
    Last Post: 11-17-14, 09:38 PM
  4. Thoughts on BlackBerry Passport as hardcore BlackBerry user.
    By EnginDOGN in forum BlackBerry Passport
    Replies: 2
    Last Post: 11-17-14, 07:06 PM
  5. This week only - Passport on 2 year contract $150 at Telus
    By ALToronto in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 11-17-14, 06:12 PM