1. ftowhidi's Avatar
    I had an update last night and my Priv didn't turn on after the update. It was hot, left it charging until morning and it was still hot. Pressed the power button for about 20 seconds and it turned back on. But my question is why phone is not turning on after the update? Will there be a fix for this issue soon?
    06-07-17 08:52 AM
  2. FF22's Avatar
    I had an update last night and my Priv didn't turn on after the update. It was hot, left it charging until morning and it was still hot. Pressed the power button for about 20 seconds and it turned back on. But my question is why phone is not turning on after the update? Will there be a fix for this issue soon?
    Welcome to Crackberry.

    But first let me clarify - your Priv is now acting fine?

    As for what happened during and after the update - a lot of things are happening. It is updating a bunch of OS modules, it is writing and deleting files and chunks of the OS. So, during updates it does tend to get hot. As for why it than stalled - sometimes odd things happening and it needs the help of a reboot or Power cycle. It does not happen often but it does happen. Mine rebooted during the process and when I returned to it, it was working normally. But someone else reported in another thread that they had to reboot it 3 times. Why - only the "computer" (the phone) knows but it does happen.

    Again, I hope your Priv is acting/working fine now. Some folks actually will do another reboot after the normal process.

    Again, Welcome to CB.
    ftowhidi likes this.
    06-07-17 09:50 AM
  3. ftowhidi's Avatar
    Thanks for the reply,
    Yes my Priv seems to be ok, as I was able to turn it on after pressing the power key for about 20 second before posting this question. I just wanted to know why that happens which apparently there is no answer to that
    I had this phone for about 8 months and this was the first time I saw this issue and was really scared at first!
    06-07-17 12:11 PM

Similar Threads

  1. emails not updating
    By pcares in forum Ask a Question
    Replies: 2
    Last Post: 06-27-17, 10:54 AM
  2. How to update to 6.0 [Help]
    By dogukanuck in forum BlackBerry Bold 9700
    Replies: 11
    Last Post: 06-11-17, 12:19 AM
  3. System Update option missing
    By killarneygetaway in forum BlackBerry KEYone
    Replies: 5
    Last Post: 06-10-17, 09:55 AM
  4. Anti-virus required on K1?
    By Ad Bosch in forum BlackBerry KEYone
    Replies: 5
    Last Post: 06-07-17, 07:23 AM
  5. why all android apps didnt work on my BlackBerry classic?
    By walexzboy in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 06-07-17, 04:14 AM
LINK TO POST COPIED TO CLIPBOARD