1. JF Sabourin1's Avatar
    Help please...seems like my Z30 isn't recognized by the PC. Link does't see it when I plug it in although the phone is charging.
    It was able sync wirelessly...until I checked the box on Link to force the USB connection (bad idea as I can't un-check it anymore).
    My old Z10 and Z30 always worked as they should. Seems like my new Z30 doesn't.
    I rebooted Z30 and PCs, reinstalled Link. Tried it on 2 different computers (Dell w/Windows 7, Surface Pro2 w/W8.1)...same issue.

    When I first got the phone last week, it seems like it was recognized once by the Dell-Win7 computer although I had an error among the 3-4 steps it goes through when installing the driver...didn't recognize it since then.

    I have a Z30 STA100-5
    Software release
    10-20-14 03:29 PM
  2. Carl Estes's Avatar
    Make sure you are using the data cable, not a charging cable. Not created equal.
    And try a different USB port so it looks for the new address.
    10-20-14 03:34 PM
  3. JF Sabourin1's Avatar
    Thank you for the reply. I tried many different USB cables (including the one that I used to connect the Z10 last week) and all available ports!!! No success. This is very frustrating as it seems to be the only way to install Snap or even try 10.3
    10-20-14 08:10 PM
  4. Warlack's Avatar
    Did you try the settings in "storage and access"?
    Why isn't my New Z30 being recognized by Link/Windows?-img_20141021_052808.png

    Posted via CB10
    10-20-14 11:28 PM
  5. muellerto's Avatar
    You must be sure to switch the use of BB Link ON and the use of USB OFF in the mass storage settings of your device. (This is indenpendent from the screen shot above. There's another option on the bottom of this dialog page.) Otherwise the Link software of the PC can't recognize the BB device.
    10-21-14 12:46 AM
  6. zclash's Avatar
    What I did was delete link from my cpu because for some reason it wouldn't update then installed the newest version from the site.
    All because my z30 wasn't being recognized then (I'm guessing it installed new drivers) and all is fine hope this helps

    Posted via CB10
    10-21-14 12:49 AM
  7. JF Sabourin1's Avatar
    Well, it finally connected. Not sure why. I tried using the same cable, same USB port.
    What I did different was to first plug in my old Z10 (after reinstalling Link) which was recognized and installed drivers automatically. Unplugged it and plugged in the Z30. And voila! Z30 was recognized.
    Maybe my PC just needed a good night sleep.
    I'm puzzled but I was finally able to install both Snap store and the Pebble app!!!
    zclash likes this.
    10-21-14 02:13 PM
  8. Warlack's Avatar
    Great to hear!

    Posted via CB10
    10-21-14 02:38 PM

Similar Threads

  1. Blackberry Passport - Unlocked - New In Box
    By netwerx1 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 10
    Last Post: 10-23-14, 09:51 AM
  2. LINE app Z30
    By gp2002 in forum BlackBerry Z30
    Replies: 7
    Last Post: 10-21-14, 12:51 AM
  3. New feature - Auto "Meeting Mode" in
    By 3rdStone in forum BlackBerry Z10
    Replies: 2
    Last Post: 10-20-14, 04:13 PM
  4. How do I set up my Z30 to use my micro SD Card as the default storage?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-20-14, 03:31 PM