1. CrackBerry Question's Avatar
    For the past 9 months my Passport has always given me long battery life. Today with no change that I am aware of my battery was in the red in 4 hours. Any ideas, suggestions?
    03-24-16 12:45 AM
  2. ronfc's Avatar
    Restart your device.
    03-24-16 01:06 AM
  3. Tamquam Leo Rugiens's Avatar
    Am having the same problem with my Z30. Every day I use less than 60% of my battery charge, then suddenly today it drained in just six hours doing nothing much, I estimate I was using 1% every ten minutes at one point. The unit was noticeably hot to the touch. I did reboot it several times, but still the same. Looking at battery usage it tells me 56% is being used by Standby; System is jumping from 48% to 72%. How can I figure out what the vampire app is?
    03-24-16 01:24 AM
  4. ronfc's Avatar
    Am having the same problem with my Z30. Every day I use less than 60% of my battery charge, then suddenly today it drained in just six hours doing nothing much, I estimate I was using 1% every ten minutes at one point. The unit was noticeably hot to the touch. I did reboot it several times, but still the same. Looking at battery usage it tells me 56% is being used by Standby; System is jumping from 48% to 72%. How can I figure out what the vampire app is?
    When this happens, most of the time it's not an app but the System itself. If it doesn't resolved in doing a reboot, you may probably want to reload your OS.
    03-24-16 12:05 PM
  5. Tamquam Leo Rugiens's Avatar
    A few weeks before this problem turned up I had installed Google Play. Just before it went haywire It was updating various Google apps. So I uninstalled Google Play Store and rebooted. Situation back to normal for about eight hours, the battery consumption surged again. Rebooted, all well for about eight hours again, then battery suck again.

    It has been a few days now, and every time I reboot normal battery use ensues for increasingly extended periods of time. Weird. I used to not reboot for months at a time. But at least I have a workaround until the latest version of the OS filters down to me. I'd hate to replace my Z30, it is a fine product that meets my needs almost perfectly. The only thing I don't care for is that I can't customize the timer alarm - that meek beep just doesn't cut it.
    04-04-16 09:01 PM
  6. ronfc's Avatar
    I used to not reboot for months at a time.
    Any type of computing devices needs a reboot. As HTG Explains:
    In all cases, a restart wipes away the current state of the software . Any code that’s stuck in a misbehaving state will be swept away, too. When you restart, the computer or device will bring the system up from scratch, restarting all the software from square one so it will work just as well as it was working before.
    04-05-16 07:19 PM
  7. mruckus's Avatar
    Havong same issue with my Z30. Attached is a photo pf the usage I just screen captured. Does reloading OS mean losing phone contacts, losing saved data, having to reinstall apps, etc.? And how do we reload OS?

    Posted via CB10
    04-13-16 01:13 AM
  8. mruckus's Avatar
    Oops attachment did not work, but says "system" was using 59%

    Posted via CB10
    04-13-16 01:14 AM
  9. mruckus's Avatar
    Why did my battery life suddenly drop from 40 hrs to 5?-img_20160413_005350.png
    Why did my battery life suddenly drop from 40 hrs to 5?-img_20160413_005604.png

    Posted via CB10
    04-13-16 01:28 AM
  10. TopFit's Avatar
    All problems with a system task that got stuck at ~20% CPU usage was due to some Android Apps and mainly the Amazon Appstore. I disabled the Amazon Appstore (security settings -> "youth protections setting" - may differ in your language).

    You should keep checking the system monitor for CPU usage after you open and close every App you use, to find out if there is one, that will leave the system task at ~20%. Normal system tastk CPU usage should be around 2-7% when you are not using the phone.
    04-13-16 04:17 AM
  11. mruckus's Avatar
    The problem is that some Android apps require the Amazon appstore to operate, so does disabling it prevent them from working? I jist tried disabling "run when minimized" for almost all apps except BlackBerry apps that have hub notifications to see if that helps with battery drainage. I see that CPU for "system" still hovers around 20% though.

    Posted via CB10
    04-13-16 07:05 AM
  12. mruckus's Avatar
    I closed all apps in the CPU device manager screen that I was able to from there and nothing changed.
    Why did my battery life suddenly drop from 40 hrs to 5?-img_20160413_071242.png

    Posted via CB10
    04-13-16 07:14 AM
  13. TopFit's Avatar
    I closed all apps in the CPU device manager screen that I was able to from there and nothing changed.


    Posted via CB10

    You need to hard reset the phone after you close all the apps. Otherwise you won't be able to find out what App is causing this system cpu usage. After the reboot wait until the system task went down to 3-7% cpu usage. After that you can start to find out what App is causing this problem.
    04-13-16 08:27 AM
  14. mruckus's Avatar
    Thanks! Just did a hard reset and didn't make any difference. "System" (what is that? Just the OS in general?) still sucks up a lot.
    Why did my battery life suddenly drop from 40 hrs to 5?-img_20160413_090306.png

    Posted via CB10
    04-13-16 09:04 AM
  15. TopFit's Avatar
    Thanks! Just did a hard reset and didn't make any difference. "System" (what is that? Just the OS in general?) still sucks up a lot.


    Posted via CB10
    That is weird. There are several threads with people having crazy CPU usage on their devices. Seems like a major bug that only appears in certain constellations.

    Did you open any apps after the reboot ? How long after the reboot was this screenshot taken ?

    If this is your CPU usage right after a reboot and it will not change after a few minutes, I guess you should try to wipe the device next and monitor if there are any changes after you install each app you need.
    04-13-16 09:43 AM
  16. Lusitano17's Avatar
    That is weird. There are several threads with people having crazy CPU usage on their devices. Seems like a major bug that only appears in certain constellations.

    Did you open any apps after the reboot ? How long after the reboot was this screenshot taken ?

    If this is your CPU usage right after a reboot and it will not change after a few minutes, I guess you should try to wipe the device next and monitor if there are any changes after you install each app you need.
    "Major bug" is likely android based.
    PIM services are up so it might be an account (email etc) that's been added and is leeching system. Hard reboot often resolves this but if OP doesn't have the patience to selectively disable or remove apps then as suggested a reload or wipe might help.
    04-13-16 11:07 AM
  17. TopFit's Avatar
    "Major bug" is likely android based.
    PIM services are up so it might be an account (email etc) that's been added and is leeching system. Hard reboot often resolves this but if OP doesn't have the patience to selectively disable or remove apps then as suggested a reload or wipe might help.
    I also think it's an Android problem. That's why I ditched the Amazon Appstore and only use Android Apps I know are working. I had the same problems before.

    Posted via CB10
    04-13-16 11:39 AM
  18. mruckus's Avatar
    It is the same email accounts I had before I ever installed any Android apps.

    My phone keeps stalling too when I have apps open (whether BlackBerry pr Android).. getting really annoying. The other day, I had the native BlackBerry maps app open to use the GPS and search for where I was going.. froze for a minute or two as I was in the car (also had the BlackBerry browser open to stream some music). Just now, had Nemory instagram and BlackBerry whatsapp open and everything stalled.

    Posted via CB10
    04-16-16 10:31 AM
  19. TopFit's Avatar
    It is the same email accounts I had before I ever installed any Android apps.

    My phone keeps stalling too when I have apps open (whether BlackBerry pr Android).. getting really annoying. The other day, I had the native BlackBerry maps app open to use the GPS and search for where I was going.. froze for a minute or two as I was in the car (also had the BlackBerry browser open to stream some music). Just now, had Nemory instagram and BlackBerry whatsapp open and everything stalled.

    Posted via CB10
    You have huge system CPU usage, so the OS will have problems running apps normally. Same with every OS that has not enough CPU resources.

    What irritates me, is the fact that you have high CPU usage after a reboot without starting any apps.

    How are your email account settings regarding the amount of emails that synchronised with your phone? I had two accounts and for one of them I set the peroid to sync to 'all'. That slowed down my HUB and the overall system performance to the extent that I set it back to the last 30 days. You could try to change these settings.

    Did you already wipe your device and start from the beginnging?





    Posted via CB10
    04-17-16 05:49 PM

Similar Threads

  1. Replies: 27
    Last Post: 05-18-16, 11:09 AM
  2. How do I transfer a downloaded file to my computer?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 03-24-16, 07:13 PM
  3. Deactivating the HUB does not improve priv battery life
    By ReSeanRussell in forum BlackBerry Priv
    Replies: 5
    Last Post: 03-24-16, 04:35 PM
  4. Is there quicker way to call a contact on the Blackberry Priv?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-23-16, 08:06 PM
  5. Can anyone explain why the Facebook app stopped working please?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-23-16, 07:25 PM
LINK TO POST COPIED TO CLIPBOARD