1. Samundae's Avatar
    Store gave me a new sim still the same problem. Sim works in my Z10. This happened after I tried a T-MOBILE sim in my phone. I've wiped it and it's still not recognizing sim. Help please
    04-01-16 10:47 PM
  2. raino's Avatar
    Weird. Have you checked Network Mode settings to make sure they match LTE/CDMA as described here: Network Mode Settings - BlackBerry Q10 | Verizon Wireless

    I doubt that's what it is, but that's all I've got at the moment. If this doesn't help, maybe someone else has a better suggestion.
    04-01-16 11:16 PM
  3. Samundae's Avatar
    Thanks I'll try that and see if it works.
    04-01-16 11:18 PM
  4. Samundae's Avatar
    Wouldn't let me select any options. Got an error message saying sim card wasn't detected. Go to sim card settings. Couldn't do anything there either.
    04-01-16 11:35 PM
  5. raino's Avatar
    Are you absolutely sure that the SIM card holder/slot hasn't been damaged? Do you still have that TMO SIM card to try?
    04-01-16 11:42 PM
  6. Samundae's Avatar
    I don't think it's damaged. I don't have the T-Mobile sim card. I tried My Nephew's sim.
    04-01-16 11:48 PM
  7. Tamashek's Avatar
    Is that Z30 unlocked?

    Posted via CB30
    04-02-16 08:54 AM
  8. Samundae's Avatar
    It says network unlocked.
    04-02-16 09:04 AM
  9. raino's Avatar
    Yeah, it's unlocked. It's a Verizon LTE phone with band 13, so it has to be. So that's very unlikely to be the issue. Plus, this phone is Verizon and the OP is trying a Verizon SIM card.

    OP--you say you tried your nephew's SIM card. Was that also from Verizon? If so, can you get any non-Verizon SIM card to test? Testing with multiple Verizon SIM cards won't tell us if the problem is with the phone, or something on Verizon's end.
    04-02-16 12:45 PM
  10. Samundae's Avatar
    Got a new sim card tray installed. Still having the same problem. Phone repair place has had my phone for a week. He can't figure it out.
    04-11-16 05:28 PM

Similar Threads

  1. BB Classic - Stays on start screen - will not reboot fully
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 04-02-16, 10:13 AM
  2. Z30 glimpse is sporadic on map
    By Darls999 in forum BlackBerry Z30
    Replies: 1
    Last Post: 04-02-16, 08:27 AM
  3. Why am I not able to use the internet?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 04-02-16, 12:06 AM
  4. Z30 suddenly shuts down itself
    By vergiove in forum Ask a Question
    Replies: 1
    Last Post: 04-01-16, 10:33 PM
  5. Messages not being delivered or received to priv user.
    By antonrr in forum General BBM Chat
    Replies: 1
    Last Post: 04-01-16, 09:57 PM
LINK TO POST COPIED TO CLIPBOARD