1. Jesse Ord's Avatar
    Hey guys. My z10 is having trouble saving pictures recently, I'll take a picture and it won't save to my pictures or be visible in the list of recently taken pictures, this just started happening two days ago. About a week ago I put in a micro SD card and formatted that so I can't see that being the problem. I've tried pulling the battery out but nothing seems to fix this problem. My device manager tells me I've got plenty of space both in the card and in my phones internal memory.

    Any suggestions you guys could give or advice you have would be appreciated. Thanks!

    Posted via CB10
    07-28-14 10:50 PM
  2. herbersh's Avatar
    It is still likely the SD card. Change the setting to save pictures to the device and see if that works.

    Posted via CB10 on the great Z30
    DueNorthBB likes this.
    07-28-14 10:52 PM
  3. Jesse Ord's Avatar
    That worked but it defeats the purpose of having a media card at all.. would formatting the card help this if I've already done it?

    Posted via CB10
    07-28-14 10:59 PM
  4. Jesse Ord's Avatar
    Update: the pictures are saving to the card, they're just not showing up in my directory of photos when I'm in the camera or trying to attach a picture to an sms or email or anything, is there any way I can change this?

    Posted via CB10
    07-28-14 11:04 PM
  5. tex3523's Avatar
    I have had this trouble from time to time. I just performed a re boot and then they would show up. (I did not remove the battery)

    I have no idea why.

    Posted from my awesome Q10
    07-28-14 11:56 PM
  6. John Vieira's Avatar
    Ran into this issue with my Z30 a while back.

    The fix was odd, but worked for me.

    Shut off device.
    Pull SD card out.
    Turn on device.
    Turn off device.
    SD card back in
    Turn on device.

    It's a bit of an odd fix, but it did do the job for me, and it's been good since then.

    Let me know if it works out for you.

    Posted via (hopefully) a passport A10
    07-29-14 12:08 AM
  7. Heinz Katchup's Avatar
    It doesn't save to pictures folder. It saves to camera folder.

    Posted via CB10
    07-29-14 12:11 AM
  8. DueNorthBB's Avatar
    It is still likely the SD card. Change the setting to save pictures to the device and see if that works.

    Posted via CB10 on the great Z30
    I got a cheap MicroSD card and used it on my Z10 for a while. Initially it works fine, but over time it got worse and worse. I wasn't able to record any HD video on it. It would just record a couple of seconds before cutting off.

    So I tested it by record it directly to the device and it works fine.

    I swapped it with a new micro SD card from a more reliable manufacturer (Sandisk in my case) and the problem went away. Did a format when I received it just to make sure all is good.

    Symptoms of problem:
    - Long reading/writing time to the micro SD card
    - HD video cuts off when recording to micro SD card

    Good luck.
    07-29-14 12:23 AM
  9. herbersh's Avatar
    Agree with above. The SD cards often fail. Look for the post discussing SD cards for which ones are recommended.

    Posted via CB10 on the great Z30
    07-29-14 07:53 AM

Similar Threads

  1. Passport pictures collection
    By kamal lyall in forum BlackBerry Passport
    Replies: 286
    Last Post: 12-22-14, 01:16 PM
  2. Functionallity Comparison with Torch
    By JTeale in forum BlackBerry Z10
    Replies: 8
    Last Post: 08-11-14, 06:57 PM
  3. Replies: 3
    Last Post: 07-29-14, 03:00 PM
  4. need help with doa z10
    By silversmith75 in forum Ask a Question
    Replies: 1
    Last Post: 07-28-14, 08:19 PM
  5. Snap2Chat updated with plenty of bug fixes
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 07-28-14, 01:51 PM